summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-08-15 22:05:59 -0700
committerKhem Raj <raj.khem@gmail.com>2024-08-15 23:20:05 -0700
commitbdae51c5841128ed3640f509e076b36411b8fe5b (patch)
tree59e11dbee7c176b8050e6d69291ab2153a4e4fc0 /meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
parent7091189c6f825f3ffa80b4e8126a1bf12f883f52 (diff)
downloadmeta-openembedded-bdae51c5841128ed3640f509e076b36411b8fe5b.tar.gz
python3-kivy: Remove buildpaths from comments in generated C sources
Cython does not provide a direct option to disable or customize the metadata written in the generated C files. The metadata includes information like the Cython version and absolute paths to the original Cython files, which can be problematic for doing reproducible builds Therefore edit out these comments from the cython generated C files they are nicely tucked between two known tags at the top of file. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
index 6bd7ce8ba3..045ac23106 100644
--- a/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
@@ -75,3 +75,10 @@ RDEPENDS:${PN} = " \
75# python3-kivy/2.3.0/git/kivy/graphics/cgl_backend/cgl_gl.c:4568:52: error: assignment to 'void (*)(GLuint, GLsizei, const GLchar **, const GLint *)' {aka 'void (*)(unsigned int, int, const char **, const int *)'} from incompatible pointer type 'void (*)(GLuint, GLsizei, const GLchar * const*, const GLint *)' {aka 'void (*)(unsigned int, int, const char * const*, const int *)'} [-Wincompatible-pointer-types] 75# python3-kivy/2.3.0/git/kivy/graphics/cgl_backend/cgl_gl.c:4568:52: error: assignment to 'void (*)(GLuint, GLsizei, const GLchar **, const GLint *)' {aka 'void (*)(unsigned int, int, const char **, const int *)'} from incompatible pointer type 'void (*)(GLuint, GLsizei, const GLchar * const*, const GLint *)' {aka 'void (*)(unsigned int, int, const char * const*, const int *)'} [-Wincompatible-pointer-types]
76# python3-kivy/2.3.0/git/kivy/core/window/_window_sdl2.c:8781:23: error: passing argument 1 of 'SDL_SetEventFilter' from incompatible pointer type [-Wincompatible-pointer-types] 76# python3-kivy/2.3.0/git/kivy/core/window/_window_sdl2.c:8781:23: error: passing argument 1 of 'SDL_SetEventFilter' from incompatible pointer type [-Wincompatible-pointer-types]
77CFLAGS += "-Wno-error=incompatible-pointer-types" 77CFLAGS += "-Wno-error=incompatible-pointer-types"
78
79do_compile:append() {
80 for f in `find ${B} -name *.c`
81 do
82 sed -i -e "/BEGIN: Cython Metadata/,/END: Cython Metadata/d" $f
83 done
84}