summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.9.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-09-20 10:28:59 +0800
committerKhem Raj <raj.khem@gmail.com>2022-09-21 06:34:45 -0700
commit7450ae51a51c0ac7bea5e31a7526f745fd453b5e (patch)
tree1438c00bef85ffd341e518e61fa59c2728164bb9 /meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.9.bb
parentc5533c184eda62311b7998f61c937df2a5dd2390 (diff)
downloadmeta-openembedded-7450ae51a51c0ac7bea5e31a7526f745fd453b5e.tar.gz
python3-jsonrpcserver: upgrade 5.0.8 -> 5.0.9
Changelog: ========= Remove unncessary package_data from setup.py (#243) Use a custom logger when logging exceptions, not root Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.9.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.9.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.9.bb b/meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.9.bb
new file mode 100644
index 000000000..7e058a757
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonrpcserver_5.0.9.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Library to process JSON-RPC requests"
2HOMEPAGE = "https://github.com/explodinglabs/jsonrpcserver"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=61b63ea9d36f6fb63ddaaaac8265304f"
5
6SRC_URI[sha256sum] = "a71fb2cfa18541c80935f60987f92755d94d74141248c7438847b96eee5c4482"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 python3-apply-defaults \
12 python3-asyncio \
13 python3-core \
14 python3-json \
15 python3-jsonschema \
16 python3-logging \
17 python3-netclient \
18 python3-pkgutil \
19 python3-oslash \
20 python3-typing-extensions \
21"
22
23BBCLASSEXTEND = "native nativesdk"