summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-auth_2.29.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-06-25 16:56:04 +0800
committerKhem Raj <raj.khem@gmail.com>2024-06-27 09:18:58 -0700
commitdc72eb669d11ec8cfeb531c56d74c9e7cb041e11 (patch)
treecb36aa55c07c19918b567520cae07fa9a7c6e529 /meta-python/recipes-devtools/python/python3-google-auth_2.29.0.bb
parentfef867ed04b65d8921bca64f34ae22ef1c33d4a3 (diff)
downloadmeta-openembedded-dc72eb669d11ec8cfeb531c56d74c9e7cb041e11.tar.gz
python3-google-auth: upgrade 2.29.0 -> 2.30.0
Features -------- - Add WebAuthn plugin component to handle WebAuthn get assertion request - ECP Provider drop cryptography requirement - Enable webauthn plugin for security keys Bug Fixes ---------- - Fix id_token iam endpoint for non-gdu service credentials - Makes default token_url universe aware Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-auth_2.29.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth_2.29.0.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-auth_2.29.0.bb b/meta-python/recipes-devtools/python/python3-google-auth_2.29.0.bb
deleted file mode 100644
index e8d438df0..000000000
--- a/meta-python/recipes-devtools/python/python3-google-auth_2.29.0.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1DESCRIPTION = "Google Authentication Library"
2HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "672dff332d073227550ffc7457868ac4218d6c500b155fe6cc17d2b13602c360"
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 python3-cryptography \
16 python3-flask \
17 python3-freezegun \
18 python3-grpcio \
19 python3-mock \
20 python3-oauth2client \
21 python3-pyopenssl \
22 python3-pytest \
23 python3-pytest-localserver \
24 python3-pyu2f \
25 python3-requests \
26 python3-responses \
27 python3-unittest-automake-output \
28 python3-unixadmin \
29"
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
34}
35
36RDEPENDS:${PN} += "\
37 python3-cachetools \
38 python3-json \
39 python3-pyasn1-modules \
40 python3-rsa \
41"