summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-api-core_2.17.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-06 16:43:19 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:22 -0800
commit149b4f4cfb37d8c0fdf2446c88ac99c11086d1f0 (patch)
treef183a02ce76ed455153fcfc6403b968767b65d0f /meta-python/recipes-devtools/python/python3-google-api-core_2.17.1.bb
parent890e6b696242e39a1e65533907048d4a727a93ed (diff)
downloadmeta-openembedded-149b4f4cfb37d8c0fdf2446c88ac99c11086d1f0.tar.gz
python3-google-api-core: upgrade 2.16.2 -> 2.17.1
Changelog: Resolve issue handling protobuf responses in rest streaming Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-api-core_2.17.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-core_2.17.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-core_2.17.1.bb b/meta-python/recipes-devtools/python/python3-google-api-core_2.17.1.bb
new file mode 100644
index 000000000..f9df8cf2a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-core_2.17.1.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Google API client core library"
2HOMEPAGE = "https://github.com/googleapis/python-api-core"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6inherit pypi setuptools3
7
8SRC_URI[sha256sum] = "9df18a1f87ee0df0bc4eea2770ebc4228392d8cc4066655b320e2cfccb15db95"
9
10RDEPENDS:${PN} += "\
11 python3-asyncio \
12 python3-datetime \
13 python3-logging \
14 python3-math \
15"
16
17RDEPENDS:${PN} += "\
18 python3-googleapis-common-protos \
19 python3-google-auth \
20 python3-grpcio \
21 python3-protobuf \
22 python3-pytz \
23 python3-requests \
24 python3-six \
25"