summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gmqtt_0.7.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2024-11-27 13:26:17 +0200
committerKhem Raj <raj.khem@gmail.com>2024-11-27 09:36:52 -0800
commitb0b743f775e14ae27b7b474e613c528b4bbe4813 (patch)
treec6b8acecee02a66f84746ad017fe1113a4fafd68 /meta-python/recipes-devtools/python/python3-gmqtt_0.7.0.bb
parent1f858bb9f1a648a24629425437eba9cd69edddca (diff)
downloadmeta-openembedded-b0b743f775e14ae27b7b474e613c528b4bbe4813.tar.gz
python3-gmqtt: Upgrade 0.6.16 -> 0.7.0
Upgrade to version 0.7.0: - Resend QoS queue only on reconnect, not periodically - Fixed server_keep_alive - Try to use github actions - Fix github actions badge - Added the ability to pass your logger - Properly handle already encoded topics Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gmqtt_0.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gmqtt_0.7.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gmqtt_0.7.0.bb b/meta-python/recipes-devtools/python/python3-gmqtt_0.7.0.bb
new file mode 100644
index 0000000000..f4dfaa345b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gmqtt_0.7.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Client for MQTT protocol"
2HOMEPAGE = "https://github.com/wialon/gmqtt"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=903f1792621a3b35ee546da75d139177"
5
6SRC_URI[sha256sum] = "bedfec7bac26b6b4ce1f0c4c32cff3d663526a54c882d323d41560fc3b9b44a2"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 python3-asyncio \
12 python3-core \
13 python3-datetime \
14 python3-json \
15 python3-logging \
16 python3-netclient \
17"
18
19BBCLASSEXTEND = "native nativesdk"