diff options
author | alperak <alperyasinak1@gmail.com> | 2024-08-09 19:31:01 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-10 15:57:57 -0700 |
commit | 28900899cbe11d429f0ab737ac1f6acf1807fa5e (patch) | |
tree | 14e38ccf0b6bcc2ec95a81aca7c6c3c7603d3fcd /meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb | |
parent | 197c1020ca6b2ad4a37e0e4450ca62d2a4bb9277 (diff) | |
download | meta-openembedded-28900899cbe11d429f0ab737ac1f6acf1807fa5e.tar.gz |
python3-gevent: switch to PEP-517 build backend
The project has a proper pyproject.toml which declares the setuptools.build.meta PEP-517 backend.
Fix:
WARNING: python3-gevent-24.2.1-r0 do_check_backend: QA Issue: inherits setuptools3 but has pyproject.toml with setuptools.build_meta, use the correct class [pep517-backend]
Signed-off-by: alperak <alperyasinak1@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb index 806e093910..e44972178e 100644 --- a/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb +++ b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb | |||
@@ -4,7 +4,7 @@ a high-level synchronous API on top of the libevent event loop." | |||
4 | HOMEPAGE = "http://www.gevent.org" | 4 | HOMEPAGE = "http://www.gevent.org" |
5 | LICENSE = "MIT & Python-2.0" | 5 | LICENSE = "MIT & Python-2.0" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65" |
7 | DEPENDS += "python3-greenlet libev libuv c-ares python3-cython-native" | 7 | DEPENDS += "python3-greenlet-native python3-greenlet libev libuv python3-cython-native python3-cffi-native" |
8 | 8 | ||
9 | RDEPENDS:${PN} = "python3-greenlet \ | 9 | RDEPENDS:${PN} = "python3-greenlet \ |
10 | python3-mime \ | 10 | python3-mime \ |
@@ -18,7 +18,7 @@ SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch \ | |||
18 | 18 | ||
19 | SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056" | 19 | SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056" |
20 | 20 | ||
21 | inherit pypi setuptools3 | 21 | inherit pypi python_setuptools_build_meta |
22 | 22 | ||
23 | # Don't embed libraries, link to the system provided libs instead | 23 | # Don't embed libraries, link to the system provided libs instead |
24 | export GEVENTSETUP_EMBED_CARES = "0" | 24 | export GEVENTSETUP_EMBED_CARES = "0" |