summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-eth-utils_3.0.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-01-23 09:45:18 +0800
committerKhem Raj <raj.khem@gmail.com>2024-01-23 11:55:37 -0800
commit613b9e713a01e89021377cd6629caab8d94df5fd (patch)
treeecf018e780813ac4ef71c74b3b021d647dbf412b /meta-python/recipes-devtools/python/python3-eth-utils_3.0.0.bb
parent6f325c9801e35e13766cf261e1dba3a294575127 (diff)
downloadmeta-openembedded-613b9e713a01e89021377cd6629caab8d94df5fd.tar.gz
python3-eth-utils: upgrade 2.3.1 -> 3.0.0
Changelog: ============ -Drop python 3.7 support -Merge updates from the project template, notably: use pre-commit for linting and change the name of the master branch to main -Correct booleans in pyproject.toml and add test for the presence of the eth_utils.__version__ attribute -Some users were experiencing encoding issues when parsing the networks json. Use UTF-8 explicitly. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-eth-utils_3.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-utils_3.0.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eth-utils_3.0.0.bb b/meta-python/recipes-devtools/python/python3-eth-utils_3.0.0.bb
new file mode 100644
index 000000000..faca03865
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-utils_3.0.0.bb
@@ -0,0 +1,16 @@
1SUMMARY = "Common utility functions for codebases which interact with ethereum."
2HOMEPAGE = "https://github.com/ethereum/eth-utils"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6749008d847c14b9718949c2e24d5c0a"
6
7SRC_URI[sha256sum] = "8721869568448349bceae63c277b75758d11e0dc190e7ef31e161b89619458f1"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-eth-hash \
13 python3-eth-typing \
14 python3-setuptools \
15 python3-toolz \
16"