summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cmd2_1.3.11.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-06 12:05:22 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-07 08:42:52 -0700
commite248c8a5b97b1485b0625c7fd8dd2350bbf12717 (patch)
treeb70c4555e1b9b91bc6228854697b1aa7e723aceb /meta-python/recipes-devtools/python/python3-cmd2_1.3.11.bb
parenta432d526c11b746be3cd9a8882d8765af0188b34 (diff)
downloadmeta-openembedded-e248c8a5b97b1485b0625c7fd8dd2350bbf12717.tar.gz
python3-cmd2: Upgrade 1.3.10 -> 1.3.11
Upgrade to release 1.3.11: - Fixed issue where quoted redirectors and terminators in aliases and macros were not being restored when read from a startup script. - Fixed issue where instantiating more than one cmd2-based class which uses the @as_subcommand_to decorator resulted in duplicated help text in the base command the subcommands belong to. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cmd2_1.3.11.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cmd2_1.3.11.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_1.3.11.bb b/meta-python/recipes-devtools/python/python3-cmd2_1.3.11.bb
new file mode 100644
index 000000000..3b2aa5b74
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cmd2_1.3.11.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Extra features for standard library's cmd module"
2HOMEPAGE = "https://github.com/python-cmd2/cmd2"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9791cd24ca7d1807388ccd55cd066def"
5
6DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
7
8SRC_URI[md5sum] = "7e3dbe0aefa331e80f515d3c41cc3b8c"
9SRC_URI[sha256sum] = "826a288ee6d9c4ec1184e64e9566c09d3b73be8f4283c1898fa4332f1daf8dbf"
10
11inherit pypi setuptools3
12
13RDEPENDS_${PN} += "\
14 ${PYTHON_PN}-attrs \
15 ${PYTHON_PN}-colorama \
16 ${PYTHON_PN}-pyperclip \
17 ${PYTHON_PN}-wcwidth \
18"
19
20BBCLASSEXTEND = "native nativesdk"