summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2024-11-28 12:38:58 +0200
committerKhem Raj <raj.khem@gmail.com>2024-11-28 08:17:56 -0800
commitd9cf8080d230c5d3d842eb4d16764aa76d6eac44 (patch)
treef4c5dd9f3f04778c1a136c8f0515feb78121691f /meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.0.bb
parent1f86c3ba7db07b08caf367ae18a42433552df7ec (diff)
downloadmeta-openembedded-d9cf8080d230c5d3d842eb4d16764aa76d6eac44.tar.gz
python3-charset-normalizer: Upgrade 3.3.2 -> 3.4.0
Upgrade to version 3.4.0: - Argument --no-preemptive in the CLI to prevent the detector to search for hints - Support for Python 3.13 - Relax the TypeError exception thrown when trying to compare a CharsetMatch with anything else than a CharsetMatch - Improved the general reliability of the detector based on user feedbacks - Declared charset in content (preemptive detection) not changed when converting to utf-8 bytes Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.0.bb b/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.0.bb
new file mode 100644
index 0000000000..10f199db49
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "The Real First Universal Charset Detector. Open, modern and actively maintained alternative to Chardet."
2HOMEPAGE = "https://github.com/ousret/charset_normalizer"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0974a390827087287db39928f7c524b5"
5
6SRC_URI[sha256sum] = "223217c3d4f82c3ac5e29032b3f1c2eb0fb591b72161f86d93f5719079dae93e"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "charset_normalizer"
11
12RDEPENDS:${PN} += " \
13 python3-core \
14 python3-logging \
15 python3-codecs \
16 python3-json \
17"
18
19BBCLASSEXTEND = "native nativesdk"