diff options
author | zhengrq.fnst <zhengrq.fnst@fujitsu.com> | 2022-06-02 09:37:46 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-06-01 19:52:12 -0700 |
commit | 01e4f02da8d72d9b2edfb5ff19cecba77932daec (patch) | |
tree | c746110f6eb50faf290f9cdc1741f0fda4ea439d /meta-python/recipes-devtools/python/python3-cachetools_5.2.0.bb | |
parent | 1ebf31315e8c0719f6c1fe3ed29966b401a5a2f9 (diff) | |
download | meta-openembedded-01e4f02da8d72d9b2edfb5ff19cecba77932daec.tar.gz |
python3-cachetools: upgrade 5.1.0 -> 5.2.0
Changelog:
=========
Add cachetools.keys.methodkey().
Add cache_clear() function to decorators.
Add src directory to sys.path for Sphinx autodoc.
Modernize func wrappers.
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cachetools_5.2.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cachetools_5.2.0.bb | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_5.2.0.bb b/meta-python/recipes-devtools/python/python3-cachetools_5.2.0.bb new file mode 100644 index 000000000..35b338ca8 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cachetools_5.2.0.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "Extensible memoizing collections and decorators" | ||
2 | HOMEPAGE = "https://github.com/tkem/cachetools" | ||
3 | DESCRIPTION = "This module provides various memoizing \ | ||
4 | collections and decorators, including variants of the \ | ||
5 | Python 3 Standard Library @lru_cache function decorator." | ||
6 | SECTION = "devel/python" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ec55353c80c662e4255f8889a0ca558" | ||
10 | |||
11 | inherit pypi python_setuptools_build_meta ptest | ||
12 | |||
13 | SRC_URI += " \ | ||
14 | file://run-ptest \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS:${PN} += " \ | ||
18 | ${PYTHON_PN}-math \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS:${PN}-ptest += " \ | ||
22 | ${PYTHON_PN}-pytest \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | install -d ${D}${PTEST_PATH}/tests | ||
27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
28 | } | ||
29 | |||
30 | SRC_URI[sha256sum] = "6a94c6402995a99c3970cc7e4884bb60b4a8639938157eeed436098bf9831757" | ||
31 | |||
32 | BBCLASSEXTEND = "native nativesdk" | ||