summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.11.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-04-28 15:02:30 +0800
committerKhem Raj <raj.khem@gmail.com>2022-05-02 14:12:12 -0700
commit4edfb7ac9f048ce649f9f4bf2aec5864d2cbd098 (patch)
tree2cac791a0d50a9f44715513a44a711f6340578c1 /meta-python/recipes-devtools/python/python3-cachecontrol_0.12.11.bb
parent12df23be74aced544d3025aa3442840561b72acb (diff)
downloadmeta-openembedded-4edfb7ac9f048ce649f9f4bf2aec5864d2cbd098.tar.gz
python3-cachecontrol: upgrade 0.12.10 -> 0.12.11
License-Updated: PKG-INFO changes from "SPDX-License-Identifier: Apache-2.0" to "Classifier: Environment :: Web Environment" Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cachecontrol_0.12.11.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachecontrol_0.12.11.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.11.bb b/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.11.bb
new file mode 100644
index 000000000..fc2b0ae75
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.11.bb
@@ -0,0 +1,29 @@
1SUMMARY = "httplib2 caching for requests"
2HOMEPAGE = "https://pypi.org/project/CacheControl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=12;endline=12;md5=942a721dac34d073453642ffe5fcf546"
5
6# On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to
7# override PYPI_PACKAGE so fetch succeeds.
8PYPI_PACKAGE = "CacheControl"
9
10SRC_URI[sha256sum] = "a5b9fcc986b184db101aa280b42ecdcdfc524892596f606858e0b7a8b4d9e144"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN} += "\
15 python3-crypt \
16 python3-datetime \
17 python3-email \
18 python3-lockfile \
19 python3-json \
20 python3-logging \
21 python3-msgpack \
22 python3-netclient \
23 python3-pickle \
24 python3-requests \
25 python3-urllib3 \
26 python3-mmap \
27"
28
29BBCLASSEXTEND = "native nativesdk"