diff options
author | Derek Straka <derek@asterius.io> | 2023-09-20 16:35:57 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-09-20 22:15:40 -0700 |
commit | 9769c139fd9e5cacfdd983a03f814104a5d12f24 (patch) | |
tree | c4c5e728faffcd514ac1044784faf4b1c852d5b5 /meta-python/recipes-devtools/python/python3-bleak | |
parent | 46c7758a85a98b8998417877b65d3697e2b23aa5 (diff) | |
download | meta-openembedded-9769c139fd9e5cacfdd983a03f814104a5d12f24.tar.gz |
python3-bleak: Update version 0.20.2 -> 0.21.1
Removed a patch the no longer appears to be needed and dropped support for python 3.7
Changelog
=========
0.21.1 (2023-09-08)
Changed
Changed dbus-fast dependency to include v2.x. Fixes #1412.
0.21.0 (2023-09-02)
Added
Added bleak.uuids.normalize_uuid_16() function.
Added bleak.uuids.normalize_uuid_32() function.
Added advertisement_data() async iterator method to BleakScanner. Merged #1361.
Added type hints for kwargs on BleakScanner class methods.
Added support for Python 3.12.
Changed
Improved error messages when failing to get services in WinRT backend.
Improved error messages with enum values in WinRT backend. Fixes #1284.
Scanner backends modified to allow multiple advertisement callbacks. Merged #1367.
Changed default handling of the response argument in BleakClient.write_gatt_char. Fixes #909.
Bleak recipe now automatically installs bleak from GitHub release in Kivy example.
Changed BlueZManager methods to raise BleakError when device is not in BlueZ.
Optimized BlueZ backend device watchers and condition callbacks to avoid linear searches.
Changed type hint for buffer protocol to collections.abc.Buffer.
Fixed
Fixed handling all access denied errors when enumerating characteristics on Windows. Fixes #1291.
Added support for 32bit UUIDs. Fixes #1314.
Fixed typing for BaseBleakScanner detection callback.
Fixed possible crash in _stopped_handler() in WinRT backend. Fixes #1330.
Reduced expensive logging in the BlueZ backend. Merged #1376.
Fixed race condition with "InterfaceRemoved" when getting services in BlueZ backend.
Fixed missing permissions and requirements in android Kivy example. Fixes #1184.
Fixed WinRT backend sometimes hanging forever when a device goes out of range during connection. Fixes #1359.
Removed
Dropped support for Python 3.7.
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bleak')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch | 23 |
1 files changed, 0 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch b/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch deleted file mode 100644 index 051ebbe674..0000000000 --- a/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | --- a/pyproject.toml 2023-04-19 19:04:47.159474100 -0300 | ||
4 | +++ b/pyproject.toml 2023-05-04 08:08:12.289941765 -0300 | ||
5 | @@ -31,15 +31,15 @@ | ||
6 | bleak-winrt = { version = "^1.2.0", markers = "platform_system=='Windows'" } | ||
7 | dbus-fast = { version = "^1.83.0", markers = "platform_system == 'Linux'" } | ||
8 | |||
9 | -[tool.poetry.group.docs.dependencies] | ||
10 | +#[tool.poetry.group.docs.dependencies] | ||
11 | Sphinx = { version = "^5.1.1", python = ">=3.8" } | ||
12 | sphinx-rtd-theme = "^1.0.0" | ||
13 | |||
14 | -[tool.poetry.group.lint.dependencies] | ||
15 | +#[tool.poetry.group.lint.dependencies] | ||
16 | black = "^22.1.0" | ||
17 | flake8 = { version = "^5.0.0", python = ">=3.8" } | ||
18 | |||
19 | -[tool.poetry.group.test.dependencies] | ||
20 | +#[tool.poetry.group.test.dependencies] | ||
21 | asynctest = { version = "^0.13.0", python = "<3.8" } | ||
22 | pytest = "^7.0.0" | ||
23 | pytest-asyncio = "^0.19.0" | ||