summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2023-12-14 05:37:25 +0000
committerKhem Raj <raj.khem@gmail.com>2023-12-13 22:03:49 -0800
commite650892546d0789034de85c90b331d96fa155250 (patch)
tree8b81e764c6bc28937a43867975862436cf21aeb0 /meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb
parent8f276a9bae3c92114a12d6005f76cc041dc783dc (diff)
downloadmeta-openembedded-e650892546d0789034de85c90b331d96fa155250.tar.gz
python3-bitstring: update to version 4.1.4
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb b/meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb
new file mode 100644
index 000000000..6fc2cf480
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Simple construction, analysis and modification of binary data."
2HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=661f450e2c0aef39b4b15597333444a7"
5
6SRC_URI[sha256sum] = "94f3f1c45383ebe8fd4a359424ffeb75c2f290760ae8fcac421b44f89ac85213"
7
8PYPI_PACKAGE = "bitstring"
9
10inherit pypi python_poetry_core
11
12RDEPENDS:${PN} = "\
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-mmap \
16 ${PYTHON_PN}-numbers \
17"
18
19BBCLASSEXTEND = "native nativesdk"