diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2024-11-26 17:11:49 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-11-26 07:26:30 -0800 |
commit | 09ce9583a4785e0d3b11847d1223d9cead2aabc2 (patch) | |
tree | a91bc91448ddc78d4181a4c147ac5cced087a39e /meta-python/recipes-devtools/python/python3-bitarray_3.0.0.bb | |
parent | 4d2e519dd4b11b15d379ec1a9efa0f59812c6cce (diff) | |
download | meta-openembedded-09ce9583a4785e0d3b11847d1223d9cead2aabc2.tar.gz |
python3-bitarray: Upgrade 2.9.3 -> 3.0.0
Upgrade to version 3.0.0:
- Remove Python 2.7 support
- .decode() now returns iterator (equivalent to past .iterdecode())
- .search() now returns iterator (equivalent to past .itersearch())
- Remove .iterdecode() and .itersearch()
- Remove util.rindex(), use .index(..., right=1) instead,
deprecated since 2.9
- Remove util.make_endian(), use bitarray(..., endian=...) instead,
deprecated since 2.9
- Remove hackish support for bitarray() handling unpickling
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bitarray_3.0.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-bitarray_3.0.0.bb | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_3.0.0.bb b/meta-python/recipes-devtools/python/python3-bitarray_3.0.0.bb new file mode 100644 index 0000000000..c2a7e770d6 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-bitarray_3.0.0.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | SUMMARY = "efficient arrays of booleans -- C extension" | ||
2 | DESCRIPTION = "A high-level Python efficient arrays of booleans -- C extension" | ||
3 | HOMEPAGE = "https://github.com/ilanschnell/bitarray" | ||
4 | LICENSE = "PSF-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d" | ||
6 | |||
7 | SRC_URI[sha256sum] = "a2083dc20f0d828a7cdf7a16b20dae56aab0f43dc4f347a3b3039f6577992b03" | ||
8 | |||
9 | inherit setuptools3 pypi | ||
10 | |||
11 | BBCLASSEXTEND = "native nativesdk" | ||