summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bitarray_1.5.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-17 14:29:00 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-18 09:37:39 -0700
commit8b729f9dbb2a6fec982ce31c9347b26012235014 (patch)
treec355697b988876e249f491f38ba7260468063156 /meta-python/recipes-devtools/python/python3-bitarray_1.5.2.bb
parentb71ea584ea9610777eddc187bacc66c4007bf077 (diff)
downloadmeta-openembedded-8b729f9dbb2a6fec982ce31c9347b26012235014.tar.gz
python3-bitarray: Upgrade 1.5.1 -> 1.5.2
Upgrade to release 1.5.2: - add PyType_Ready usage, issue #66 - speedup search() for bitarrays with length 1 in sparse bitarrays - add tests Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bitarray_1.5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray_1.5.2.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_1.5.2.bb b/meta-python/recipes-devtools/python/python3-bitarray_1.5.2.bb
new file mode 100644
index 000000000..15393001a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bitarray_1.5.2.bb
@@ -0,0 +1,11 @@
1SUMMARY = "A high-level Python efficient arrays of booleans -- C extension"
2HOMEPAGE = "https://github.com/ilanschnell/bitarray"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d"
5
6SRC_URI[md5sum] = "ccd872c5effef77bf4028c67c0619f6c"
7SRC_URI[sha256sum] = "38fe66d5f7720835703a07fe8d0a4b5eda87f692f3cf4fb01543407b79857edf"
8
9inherit setuptools3 pypi
10
11BBCLASSEXTEND = "native nativesdk"