summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-asgiref_3.8.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-01 22:50:43 +0800
committerKhem Raj <raj.khem@gmail.com>2024-04-02 11:28:50 -0700
commit995bac1a612067ab9c74502cd8312d6ea21cd226 (patch)
treed08e50f8e5d57c0101d6d99ce84c4c1e3863a98b /meta-python/recipes-devtools/python/python3-asgiref_3.8.1.bb
parent796db55dc7cf57faf85d4c8243da73c1278fb2cb (diff)
downloadmeta-openembedded-995bac1a612067ab9c74502cd8312d6ea21cd226.tar.gz
python3-asgiref: upgrade 3.7.2 -> 3.8.1
Changelog: =========== * Fixes a regression in 3.8.0 affecting nested task cancellation inside sync_to_async. * Adds support for Python 3.12. * Drops support for (end-of-life) Python 3.7. * Fixes task cancellation propagation to subtasks when using synchronous Django middleware. * Allows nesting "sync_to_async" via "asyncio.wait_for". * Corrects WSGI adapter handling of root path. * Handles case where `"client"` is "None" in WsgiToAsgi adapter. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-asgiref_3.8.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-asgiref_3.8.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asgiref_3.8.1.bb b/meta-python/recipes-devtools/python/python3-asgiref_3.8.1.bb
new file mode 100644
index 000000000..3b90eda5b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-asgiref_3.8.1.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "ASGI is a standard for Python asynchronous web apps and servers to communicate with each other, and positioned as an asynchronous successor to WSGI."
2HOMEPAGE = "https://pypi.org/project/asgiref/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
6
7SRC_URI += "file://run-ptest \
8 "
9
10SRC_URI[sha256sum] = "c343bd80a0bec947a9860adb4c432ffa7db769836c64238fc34bdc3fec84d590"
11
12export BUILD_SYS
13export HOST_SYS
14
15inherit pypi ptest setuptools3
16
17RDEPENDS:${PN}-ptest += " \
18 python3-asyncio \
19 python3-io \
20 python3-multiprocessing \
21 python3-pytest \
22 python3-unittest-automake-output \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29
30BBCLASSEXTEND = "native nativesdk"