summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-asgiref_3.7.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-05-31 15:40:04 +0800
committerKhem Raj <raj.khem@gmail.com>2023-05-31 08:28:50 -0700
commitd81f9b154f4068e3422b1cf4be62169d7d353090 (patch)
treee4e70ece4222bf5d74140e838735dcba9ec7c5a7 /meta-python/recipes-devtools/python/python3-asgiref_3.7.2.bb
parentb3626edcd75b76cb35db6eb7016bd8a8fe117217 (diff)
downloadmeta-openembedded-d81f9b154f4068e3422b1cf4be62169d7d353090.tar.gz
python3-asgiref: upgrade 3.7.1 -> 3.7.2
Changelog: ========== * The type annotations for SyncToAsync and AsyncToSync have been changed to more accurately reflect the kind of callables they return. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-asgiref_3.7.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-asgiref_3.7.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asgiref_3.7.2.bb b/meta-python/recipes-devtools/python/python3-asgiref_3.7.2.bb
new file mode 100644
index 000000000..c9081c8cb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-asgiref_3.7.2.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "ASGI is a standard for Python asynchronous web apps and servers to communicate with each other, and positioned as an asynchronous successor to WSGI."
2HOMEPAGE = "https://pypi.org/project/asgiref/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
6
7SRC_URI += "file://run-ptest \
8 "
9
10SRC_URI[sha256sum] = "9e0ce3aa93a819ba5b45120216b23878cf6e8525eb3848653452b4192b92afed"
11
12export BUILD_SYS
13export HOST_SYS
14
15inherit pypi ptest setuptools3
16
17RDEPENDS:${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19 ${PYTHON_PN}-asyncio \
20 ${PYTHON_PN}-io \
21 ${PYTHON_PN}-multiprocessing \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
29BBCLASSEXTEND = "native nativesdk"