summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
diff options
context:
space:
mode:
authorRichard Leitner <dev@g0hl1n.net>2024-02-05 13:58:26 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-10 10:39:57 -0800
commit7e95b8600e3062770d99c08600b1962abd63393f (patch)
tree119f186e215a0f855aff401f8cd99e7d59bddc14 /meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
parent6d766dd2b080ccc351aea12f52faa43e99b593be (diff)
downloadmeta-openembedded-7e95b8600e3062770d99c08600b1962abd63393f.tar.gz
python3-anyio: add recipe for v4.2.0
High level compatibility layer for multiple asynchronous event loop implementations. This recipe is currently provided without trio support, as the author has no use for it and it would require to add a new python3-trio recipe. This recipe uses pypi as source: https://pypi.org/project/anyio Signed-off-by: Richard Leitner <dev@g0hl1n.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb b/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
new file mode 100644
index 000000000..0bf907de7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "High level compatibility layer for multiple asynchronous event loop implementations"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f"
5
6inherit pypi python_setuptools_build_meta
7
8SRC_URI[sha256sum] = "e1875bb4b4e2de1669f4bc7869b6d3f54231cdced71605e6e64c9be77e3be50f"
9
10DEPENDS += " \
11 python3-setuptools-scm-native \
12"
13
14# Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently.
15# If somebody needs this please feel free to add python3-trio and enable the
16# packageconfig below:
17#PACKAGECONFIG ??= ""
18#PACKAGECONFIG[trio] = ",,,python3-trio"
19
20RDEPENDS:${PN} += "\
21 python3-idna \
22 python3-sniffio \
23"