summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-01-16 15:56:44 +0200
committerKhem Raj <raj.khem@gmail.com>2023-01-16 10:32:40 -0800
commitc0e580a4b358199c97f3eca4ac0115c73ff27906 (patch)
tree0f8d10de4c110b741c18a550d0cb80005321af2d /meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb
parentd42d733990a67ac8975ed51a628196172f7e1b7c (diff)
downloadmeta-openembedded-c0e580a4b358199c97f3eca4ac0115c73ff27906.tar.gz
python3-alembic: Upgrade 1.9.1 -> 1.9.2
Upgrade to release 1.9.2: - Fixed typing definitions for EnvironmentContext.get_x_argument() - Fixed regression where the string transformations applied to server defaults caused expressions such as (getdate()) to no longer compare as equivalent on SQL Server, others. License-Update: Update years Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb b/meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb
new file mode 100644
index 000000000..0d83f86c4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A database migration tool for SQLAlchemy"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=e3023b042cb6002cb398344b51c67093"
4
5inherit pypi setuptools3
6
7SRC_URI[sha256sum] = "6880dec4f28dd7bd999d2ed13fbe7c9d4337700a44d11a524c0ce0c59aaf0dbd"
8
9PYPI_PACKAGE = "alembic"
10
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-dateutil \
13 ${PYTHON_PN}-editor \
14 ${PYTHON_PN}-mako \
15 ${PYTHON_PN}-sqlalchemy \
16 ${PYTHON_PN}-misc \
17"
18
19BBCLASSEXTEND = "native nativesdk"