summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-01-05 18:12:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-25 15:58:54 +0100
commit1161ab8f8dda272eb5d09917446cc5b971be1335 (patch)
tree6d54ae1bce773d0aae59257634081705430e8e8d /meta-python/recipes-devtools/python/python-pyyaml_3.12.bb
parent0c41b5e3148a7d6233b4e3704ab53bb726f814d6 (diff)
downloadmeta-openembedded-1161ab8f8dda272eb5d09917446cc5b971be1335.tar.gz
python-yaml: provide both python2 and python3 package
Further the recipe is simplified by using the pypi and setuptools class. The custom setup.py is no onger necessary. Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyyaml_3.12.bb')
-rwxr-xr-x[-rw-r--r--]meta-python/recipes-devtools/python/python-pyyaml_3.12.bb26
1 files changed, 2 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb b/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb
index 0899a2ee5..6d9f3e95a 100644..100755
--- a/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb
+++ b/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb
@@ -1,24 +1,2 @@
1SUMMARY = "Python support for YAML" 1inherit setuptools
2HOMEPAGE = "http://www.pyyaml.org" 2require python-pyyaml.inc
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17"
6DEPENDS = "libyaml python-cython-native"
7
8SRC_URI = "http://pyyaml.org/download/pyyaml/PyYAML-${PV}.tar.gz \
9 file://setup.py \
10"
11
12SRC_URI[md5sum] = "4c129761b661d181ebf7ff4eb2d79950"
13SRC_URI[sha256sum] = "592766c6303207a20efc445587778322d7f73b161bd994f227adaa341ba212ab"
14
15S = "${WORKDIR}/PyYAML-${PV}"
16
17inherit distutils
18
19do_configure_prepend() {
20 # upstream setup.py overcomplicated, use ours
21 install -m 0644 ${WORKDIR}/setup.py ${S}
22}
23
24BBCLASSEXTEND = "native nativesdk"