summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyudev.inc
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 14:20:59 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit9d300f9d03ec8a0762d21902f5100b92984600eb (patch)
tree300afd7f2085ffc7bf84006f1b07e2280533e088 /meta-python/recipes-devtools/python/python-pyudev.inc
parent66a864ed0d3b730af1bd345dacbd1acf996bbad7 (diff)
downloadmeta-openembedded-9d300f9d03ec8a0762d21902f5100b92984600eb.tar.gz
python-pyudev: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyudev.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-pyudev.inc19
1 files changed, 0 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyudev.inc b/meta-python/recipes-devtools/python/python-pyudev.inc
deleted file mode 100644
index 683a75cdd..000000000
--- a/meta-python/recipes-devtools/python/python-pyudev.inc
+++ /dev/null
@@ -1,19 +0,0 @@
1SUMMARY = "A libudev binding"
2LICENSE = "LGPLv2.1+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
4
5SRC_URI[md5sum] = "cf4d9db7d772622144ca1be6b5d9353b"
6SRC_URI[sha256sum] = "094b7a100150114748aaa3b70663485dd360457a709bfaaafe5a977371033f2b"
7
8do_configure_prepend() {
9 sed -i "/import pyudev/d" ${S}/setup.py
10 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
11}
12
13RDEPENDS_${PN} = "\
14 ${PYTHON_PN}-ctypes \
15 ${PYTHON_PN}-misc \
16 ${PYTHON_PN}-six \
17 ${PYTHON_PN}-threading \
18 libudev \
19"