summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pytest
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-07-05 10:00:22 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:31 +0200
commitc974fbf9ebf185552ab65301e07af44f36517abf (patch)
treee5df11fa16ca50f17ad4ea1d81c64ff588609690 /meta-python/recipes-devtools/python/python-pytest
parent941ad264a6f9e6b21860c3834ce235b791912972 (diff)
downloadmeta-openembedded-c974fbf9ebf185552ab65301e07af44f36517abf.tar.gz
python-pytest: remove fetch during do_compile phase
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
new file mode 100644
index 000000000..e283b17c4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
@@ -0,0 +1,29 @@
1From e2d81009c790b4ebeced8408b6bae78060cabcaf Mon Sep 17 00:00:00 2001
2From: Derek Straka <derek@asterius.io>
3Date: Wed, 5 Jul 2017 09:35:51 -0400
4Subject: [PATCH 1/1] setup.py: remove the setup_requires for setuptools-scm
5
6The setup_requires argument forces the download of the egg file for setuptools-scm
7during the do_compile phase. This download is incompatible with the typical fetch
8and mirror structure. The only usage of scm is the generation of the _version.py
9file and in the release tarball it is already correctly created
10
11Signed-off-by: Derek Straka <derek@asterius.io>
12---
13 setup.py | 1 -
14 1 file changed, 1 deletion(-)
15
16diff --git a/setup.py b/setup.py
17index 751868c..ef6ebf1 100644
18--- a/setup.py
19+++ b/setup.py
20@@ -71,7 +71,6 @@ def main():
21 keywords="test unittest",
22 cmdclass={'test': PyTest},
23 # the following should be enabled for release
24- setup_requires=['setuptools-scm'],
25 install_requires=install_requires,
26 extras_require=extras_require,
27 packages=['_pytest', '_pytest.assertion', '_pytest._code', '_pytest.vendored_packages'],
28--
292.7.4