summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:56:58 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:26 +0200
commit4f93338b18caf5c9d2053c0f4a0f9d5706285f3f (patch)
tree5e59fe9cc21ce5acf2db3dbbf3ae96bfa65e708c /meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb
parent56a4d21706e0219bbe488c2bd1450247f4f89d0d (diff)
downloadmeta-openembedded-4f93338b18caf5c9d2053c0f4a0f9d5706285f3f.tar.gz
python-pyrex: add a recipe
This is moved from oe-core. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb b/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb
new file mode 100644
index 000000000..c4dd2e69b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Language for writing Python extension modules"
2DESCRIPTION = "Pyrex is a language specially designed for writing Python extension modules. \
3It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
4and the messy, low-level world of C."
5SECTION = "devel/python"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=771d472f53f933033f57eeee7808e5bd"
8SRCNAME = "Pyrex"
9PR = "r4"
10
11SRC_URI = "\
12 http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
13 file://pyrex-fix-optimized-mode.patch \
14"
15
16SRC_URI[md5sum] = "515dee67d15d4393841e2d60e8341947"
17SRC_URI[sha256sum] = "5f87df06831d0b3412eb4bc9d3fc2ee7bfae1b913d7da8c23ab2bf5699fb6b50"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit distutils
21
22FILES_${PN} += "${datadir}${base_libdir}/${PYTHON_DIR}/site-packages/Pyrex/Compiler/Lexicon.pickle"