summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pycrypto
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-02-06 08:37:15 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:30 +0100
commita625494863b70f13ca29b4b0322fbfd5a8a073d9 (patch)
tree08f898342ab32db5a4bfd70e1430eb30160107db /meta-python/recipes-devtools/python/python-pycrypto
parent2b6cad9522582b0816251b5efbbc4601d037ae0e (diff)
downloadmeta-openembedded-a625494863b70f13ca29b4b0322fbfd5a8a073d9.tar.gz
python-pycrypto: add app to meta-python
move it from meta-security Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pycrypto')
-rw-r--r--meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch
new file mode 100644
index 0000000000..712f3e8dde
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch
@@ -0,0 +1,23 @@
1Index: pycrypto-2.6/setup.py
2===================================================================
3--- pycrypto-2.6.orig/setup.py
4+++ pycrypto-2.6/setup.py
5@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
6 if not os.path.exists("config.status"):
7 if os.system("chmod 0755 configure") != 0:
8 raise RuntimeError("chmod error")
9- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
10+ host = os.environ.get("HOST_SYS")
11+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
12 if self.verbose < 1:
13 cmd += " -q"
14 if os.system(cmd) != 0:
15@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
16 'ext_modules': plat_ext + [
17 # _fastmath (uses GNU mp library)
18 Extension("Crypto.PublicKey._fastmath",
19- include_dirs=['src/','/usr/include/'],
20+ include_dirs=['src/'],
21 libraries=['gmp'],
22 sources=["src/_fastmath.c"]),
23