summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-14 23:05:18 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:48 +0100
commit9d9a616a392deeb06bf7458902281c9bfeb7f5b6 (patch)
treedccc15079aa4f39de3266c838415202ada4a4060 /meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
parentb62ae60f869b83721757a2f5316cdc26c1030af3 (diff)
downloadmeta-openembedded-9d9a616a392deeb06bf7458902281c9bfeb7f5b6.tar.gz
Update python recipes to use the common pypi package
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb12
1 files changed, 2 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb b/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
index fdc13eb11..14edb030a 100644
--- a/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
+++ b/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
@@ -1,21 +1,13 @@
1# Imported from git://git.yoctoproject.org/meta-cloud-services
2
3SUMMARY = "Python library for displaying tabular data in a ASCII table format" 1SUMMARY = "Python library for displaying tabular data in a ASCII table format"
4HOMEPAGE = "http://code.google.com/p/prettytable" 2HOMEPAGE = "http://code.google.com/p/prettytable"
5SECTION = "devel/python"
6LICENSE = "BSD" 3LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282" 4LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
8 5
9SRCNAME = "prettytable"
10
11SRC_URI = "http://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip"
12
13SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899" 6SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899"
14SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f" 7SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f"
15 8
16S = "${WORKDIR}/${SRCNAME}-${PV}" 9PYPI_PACKAGE_EXT = "zip"
17 10inherit pypi setuptools
18inherit setuptools
19 11
20do_install_append() { 12do_install_append() {
21 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"` 13 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"`