summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-10-14 08:30:33 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-25 15:31:15 +0200
commitd4185c69156e91a4b47597686f7cb526f3419bd4 (patch)
treefc2c9a2db4b84478c968f26027539eef8f0a47c4 /meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
parentecc78a905b0ae5398f1fa64593a73435cf0b28a6 (diff)
downloadmeta-openembedded-d4185c69156e91a4b47597686f7cb526f3419bd4.tar.gz
python-dbusmock: update to version 0.16.7
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb b/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
new file mode 100644
index 000000000..fb8c0aa60
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dbusmock_0.16.7.bb
@@ -0,0 +1,26 @@
1# Copyright (c) 2014 LG Electronics, Inc.
2
3SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
4AUTHOR = "Martin Pitt <martin.pitt@ubuntu.com>"
5
6LICENSE = "GPL-3.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
8
9SRC_URI[md5sum] = "80f8caa838fad96483a8751e11d384f9"
10SRC_URI[sha256sum] = "2d2ea892fa4633c3ec6ac1e912120ec493047a5c6522849b7d1c95ad755bce75"
11
12SRC_URI += " \
13 file://0001-Add-functionality-to-add-own-objects-to-internal-obj.patch \
14 file://0002-Add-possibility-to-import-templates-from-packages.patch \
15"
16
17PYPI_PACKAGE = "python-dbusmock"
18
19inherit pypi setuptools
20
21RDEPENDS_${PN} += "\
22 ${PYTHON_PN}-dbus \
23 ${PYTHON_PN}-importlib \
24 ${PYTHON_PN}-pygobject \
25 ${PYTHON_PN}-xml \
26 "