summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-automat.inc
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-22 09:16:06 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-27 07:25:02 -0800
commitcd7cc6e9dd9f700f07b8a09e6533fa205db28479 (patch)
tree8f531f529d7a5805fdea89c54a2d26f92be50e73 /meta-python/recipes-devtools/python/python-automat.inc
parentb08b570c8624303acbb6bb064a7bda466a679df4 (diff)
downloadmeta-openembedded-cd7cc6e9dd9f700f07b8a09e6533fa205db28479.tar.gz
python-automat: fix build dependencies to avoid download during do_compile
Add the correct version of python{3}-setuptools-scm-native Remove the dependency on m2r Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-automat.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-automat.inc8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-automat.inc b/meta-python/recipes-devtools/python/python-automat.inc
index 1ac5d3b32..43b9ce9e3 100644
--- a/meta-python/recipes-devtools/python/python-automat.inc
+++ b/meta-python/recipes-devtools/python/python-automat.inc
@@ -3,6 +3,8 @@ HOMEPAGE = "https://github.com/glyph/Automat"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
5 5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-automat:"
7
6SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d" 8SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d"
7SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8" 9SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8"
8 10
@@ -10,6 +12,12 @@ PYPI_PACKAGE = "Automat"
10 12
11inherit pypi 13inherit pypi
12 14
15SRC_URI_append = " \
16 file://0001-setup.py-remove-the-dependency-on-m2r.patch \
17"
18
19DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
20
13RDEPENDS_${PN} += "\ 21RDEPENDS_${PN} += "\
14 ${PYTHON_PN}-attrs \ 22 ${PYTHON_PN}-attrs \
15 ${PYTHON_PN}-six \ 23 ${PYTHON_PN}-six \