summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2024-12-16 15:55:14 +0000
committerKhem Raj <raj.khem@gmail.com>2024-12-19 09:41:21 -0800
commitc089690f57155cc62c3b22a9af9527ec927b16e3 (patch)
tree3616102cf6d352c02eef8601bf9f4cec31d1381d /meta-python/recipes-connectivity
parentdd241e2406db26f08ec3507ce73b273a893378e2 (diff)
downloadmeta-openembedded-c089690f57155cc62c3b22a9af9527ec927b16e3.tar.gz
python3-*: Update recipes to correctly check the upstream packages
With the upstream check migrated to the simple repo API, a number of the recipes required updates to: 1. Remove outdated UPSTREAM_CHECK_REGEX checks 2. Add recipe specific UPSTREAM_CHECK_PYPI_PACKAGE definitions for packages that use '_', CamelCase, or other deviations from PEP625 in the source archive Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb b/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb
index c49e67c919..9f5e6d6dba 100644
--- a/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb
+++ b/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.82.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=cd13dafd4eeb0802bb6efea6b4a4bdbc"
5SRC_URI[sha256sum] = "511f5b0804e92dd77dc33adf9c947787e3f9e9c5a96b12162f0557a7c4ce21fb" 5SRC_URI[sha256sum] = "511f5b0804e92dd77dc33adf9c947787e3f9e9c5a96b12162f0557a7c4ce21fb"
6 6
7PYPI_PACKAGE = "Pyro4" 7PYPI_PACKAGE = "Pyro4"
8UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
8 9
9inherit pypi setuptools3 10inherit pypi setuptools3
10 11