diff options
author | Kang Kai <kai.kang@windriver.com> | 2014-08-14 17:13:30 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-21 21:35:05 +0200 |
commit | e4c1f724441af1c518d6bfe54457e09c1504dd21 (patch) | |
tree | 9f4d5cd11de8014521ebb4dc3e4c20a5486271b4 /meta-perl | |
parent | 622ad1538bd931e3bda6c8a9c4cd879db454d15d (diff) | |
download | meta-openembedded-e4c1f724441af1c518d6bfe54457e09c1504dd21.tar.gz |
libdigest-sha1-perl: add recipe
Add recipe for libdigest-sha1-perl and enable create -ptest sub-package.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r-- | meta-perl/recipes-perl/libdigest/files/run-ptest | 16 | ||||
-rw-r--r-- | meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb | 25 |
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libdigest/files/run-ptest b/meta-perl/recipes-perl/libdigest/files/run-ptest new file mode 100644 index 0000000000..c9f9ca94d0 --- /dev/null +++ b/meta-perl/recipes-perl/libdigest/files/run-ptest | |||
@@ -0,0 +1,16 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | for case in `find t -type f -name '*.t'`; do | ||
4 | perl $case >$case.output 2>&1 | ||
5 | ret=$? | ||
6 | cat $case.output | ||
7 | if [ $ret -ne 0 ]; then | ||
8 | echo "FAIL: ${case%.t}" | ||
9 | elif grep -i 'SKIP' $case.output; then | ||
10 | echo "SKIP: ${case%.t}" | ||
11 | else | ||
12 | echo "PASS: ${case%.t}" | ||
13 | fi | ||
14 | |||
15 | rm -f $case.output | ||
16 | done | ||
diff --git a/meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb b/meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb new file mode 100644 index 0000000000..0371ea68cd --- /dev/null +++ b/meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "Perl interface to the SHA-1 algorithm " | ||
2 | DESCRIPTION = "Digest::SHA1 - Perl interface to the SHA-1 algorithm" | ||
3 | HOMEPAGE = "http://search.cpan.org/~gaas/Digest-SHA1-2.13/" | ||
4 | SECTION = "libs" | ||
5 | |||
6 | LICENSE = "Artistic-1.0|GPLv1+" | ||
7 | LIC_FILES_CHKSUM = "file://README;beginline=10;endline=14;md5=ff5867ebb4bc1103a7a416aef2fce00a" | ||
8 | |||
9 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Digest-SHA1-${PV}.tar.gz \ | ||
10 | file://run-ptest \ | ||
11 | " | ||
12 | SRC_URI[md5sum] = "bd22388f268434f2b24f64e28bf1aa35" | ||
13 | SRC_URI[sha256sum] = "68c1dac2187421f0eb7abf71452a06f190181b8fc4b28ededf5b90296fb943cc" | ||
14 | |||
15 | S = "${WORKDIR}/Digest-SHA1-${PV}" | ||
16 | |||
17 | inherit cpan ptest | ||
18 | |||
19 | do_install_ptest () { | ||
20 | cp -r ${B}/t ${D}${PTEST_PATH} | ||
21 | } | ||
22 | |||
23 | BBCLASSEXTEND="native" | ||
24 | |||
25 | FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Digest/SHA1/.debug/" | ||