summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-10-11 10:28:39 -0700
committerKhem Raj <raj.khem@gmail.com>2023-10-11 12:32:09 -0700
commit9f312824d429603417109eb08d13d260d6231361 (patch)
tree705cf9eb161c5367361426bbba8366166da3e675 /meta-perl
parent62039a2c3347841f0e5b2c46345c9bd2fe76805e (diff)
downloadmeta-openembedded-9f312824d429603417109eb08d13d260d6231361.tar.gz
libnet-idn-encode: Fix build with perl 2.38 and gcc13
Add missing rdep on perl-module-encode-encoding fixes Can't locate Encode/Encoding.pm in @INC (you may need to install the Encode::Encoding module) Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-idn-encode/Net-IDN-Encode-2.500-use_uvchr_to_utf8_flags_instead_of_uvuni_to_utf8_flags.patch36
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-idn-encode_2.500.bb6
2 files changed, 40 insertions, 2 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-idn-encode/Net-IDN-Encode-2.500-use_uvchr_to_utf8_flags_instead_of_uvuni_to_utf8_flags.patch b/meta-perl/recipes-perl/libnet/libnet-idn-encode/Net-IDN-Encode-2.500-use_uvchr_to_utf8_flags_instead_of_uvuni_to_utf8_flags.patch
new file mode 100644
index 000000000..f0e9010bf
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-idn-encode/Net-IDN-Encode-2.500-use_uvchr_to_utf8_flags_instead_of_uvuni_to_utf8_flags.patch
@@ -0,0 +1,36 @@
1Subject: [PATCH] use uvchr_to_utf8_flags instead of uvuni_to_utf8_flags (which is removed in perl 5.38.0)
2
3https://perldoc.perl.org/5.36.0/perlintern#uvuni_to_utf8_flags
4Signed-off-by: Shin Kojima <shin@kojima.org>
5Upstream-Status: Submitted [https://github.com/cfaerber/Net-IDN-Encode/pull/11]
6---
7 lib/Net/IDN/Punycode.xs | 6 +++++-
8 1 file changed, 5 insertions(+), 1 deletion(-)
9
10diff --git a/lib/Net/IDN/Punycode.xs b/lib/Net/IDN/Punycode.xs
11index 211ef9c..36530dd 100644
12--- a/lib/Net/IDN/Punycode.xs
13+++ b/lib/Net/IDN/Punycode.xs
14@@ -24,6 +24,10 @@
15 #define utf8_to_uvchr_buf(in_p,in_e,u8) utf8_to_uvchr(in_p,u8);
16 #endif
17
18+#ifndef uvchr_to_utf8_flags
19+#define uvchr_to_utf8_flags(d, uv, flags) uvuni_to_utf8_flags(d, uv, flags);
20+#endif
21+
22 static char enc_digit[BASE] = {
23 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm',
24 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z',
25@@ -253,7 +257,7 @@ decode_punycode(input)
26 if(skip_p < re_p) /* move succeeding chars */
27 Move(skip_p, skip_p + u8, re_p - skip_p, char);
28 re_p += u8;
29- uvuni_to_utf8_flags((U8*)skip_p, n, UNICODE_ALLOW_ANY);
30+ uvchr_to_utf8_flags((U8*)skip_p, n, UNICODE_ALLOW_ANY);
31 }
32
33 if(!first) SvUTF8_on(RETVAL); /* UTF-8 chars have been inserted */
34--
352.41.0
36
diff --git a/meta-perl/recipes-perl/libnet/libnet-idn-encode_2.500.bb b/meta-perl/recipes-perl/libnet/libnet-idn-encode_2.500.bb
index ce3b75b77..7f33fd2b1 100644
--- a/meta-perl/recipes-perl/libnet/libnet-idn-encode_2.500.bb
+++ b/meta-perl/recipes-perl/libnet/libnet-idn-encode_2.500.bb
@@ -7,7 +7,9 @@ SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0-or-later" 7LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=8ea5704cf65ca4ec6e9e167fb94f14dd" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=8ea5704cf65ca4ec6e9e167fb94f14dd"
9 9
10SRC_URI = "${CPAN_MIRROR}/authors/id/C/CF/CFAERBER/Net-IDN-Encode-${PV}.tar.gz" 10SRC_URI = "${CPAN_MIRROR}/authors/id/C/CF/CFAERBER/Net-IDN-Encode-${PV}.tar.gz \
11 file://Net-IDN-Encode-2.500-use_uvchr_to_utf8_flags_instead_of_uvuni_to_utf8_flags.patch \
12"
11SRC_URI[sha256sum] = "55453633e3ff24ce325b34bc2c8157b9859962a31ab5cf28bf7ccc1c9b3a3eaa" 13SRC_URI[sha256sum] = "55453633e3ff24ce325b34bc2c8157b9859962a31ab5cf28bf7ccc1c9b3a3eaa"
12 14
13S = "${WORKDIR}/Net-IDN-Encode-${PV}" 15S = "${WORKDIR}/Net-IDN-Encode-${PV}"
@@ -20,4 +22,4 @@ do_configure:prepend() {
20 22
21BBCLASSEXTEND = "native" 23BBCLASSEXTEND = "native"
22 24
23RDEPENDS:${PN} += "perl-module-unicode-normalize" 25RDEPENDS:${PN} += "perl-module-unicode-normalize perl-module-encode-encoding"