summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-03-28 09:28:50 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-31 08:32:39 -0700
commit90668d6fc607d08739e38d47456a0939370fe04d (patch)
treee8a029e8cf97aeaede479ee59d6cb803f49759f7 /meta-perl
parenta81c30edea91180f93572ddbc1471d16ee1a18f4 (diff)
downloadmeta-openembedded-90668d6fc607d08739e38d47456a0939370fe04d.tar.gz
liberror-perl: move recipe from oe-core
While this package is deprecated by the upstream maintainer, we do not know if there are any users in the wider OpenEmbedded ecosystem, so move the recipe from oe-core to meta-perl. [YOCTO #15461] Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/conf/include/ptest-packagelists-meta-perl.inc1
-rw-r--r--meta-perl/recipes-perl/liberror/liberror-perl_0.17029.bb48
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-perl/conf/include/ptest-packagelists-meta-perl.inc b/meta-perl/conf/include/ptest-packagelists-meta-perl.inc
index 29a2b2e66..842f817f1 100644
--- a/meta-perl/conf/include/ptest-packagelists-meta-perl.inc
+++ b/meta-perl/conf/include/ptest-packagelists-meta-perl.inc
@@ -11,6 +11,7 @@ PTESTS_FAST_META_PERL = "\
11 libcgi-perl \ 11 libcgi-perl \
12 libcrypt-openssl-random-perl \ 12 libcrypt-openssl-random-perl \
13 libdigest-hmac-perl \ 13 libdigest-hmac-perl \
14 liberror-perl \
14 libextutils-config-perl \ 15 libextutils-config-perl \
15 libextutils-installpaths-perl \ 16 libextutils-installpaths-perl \
16 libhtml-tagset-perl \ 17 libhtml-tagset-perl \
diff --git a/meta-perl/recipes-perl/liberror/liberror-perl_0.17029.bb b/meta-perl/recipes-perl/liberror/liberror-perl_0.17029.bb
new file mode 100644
index 000000000..e54bb11cc
--- /dev/null
+++ b/meta-perl/recipes-perl/liberror/liberror-perl_0.17029.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6HOMEPAGE = "https://github.com/shlomif/perl-error.pm"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
12
13DEPENDS += "perl"
14
15RDEPENDS:${PN} += " \
16 perl-module-carp \
17 perl-module-exporter \
18 perl-module-scalar-util \
19 perl-module-overload \
20 perl-module-strict \
21 perl-module-vars \
22 perl-module-warnings \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 perl-module-base \
27 perl-module-file-spec \
28 perl-module-io-handle \
29 perl-module-ipc-open3 \
30 perl-module-lib \
31 perl-module-test-more \
32"
33
34SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
35
36SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a"
37SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc"
38
39S = "${WORKDIR}/Error-${PV}"
40
41inherit cpan ptest-perl
42
43do_install:prepend() {
44 # test requires "-T" (taint) command line option
45 rm -rf ${B}/t/pod-coverage.t
46}
47
48BBCLASSEXTEND = "native"