summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorDavid Pierret <david.pierret@smile.fr>2023-10-13 17:39:51 +0200
committerKhem Raj <raj.khem@gmail.com>2023-10-13 10:19:11 -0700
commit74022f1009cca4d85167b8b759f52d4ff0f92f41 (patch)
tree68085f9bbda17ac277c136de5f44bc4807bcb80d /meta-perl
parent3f9032f126289b8071431d6dd309a5e3d7ebe153 (diff)
downloadmeta-openembedded-74022f1009cca4d85167b8b759f52d4ff0f92f41.tar.gz
libtext: add ptest
Signed-off-by: David Pierret <david.pierret@smile.fr> Reviewed-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest19
-rw-r--r--meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb11
2 files changed, 28 insertions, 2 deletions
diff --git a/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest b/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest
new file mode 100644
index 000000000..c65b6cf8e
--- /dev/null
+++ b/meta-perl/recipes-perl/libtext/libtext-diff-perl/run-ptest
@@ -0,0 +1,19 @@
1#!/bin/sh
2
3for case in `find t -type f -name '*.t'`; do
4 perl $case >$case.output 2>&1
5 ret=$?
6 cat $case.output
7 if [ $ret -ne 0 ]; then
8 echo "FAIL: ${case%.t}"
9 elif grep -i 'SKIP' $case.output; then
10 echo "SKIP: ${case%.t}"
11 else
12 echo "PASS: ${case%.t}"
13 fi
14
15 rm -f $case.output
16done
17
18
19
diff --git a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
index afdf63ede..9dfadde8e 100644
--- a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
+++ b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
@@ -11,17 +11,24 @@ HOMEPAGE = "http://search.cpan.org/~ovid/Text-Diff/"
11LICENSE = "Artistic-1.0 | GPL-2.0-or-later" 11LICENSE = "Artistic-1.0 | GPL-2.0-or-later"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3" 12LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3"
13 13
14SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz" 14SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz \
15 file://run-ptest \
16 "
15SRC_URI[md5sum] = "30d56e6dd5551ca16b8e16cc7299dc21" 17SRC_URI[md5sum] = "30d56e6dd5551ca16b8e16cc7299dc21"
16SRC_URI[sha256sum] = "a67f50a48e313c1680cc662109ce5f913ea71454db355d0cf4db87ac89d2d2fa" 18SRC_URI[sha256sum] = "a67f50a48e313c1680cc662109ce5f913ea71454db355d0cf4db87ac89d2d2fa"
17 19
18S = "${WORKDIR}/Text-Diff-${PV}" 20S = "${WORKDIR}/Text-Diff-${PV}"
19 21
20inherit cpan 22inherit cpan ptest
23RDEPENDS:${PN}-ptest += "perl-module-test perl-module-test-more"
21 24
22RDEPENDS:${PN} = " libalgorithm-diff-perl \ 25RDEPENDS:${PN} = " libalgorithm-diff-perl \
23 perl-module-extutils-makemaker \ 26 perl-module-extutils-makemaker \
24 perl-module-exporter \ 27 perl-module-exporter \
25" 28"
26 29
30do_install_ptest () {
31 cp -r ${B}/t ${D}${PTEST_PATH}
32}
33
27BBCLASSEXTEND = "native" 34BBCLASSEXTEND = "native"