diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2019-06-02 11:43:11 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-06-15 16:45:33 -0700 |
commit | b86d2d057d6106791537aaaead49f78de8512d26 (patch) | |
tree | ec7c98429e29e6d811f459dd0c6c253c58d9e71e /meta-perl/recipes-perl/libcrypt | |
parent | c34d38d716707f250af1945a0d65285c1958b2ae (diff) | |
download | meta-openembedded-b86d2d057d6106791537aaaead49f78de8512d26.tar.gz |
libcrypt-openssl-random-perl: upgrade 0.11 -> 0.15; enable ptest
* Add EXTRA_CPANFLAGS to fix "undefined symbol: RAND_seed"
* Add DEPENDS on libcrypt-openssl-guess-perl-native
* Add runtime and ptest dependencies
Upstream release notes:
0.15 2018-04-22 rurban
- fix mingw hints for pkg-config support (akiym, PR #7)
0.14 2018-04-17 rurban
- add library paths to LIBS from Crypt::OpenSSL::Guess (akiym, PR #6)
0.13 2018-04-14 rurban
- move Crypt::OpenSSL::Guess to configure dependency. (grinnz, PR #4)
0.12 2018-04-13 rurban
- use Crypt::OpenSSL::Guess to resolve OpenSSL include path,
fixes MacOS's homebrew OpenSSL installation problem. (akiym, PR #3)
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libcrypt')
-rw-r--r-- | meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.11.bb | 15 | ||||
-rw-r--r-- | meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.15.bb | 34 |
2 files changed, 34 insertions, 15 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.11.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.11.bb deleted file mode 100644 index 8456e313d..000000000 --- a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.11.bb +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | SUMMARY = "Crypt Openssl Random cpan module" | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=089c18d635ae273e1727ec385e64063b" | ||
6 | |||
7 | SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Random-${PV}.tar.gz " | ||
8 | SRC_URI[md5sum] = "5d71337503e0356ce1ce1481504e5885" | ||
9 | SRC_URI[sha256sum] = "bb8c81c6a39b9b13a22d818ee9a746242f136f0fadceb6b9776ae615e7524c7a" | ||
10 | |||
11 | S = "${WORKDIR}/Crypt-OpenSSL-Random-${PV}" | ||
12 | |||
13 | DEPENDS += " openssl \ | ||
14 | " | ||
15 | inherit cpan | ||
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.15.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.15.bb new file mode 100644 index 000000000..a2ebb8c7a --- /dev/null +++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.15.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "Crypt::OpenSSL::Random - OpenSSL/LibreSSL pseudo-random number generator access" | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=089c18d635ae273e1727ec385e64063b" | ||
6 | |||
7 | SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Random-${PV}.tar.gz " | ||
8 | SRC_URI[md5sum] = "bcde8d5a822c91376deda3c4f0c75fbe" | ||
9 | SRC_URI[sha256sum] = "f0876faa1ba3111e39b86aa730c603211eff2905e460c72a57b61e8cf475cef4" | ||
10 | |||
11 | S = "${WORKDIR}/Crypt-OpenSSL-Random-${PV}" | ||
12 | |||
13 | DEPENDS += " \ | ||
14 | openssl \ | ||
15 | libcrypt-openssl-guess-perl-native \ | ||
16 | " | ||
17 | |||
18 | EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -L${STAGING_BASELIBDIR} -lcrypto'" | ||
19 | |||
20 | inherit cpan ptest-perl | ||
21 | |||
22 | RDEPENDS_${PN} += "\ | ||
23 | perl-module-exporter \ | ||
24 | perl-module-strict \ | ||
25 | perl-module-vars \ | ||
26 | perl-module-xsloader \ | ||
27 | " | ||
28 | |||
29 | RDEPENDS_${PN}-ptest += "\ | ||
30 | perl-module-file-copy \ | ||
31 | perl-module-test-more \ | ||
32 | " | ||
33 | |||
34 | BBCLASSEXTEND = "native" | ||