diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2021-07-29 17:04:53 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-03 10:21:25 -0700 |
commit | c61dc077bbd81260e4f167fa2251643ba0ba6974 (patch) | |
tree | 66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-perl/recipes-extended | |
parent | c5f7cfb8db54cfa4257797db5bd87828dea43296 (diff) | |
download | meta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz |
Convert to new override syntax
This is the result of automated script (0.9.1) conversion:
oe-core/scripts/contrib/convert-overrides.py .
converting the metadata to use ":" as the override character instead of "_".
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-extended')
-rw-r--r-- | meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb | 8 | ||||
-rw-r--r-- | meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb | 4 |
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb b/meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb index bb9faa2c05..38ef0f8dc8 100644 --- a/meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb +++ b/meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb | |||
@@ -21,9 +21,9 @@ S = "${WORKDIR}/${BPN}" | |||
21 | inherit useradd | 21 | inherit useradd |
22 | 22 | ||
23 | USERADD_PACKAGES = "${PN}" | 23 | USERADD_PACKAGES = "${PN}" |
24 | USERADD_PARAM_${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \ | 24 | USERADD_PARAM:${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \ |
25 | -s /bin/false -c 'logcheck account' ${BPN}" | 25 | -s /bin/false -c 'logcheck account' ${BPN}" |
26 | GROUPADD_PARAM_${PN} = "-r ${BPN}" | 26 | GROUPADD_PARAM:${PN} = "-r ${BPN}" |
27 | 27 | ||
28 | do_install() { | 28 | do_install() { |
29 | # Fix QA Issue | 29 | # Fix QA Issue |
@@ -62,7 +62,7 @@ do_install() { | |||
62 | 62 | ||
63 | VIRTUAL-RUNTIME_syslog ??= "rsyslog" | 63 | VIRTUAL-RUNTIME_syslog ??= "rsyslog" |
64 | 64 | ||
65 | RDEPENDS_${PN} = "\ | 65 | RDEPENDS:${PN} = "\ |
66 | bash \ | 66 | bash \ |
67 | cronie \ | 67 | cronie \ |
68 | debianutils-run-parts \ | 68 | debianutils-run-parts \ |
@@ -76,4 +76,4 @@ RDEPENDS_${PN} = "\ | |||
76 | ${VIRTUAL-RUNTIME_syslog} \ | 76 | ${VIRTUAL-RUNTIME_syslog} \ |
77 | " | 77 | " |
78 | 78 | ||
79 | FILES_${PN} += "${datadir}/logtail" | 79 | FILES:${PN} += "${datadir}/logtail" |
diff --git a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb index 2516fbfcaa..2919904572 100644 --- a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb +++ b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb | |||
@@ -17,11 +17,11 @@ SRC_URI[sha256sum] = "4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a | |||
17 | 17 | ||
18 | inherit cpan | 18 | inherit cpan |
19 | 19 | ||
20 | RDEPENDS_${PN} += "libmime-types-perl libproc-waitstat-perl msmtp \ | 20 | RDEPENDS:${PN} += "libmime-types-perl libproc-waitstat-perl msmtp \ |
21 | perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \ | 21 | perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \ |
22 | " | 22 | " |
23 | 23 | ||
24 | do_install_append() { | 24 | do_install:append() { |
25 | #change the interpreter in file | 25 | #change the interpreter in file |
26 | sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \ | 26 | sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \ |
27 | ${D}/${bindir}/mime-construct | 27 | ${D}/${bindir}/mime-construct |