diff options
author | Bian Naimeng <biannm@cn.fujitsu.com> | 2015-06-17 14:43:15 +0900 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-08-24 14:01:37 +0200 |
commit | ffd829b3093a1ad125f9ba1549e6dfcf9814b037 (patch) | |
tree | 223cf499097c794f32344cd32549fdf3e31edcbc /meta-oe | |
parent | 41db3b501a79b146815c8ef77a7d284dd4dd7def (diff) | |
download | meta-openembedded-ffd829b3093a1ad125f9ba1549e6dfcf9814b037.tar.gz |
libtdb: add new recipe
libtdb is required by samba4
Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/libtdb/libtdb/do-not-check-xsltproc-manpages.patch | 15 | ||||
-rw-r--r-- | meta-oe/recipes-support/libtdb/libtdb_1.3.0.bb | 30 |
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libtdb/libtdb/do-not-check-xsltproc-manpages.patch b/meta-oe/recipes-support/libtdb/libtdb/do-not-check-xsltproc-manpages.patch new file mode 100644 index 000000000..bcc45c9fc --- /dev/null +++ b/meta-oe/recipes-support/libtdb/libtdb/do-not-check-xsltproc-manpages.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Don't check manpages for xsltproc. | ||
2 | |||
3 | Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> | ||
4 | |||
5 | --- tdb-1.3.0.orig/wscript 2015-04-22 09:52:32.366000222 +0900 | ||
6 | +++ tdb-1.3.0/wscript 2015-04-22 09:51:57.720000205 +0900 | ||
7 | @@ -90,7 +90,7 @@ def configure(conf): | ||
8 | not conf.env.disable_tdb_mutex_locking): | ||
9 | conf.define('USE_TDB_MUTEX_LOCKING', 1) | ||
10 | |||
11 | - conf.CHECK_XSLTPROC_MANPAGES() | ||
12 | + conf.find_program('xsltproc', var='XSLTPROC') | ||
13 | |||
14 | if not conf.env.disable_python: | ||
15 | # also disable if we don't have the python libs installed | ||
diff --git a/meta-oe/recipes-support/libtdb/libtdb_1.3.0.bb b/meta-oe/recipes-support/libtdb/libtdb_1.3.0.bb new file mode 100644 index 000000000..0b9e1f22b --- /dev/null +++ b/meta-oe/recipes-support/libtdb/libtdb_1.3.0.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "The tdb library" | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "LGPL-3.0+ & GPL-3.0+" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b \ | ||
6 | file://${COREBASE}/meta/files/common-licenses/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891" | ||
7 | |||
8 | SRC_URI = "http://samba.org/ftp/tdb/tdb-${PV}.tar.gz \ | ||
9 | file://do-not-check-xsltproc-manpages.patch" | ||
10 | |||
11 | SRC_URI[md5sum] = "f18cd6afc4f5670edfe58f72d2665f94" | ||
12 | SRC_URI[sha256sum] = "04bee48d405ab7815810575a6e0cb364cc0eea6187b54b18c84e9c18a768ba20" | ||
13 | |||
14 | S = "${WORKDIR}/tdb-${PV}" | ||
15 | |||
16 | inherit waf-samba | ||
17 | |||
18 | EXTRA_OECONF += "--disable-rpath \ | ||
19 | --bundled-libraries=NONE \ | ||
20 | --builtin-libraries=replace \ | ||
21 | --with-libiconv=${STAGING_DIR_HOST}${prefix}\ | ||
22 | " | ||
23 | |||
24 | PACKAGES += "tdb-tools python-tdb python-tdb-dbg" | ||
25 | |||
26 | FILES_${PN} = "${libdir}/*.so.*" | ||
27 | FILES_tdb-tools = "${bindir}/*" | ||
28 | FILES_python-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*" | ||
29 | FILES_python-tdb-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug/*" | ||
30 | RDEPENDS_python-tdb = "python" | ||