summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-06-28 22:24:06 +0200
committerKhem Raj <raj.khem@gmail.com>2023-06-28 13:53:12 -0700
commitfe5b0235b1e8f7bb4cac1e81b44225053b797b2f (patch)
tree4565bd408453b5919909b4c73b69bcfc54699e7b /meta-oe
parent2b375f3f78c239303358b3d73559ab2269f40c5c (diff)
downloadmeta-openembedded-fe5b0235b1e8f7bb4cac1e81b44225053b797b2f.tar.gz
raptor2: backport a fix to build with libxml2-2.11
* fixes: ../../raptor2-2.0.16/src/raptor_libxml.c:256:12: error: 'xmlEntity' {aka 'struct _xmlEntity'} has no member named 'checked' 256 | if(!ret->checked) | ^~ ../../raptor2-2.0.16/src/raptor_libxml.c:257:10: error: 'xmlEntity' {aka 'struct _xmlEntity'} has no member named 'checked' 257 | ret->checked = 1; | ^~ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/raptor2/raptor2/0001-Remove-the-access-to-entities-checked-private-symbol.patch34
-rw-r--r--meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/raptor2/raptor2/0001-Remove-the-access-to-entities-checked-private-symbol.patch b/meta-oe/recipes-support/raptor2/raptor2/0001-Remove-the-access-to-entities-checked-private-symbol.patch
new file mode 100644
index 000000000..e70961679
--- /dev/null
+++ b/meta-oe/recipes-support/raptor2/raptor2/0001-Remove-the-access-to-entities-checked-private-symbol.patch
@@ -0,0 +1,34 @@
1From da171e12d961b41b89196627ef5e5baae1e637ce Mon Sep 17 00:00:00 2001
2From: David Anes <david.anes@suse.com>
3Date: Thu, 4 May 2023 11:54:02 +0200
4Subject: [PATCH] Remove the access to entities 'checked' private symbol for
5 libxml2 2.11.0
6
7Since version 2.11.0, some private symbols that were never intended
8as public API/ABI have been removed from libxml2, therefore the field
9'checked' is no longer present and raptor fails to build in this
10scenario.
11
12Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
13Upstream-Status: Backport [https://github.com/dajobe/raptor/commit/ac914399b9013c54572833d4818e6ce008136dc9]
14---
15 src/raptor_libxml.c | 3 ++-
16 1 file changed, 2 insertions(+), 1 deletion(-)
17
18diff --git a/src/raptor_libxml.c b/src/raptor_libxml.c
19index 538c2c8..8bcee13 100644
20--- a/src/raptor_libxml.c
21+++ b/src/raptor_libxml.c
22@@ -246,10 +246,11 @@ raptor_libxml_getEntity(void* user_data, const xmlChar *name)
23
24 ret->owner = 1;
25
26-#if LIBXML_VERSION >= 20627
27+#if LIBXML_VERSION >= 20627 && LIBXML_VERSION < 21100
28 /* Checked field was released in 2.6.27 on 2006-10-25
29 * http://git.gnome.org/browse/libxml2/commit/?id=a37a6ad91a61d168ecc4b29263def3363fff4da6
30 *
31+ * and was later removed in version 2.11.0
32 */
33
34 /* Mark this entity as having been checked - never do this again */
diff --git a/meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb b/meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb
index 169911276..30df8e064 100644
--- a/meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb
+++ b/meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb
@@ -11,6 +11,7 @@ DEPENDS = "libxml2 libxslt curl yajl"
11 11
12SRC_URI = " \ 12SRC_URI = " \
13 http://download.librdf.org/source/${BPN}-${PV}.tar.gz \ 13 http://download.librdf.org/source/${BPN}-${PV}.tar.gz \
14 file://0001-Remove-the-access-to-entities-checked-private-symbol.patch \
14" 15"
15SRC_URI[sha256sum] = "089db78d7ac982354bdbf39d973baf09581e6904ac4c92a98c5caadb3de44680" 16SRC_URI[sha256sum] = "089db78d7ac982354bdbf39d973baf09581e6904ac4c92a98c5caadb3de44680"
16 17