summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-27 23:24:41 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:28 -0700
commitfd8a326652ddb2ccad49ec93a3bdaa3ea4c1207a (patch)
treebf96b648c1d3c655aa310f9dc12a94ad004617b4 /meta-oe
parent901af82e7d4be4777bbb2b8fba04f2f41f454c09 (diff)
downloadmeta-openembedded-fd8a326652ddb2ccad49ec93a3bdaa3ea4c1207a.tar.gz
open-vm-tools: Upgrade to 10.3.0
License-update: Copyright year and formatting changes Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Remove-assumptions-about-glibc-being-only-libc-imple.patch45
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Use-off64_t-instead-of-__off64_t.patch31
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools/0004-Add-Wno-incompatible-pointer-types-and-Wno-error-add.patch31
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools/use-tirpc.patch481
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb (renamed from meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.2.5.bb)8
5 files changed, 34 insertions, 562 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Remove-assumptions-about-glibc-being-only-libc-imple.patch b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Remove-assumptions-about-glibc-being-only-libc-imple.patch
deleted file mode 100644
index 9773b4a94..000000000
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Remove-assumptions-about-glibc-being-only-libc-imple.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From a0983d84185f04c4e40778fe951fde4439894882 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 16 Jul 2017 07:37:03 -0700
4Subject: [PATCH 01/11] Remove assumptions about glibc being only libc
5 implementation on linux
6
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 open-vm-tools/lib/file/fileIOPosix.c | 2 +-
10 open-vm-tools/lib/include/vm_basic_defs.h | 2 ++
11 2 files changed, 3 insertions(+), 1 deletion(-)
12
13Index: open-vm-tools/lib/file/fileIOPosix.c
14===================================================================
15--- open-vm-tools.orig/lib/file/fileIOPosix.c
16+++ open-vm-tools/lib/file/fileIOPosix.c
17@@ -205,7 +205,7 @@ static AlignedPool alignedPool;
18 * are not available in any header file.
19 */
20
21-#if defined(__linux__) && !defined(__ANDROID__)
22+#if defined(__linux__) && defined(__GLIBC__)
23 #if defined(_FILE_OFFSET_BITS) && (_FILE_OFFSET_BITS == 64)
24 /*
25 * We want preadv/pwritev. But due to FOB=64, the symbols are -64.
26Index: open-vm-tools/lib/include/vm_basic_defs.h
27===================================================================
28--- open-vm-tools.orig/lib/include/vm_basic_defs.h
29+++ open-vm-tools/lib/include/vm_basic_defs.h
30@@ -571,6 +571,7 @@ typedef int pid_t;
31 #if defined __linux__ && !defined __KERNEL__ && !defined MODULE && \
32 !defined VMM && !defined FROBOS && !defined __ANDROID__
33 #include <features.h>
34+#if __GLIBC__
35 #if __GLIBC_PREREQ(2, 1) && !defined GLIBC_VERSION_21
36 #define GLIBC_VERSION_21
37 #endif
38@@ -590,6 +591,7 @@ typedef int pid_t;
39 #define GLIBC_VERSION_212
40 #endif
41 #endif
42+#endif
43
44 /*
45 * Convenience definitions of unicode characters.
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Use-off64_t-instead-of-__off64_t.patch b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Use-off64_t-instead-of-__off64_t.patch
new file mode 100644
index 000000000..432496f27
--- /dev/null
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Use-off64_t-instead-of-__off64_t.patch
@@ -0,0 +1,31 @@
1From 43d859f9d5eecdc0fdc1a6bf539bcde4a152e6f5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 27 Aug 2018 23:22:21 -0700
4Subject: [PATCH] Use off64_t instead of __off64_t
5
6Fixes
7unknown type name '__off64_t'
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 lib/file/fileIOPosix.c | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/lib/file/fileIOPosix.c b/lib/file/fileIOPosix.c
16index 23108279..bcd2ddc5 100644
17--- a/lib/file/fileIOPosix.c
18+++ b/lib/file/fileIOPosix.c
19@@ -206,10 +206,10 @@ static AlignedPool alignedPool;
20 * the symbols (and anyone building XOPEN<700 gets nothing).
21 */
22 extern ssize_t preadv64(int fd, const struct iovec *iov, int iovcnt,
23- __off64_t offset) __attribute__ ((weak));
24+ off64_t offset) __attribute__ ((weak));
25
26 extern ssize_t pwritev64(int fd, const struct iovec *iov, int iovcnt,
27- __off64_t offset) __attribute__ ((weak));
28+ off64_t offset) __attribute__ ((weak));
29 #else
30 #error "Large file support unavailable. Aborting."
31 #endif
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0004-Add-Wno-incompatible-pointer-types-and-Wno-error-add.patch b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0004-Add-Wno-incompatible-pointer-types-and-Wno-error-add.patch
deleted file mode 100644
index 010516761..000000000
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0004-Add-Wno-incompatible-pointer-types-and-Wno-error-add.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From cdb0b3c898c6b6b6c8259d9ddb8b00163ac5e419 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 16 Jul 2017 09:43:18 -0700
4Subject: [PATCH 04/11] Add -Wno-incompatible-pointer-types and
5 -Wno-error=address
6
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 open-vm-tools/lib/dynxdr/Makefile.am | 2 +-
10 open-vm-tools/lib/file/Makefile.am | 1 +
11 2 files changed, 2 insertions(+), 1 deletion(-)
12
13Index: open-vm-tools/lib/dynxdr/Makefile.am
14===================================================================
15--- open-vm-tools.orig/lib/dynxdr/Makefile.am
16+++ open-vm-tools/lib/dynxdr/Makefile.am
17@@ -20,4 +20,4 @@ noinst_LTLIBRARIES = libDynxdr.la
18 libDynxdr_la_SOURCES =
19 libDynxdr_la_SOURCES += dynxdr.c
20 libDynxdr_la_SOURCES += xdrutil.c
21-
22+libDynxdr_la_CPPFLAGS = -Wno-incompatible-pointer-types
23Index: open-vm-tools/lib/file/Makefile.am
24===================================================================
25--- open-vm-tools.orig/lib/file/Makefile.am
26+++ open-vm-tools/lib/file/Makefile.am
27@@ -27,3 +27,4 @@ libFile_la_SOURCES += fileLockPrimitive.
28 libFile_la_SOURCES += fileLockPosix.c
29 libFile_la_SOURCES += fileTempPosix.c
30 libFile_la_SOURCES += fileTemp.c
31+libFile_la_CPPFLAGS = -Wno-error=address
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/use-tirpc.patch b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/use-tirpc.patch
deleted file mode 100644
index a6bb92486..000000000
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/use-tirpc.patch
+++ /dev/null
@@ -1,481 +0,0 @@
1Index: open-vm-tools/configure.ac
2===================================================================
3--- open-vm-tools.orig/configure.ac
4+++ open-vm-tools/configure.ac
5@@ -586,6 +586,11 @@ AC_ARG_WITH([xml2],
6 [enable_vgauth=no],
7 [with_xml2=yes])
8
9+AC_ARG_WITH([tirpc],
10+ [AS_HELP_STRING([--without-tirpc],
11+ [compiles without tirpc support.])],
12+ [with_tirpc="$withval"],
13+ [with_tirpc="auto"])
14
15 # Make sure we are building with openssl 1.0.1 and above so that
16 # we use only TLSv1_2.
17@@ -1067,10 +1072,45 @@ if test "$enable_caf" = "yes"; then
18
19 fi
20
21+have_tirpc="no"
22+if test "x$with_tirpc" != "xno"; then
23+ AC_VMW_CHECK_LIB([libtirpc],
24+ [TIRPC],
25+ [libtirpc],
26+ [],
27+ [],
28+ [],
29+ [],
30+ [have_tirpc="yes"],
31+ [have_tirpc="no"])
32+fi
33+
34+if test "$with_tirpc" = "no"; then
35+ use_tirpc="no"
36+elif test "$with_tirpc" = "auto"; then
37+ use_tirpc=$have_tirpc
38+elif test "$with_tirpc" = "yes"; then
39+ if test "$have_tirpc" = "no"; then
40+ AC_MSG_ERROR([libtirpc is required, but not found.])
41+ else
42+ use_tirpc="yes"
43+ fi
44+fi
45+
46+if test "$use_tirpc" = "yes"; then
47+ AC_MSG_NOTICE([Building with libtirpc])
48+else
49+ AC_MSG_NOTICE([Building without libtirpc])
50+fi
51+
52 AC_PATH_PROG(
53 [RPCGEN],
54 [rpcgen],
55- [ AC_MSG_ERROR([rpcgen not found. Please install the libc devel package.]) ])
56+ [not_found])
57+
58+if test "$RPCGEN" = "not_found"; then
59+ AC_MSG_ERROR([rpcgen not found. Please install libc-devel or libc-rpcgen package.])
60+fi
61
62 ###
63 ### Headers
64@@ -1411,6 +1451,7 @@ AM_CONDITIONAL(HAVE_MKDTEMP, test "$have
65 AM_CONDITIONAL(HAVE_UDEV, test "$have_udev" = "yes")
66 AM_CONDITIONAL(ENABLE_RESOLUTIONKMS, test "x$enable_resolutionkms" = "xyes")
67 AM_CONDITIONAL(VGAUTH_USE_CXX, test "$with_icu" = "yes" -o "$use_xmlsec1" != "yes")
68+AM_CONDITIONAL(HAVE_TIRPC, test "$use_tirpc" = "yes")
69
70 if test "$have_xsm" != "yes"; then
71 AC_DEFINE([NO_XSM], 1, [])
72@@ -1459,6 +1500,13 @@ if test "$os" = "solaris"; then
73 XDR_LIBS="-lnsl -lrpcsvc"
74 fi
75
76+# In newer Linux distros Sun RPC has been removed from libc
77+XDR_CPPFLAGS=
78+if test "$os" = "linux" -a "$use_tirpc" = "yes"; then
79+ XDR_CPPFLAGS="-DUSE_TIRPC $TIRPC_CPPFLAGS"
80+ XDR_LIBS="$TIRPC_LIBS"
81+fi
82+
83 # Installation directories for core services plugins.
84 TEST_PLUGIN_INSTALLDIR=$datadir/open-vm-tools/tests
85 COMMON_PLUGIN_INSTALLDIR=$libdir/open-vm-tools/plugins/common
86@@ -1497,6 +1545,7 @@ AC_SUBST([PLUGIN_LDFLAGS])
87 AC_SUBST([VMTOOLS_CPPFLAGS])
88 AC_SUBST([VMTOOLS_LIBS])
89 AC_SUBST([RPCGENFLAGS])
90+AC_SUBST([XDR_CPPFLAGS])
91 AC_SUBST([XDR_LIBS])
92 AC_SUBST([TEST_PLUGIN_INSTALLDIR])
93 AC_SUBST([COMMON_PLUGIN_INSTALLDIR])
94Index: open-vm-tools/lib/dynxdr/dynxdr.c
95===================================================================
96--- open-vm-tools.orig/lib/dynxdr/dynxdr.c
97+++ open-vm-tools/lib/dynxdr/dynxdr.c
98@@ -1,5 +1,5 @@
99 /*********************************************************
100- * Copyright (C) 2008-2017 VMware, Inc. All rights reserved.
101+ * Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
102 *
103 * This program is free software; you can redistribute it and/or modify it
104 * under the terms of the GNU Lesser General Public License as published
105@@ -55,7 +55,7 @@ typedef struct DynXdrData {
106 * Mac OS X, FreeBSD and Solaris don't take a const parameter to the
107 * "x_getpostn" function.
108 */
109-#if defined(__APPLE__) || defined(__FreeBSD__) || defined(sun)
110+#if defined(__APPLE__) || defined(__FreeBSD__) || defined(sun) || defined(USE_TIRPC)
111 # define DYNXDR_GETPOS_CONST
112 #else
113 # define DYNXDR_GETPOS_CONST const
114@@ -172,7 +172,11 @@ DynXdrSetPos(XDR *xdrs, // IN
115 }
116
117
118-#if defined(__GLIBC__) || (defined(sun) && (defined(_LP64) || defined(_KERNEL)))
119+#if !defined(USE_TIRPC) && \
120+ defined(__GLIBC__) || \
121+ (defined(sun) && \
122+ (defined(_LP64) || \
123+ defined(_KERNEL)))
124 /*
125 *-----------------------------------------------------------------------------
126 *
127@@ -322,11 +326,11 @@ DynXdr_Create(XDR *in) // IN
128 DynXdrSetPos, /* x_setpostn */
129 DynXdrInline, /* x_inline */
130 NULL, /* x_destroy */
131-#if defined(__GLIBC__)
132+#if defined(__APPLE__) || defined (USE_TIRPC)
133+ NULL, /* x_control */
134+#elif defined(__GLIBC__)
135 NULL, /* x_getint32 */
136 DynXdrPutInt32, /* x_putint32 */
137-#elif defined(__APPLE__)
138- NULL, /* x_control */
139 #elif defined(sun) && (defined(_LP64) || defined(_KERNEL))
140 NULL, /* x_control */
141 NULL, /* x_getint32 */
142Index: open-vm-tools/lib/dynxdr/Makefile.am
143===================================================================
144--- open-vm-tools.orig/lib/dynxdr/Makefile.am
145+++ open-vm-tools/lib/dynxdr/Makefile.am
146@@ -1,5 +1,5 @@
147 ################################################################################
148-### Copyright (C) 2008-2016 VMware, Inc. All rights reserved.
149+### Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
150 ###
151 ### This program is free software; you can redistribute it and/or modify
152 ### it under the terms of version 2 of the GNU General Public License as
153@@ -20,4 +20,7 @@ noinst_LTLIBRARIES = libDynxdr.la
154 libDynxdr_la_SOURCES =
155 libDynxdr_la_SOURCES += dynxdr.c
156 libDynxdr_la_SOURCES += xdrutil.c
157-libDynxdr_la_CPPFLAGS = -Wno-incompatible-pointer-types
158+
159+libDynxdr_la_CPPFLAGS = @XDR_CPPFLAGS@ -Wno-incompatible-pointer-types
160+libDynxdr_la_LIBADD = @XDR_LIBS@
161+
162Index: open-vm-tools/lib/guestRpc/Makefile.am
163===================================================================
164--- open-vm-tools.orig/lib/guestRpc/Makefile.am
165+++ open-vm-tools/lib/guestRpc/Makefile.am
166@@ -1,5 +1,5 @@
167 ################################################################################
168-### Copyright (C) 2008-2016 VMware, Inc. All rights reserved.
169+### Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
170 ###
171 ### This program is free software; you can redistribute it and/or modify
172 ### it under the terms of version 2 of the GNU General Public License as
173@@ -20,6 +20,10 @@ noinst_LTLIBRARIES = libGuestRpc.la
174 libGuestRpc_la_SOURCES =
175 libGuestRpc_la_SOURCES += nicinfo_xdr.c
176
177+libGuestRpc_la_CPPFLAGS = @XDR_CPPFLAGS@
178+
179+libGuestRpc_la_LIBADD = @XDR_LIBS@
180+
181 # XXX: Autoreconf complains about this and recommends using AM_CFLAGS instead.
182 # Problem is, $(CFLAGS) is appended to the compiler command line after AM_CFLAGS
183 # and after libGuestRpc_la_CFLAGS, so "-Wall -Werror" will override this flag.
184Index: open-vm-tools/lib/netUtil/Makefile.am
185===================================================================
186--- open-vm-tools.orig/lib/netUtil/Makefile.am
187+++ open-vm-tools/lib/netUtil/Makefile.am
188@@ -1,5 +1,5 @@
189 ################################################################################
190-### Copyright (C) 2007-2016 VMware, Inc. All rights reserved.
191+### Copyright (C) 2007-2018 VMware, Inc. All rights reserved.
192 ###
193 ### This program is free software; you can redistribute it and/or modify
194 ### it under the terms of version 2 of the GNU General Public License as
195@@ -20,3 +20,6 @@ noinst_LTLIBRARIES = libNetUtil.la
196 libNetUtil_la_SOURCES =
197 libNetUtil_la_SOURCES += netUtilLinux.c
198
199+libNetUtil_la_CPPFLAGS = @XDR_CPPFLAGS@
200+
201+libNetUtil_la_LIBADD = @XDR_LIBS@
202Index: open-vm-tools/lib/nicInfo/Makefile.am
203===================================================================
204--- open-vm-tools.orig/lib/nicInfo/Makefile.am
205+++ open-vm-tools/lib/nicInfo/Makefile.am
206@@ -1,5 +1,5 @@
207 ################################################################################
208-### Copyright (C) 2014-2016 VMware, Inc. All rights reserved.
209+### Copyright (C) 2014-2018 VMware, Inc. All rights reserved.
210 ###
211 ### This program is free software; you can redistribute it and/or modify
212 ### it under the terms of version 2 of the GNU General Public License as
213@@ -25,6 +25,9 @@ libNicInfo_la_SOURCES += nicInfoPosix.c
214
215 libNicInfo_la_CPPFLAGS =
216 libNicInfo_la_CPPFLAGS += @GLIB2_CPPFLAGS@
217+libNicInfo_la_CPPFLAGS += @XDR_CPPFLAGS@
218+
219+libNicInfo_la_LIBADD = @XDR_LIBS@
220
221 AM_CFLAGS = $(DNET_CPPFLAGS)
222 if USE_SLASH_PROC
223Index: open-vm-tools/lib/rpcChannel/Makefile.am
224===================================================================
225--- open-vm-tools.orig/lib/rpcChannel/Makefile.am
226+++ open-vm-tools/lib/rpcChannel/Makefile.am
227@@ -1,5 +1,5 @@
228 ################################################################################
229-### Copyright (C) 2009-2016 VMware, Inc. All rights reserved.
230+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
231 ###
232 ### This program is free software; you can redistribute it and/or modify
233 ### it under the terms of version 2 of the GNU General Public License as
234@@ -27,3 +27,6 @@ endif
235
236 libRpcChannel_la_CPPFLAGS =
237 libRpcChannel_la_CPPFLAGS += @VMTOOLS_CPPFLAGS@
238+libRpcChannel_la_CPPFLAGS += @XDR_CPPFLAGS@
239+
240+libRpcChannel_la_LIBADD = @XDR_LIBS@
241Index: open-vm-tools/lib/slashProc/net.c
242===================================================================
243--- open-vm-tools.orig/lib/slashProc/net.c
244+++ open-vm-tools/lib/slashProc/net.c
245@@ -1,5 +1,5 @@
246 /*********************************************************
247- * Copyright (C) 2009-2016 VMware, Inc. All rights reserved.
248+ * Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
249 *
250 * This program is free software; you can redistribute it and/or modify it
251 * under the terms of the GNU Lesser General Public License as published
252@@ -36,7 +36,6 @@
253 #include "panic.h"
254 #include "slashProc.h"
255 #include "slashProcNetInt.h"
256-#include "netutil.h"
257
258
259 /*
260Index: open-vm-tools/libguestlib/Makefile.am
261===================================================================
262--- open-vm-tools.orig/libguestlib/Makefile.am
263+++ open-vm-tools/libguestlib/Makefile.am
264@@ -1,5 +1,5 @@
265 ################################################################################
266-### Copyright (C) 2007-2016 VMware, Inc. All rights reserved.
267+### Copyright (C) 2007-2018 VMware, Inc. All rights reserved.
268 ###
269 ### This program is free software; you can redistribute it and/or modify
270 ### it under the terms of version 2 of the GNU General Public License as
271@@ -22,6 +22,7 @@ AM_CFLAGS += -I$(top_srcdir)/include
272
273 libguestlib_la_LIBADD =
274 libguestlib_la_LIBADD += @VMTOOLS_LIBS@
275+libguestlib_la_LIBADD += @XDR_LIBS@
276
277 libguestlib_la_SOURCES =
278 libguestlib_la_SOURCES += guestlibV3_xdr.c
279@@ -56,6 +57,7 @@ CFLAGS += -Wno-unused
280 libguestlib_la_CPPFLAGS =
281 libguestlib_la_CPPFLAGS += -DVMTOOLS_USE_GLIB
282 libguestlib_la_CPPFLAGS += @GLIB2_CPPFLAGS@
283+libguestlib_la_CPPFLAGS += @XDR_CPPFLAGS@
284
285 EXTRA_DIST = vmguestlib.pc.in
286
287Index: open-vm-tools/services/plugins/dndcp/Makefile.am
288===================================================================
289--- open-vm-tools.orig/services/plugins/dndcp/Makefile.am
290+++ open-vm-tools/services/plugins/dndcp/Makefile.am
291@@ -1,5 +1,5 @@
292 ################################################################################
293-### Copyright (C) 2009-2016 VMware, Inc. All rights reserved.
294+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
295 ###
296 ### This program is free software; you can redistribute it and/or modify
297 ### it under the terms of version 2 of the GNU General Public License as
298@@ -28,6 +28,7 @@ libdndcp_la_CPPFLAGS += -I$(top_srcdir)/
299 libdndcp_la_CPPFLAGS += -I$(top_srcdir)/services/plugins/dndcp/stringxx
300 libdndcp_la_CPPFLAGS += -I$(top_srcdir)/services/plugins/dndcp/xutils
301 libdndcp_la_CPPFLAGS += -I$(top_srcdir)/include
302+libdndcp_la_CPPFLAGS += @XDR_CPPFLAGS@
303
304 # Passing C++ related flags to CPPFLAGS generates error.
305 # So, we need to pass these to C++ compilation only.
306@@ -45,6 +46,7 @@ libdndcp_la_LIBADD += @GTKMM_LIBS@
307 libdndcp_la_LIBADD += @VMTOOLS_LIBS@
308 libdndcp_la_LIBADD += @HGFS_LIBS@
309 libdndcp_la_LIBADD += $(top_builddir)/lib/hgfsUri/hgfsUriPosix.lo
310+libdndcp_la_LIBADD += @XDR_LIBS@
311
312 libdndcp_la_SOURCES =
313
314Index: open-vm-tools/services/plugins/guestInfo/Makefile.am
315===================================================================
316--- open-vm-tools.orig/services/plugins/guestInfo/Makefile.am
317+++ open-vm-tools/services/plugins/guestInfo/Makefile.am
318@@ -1,5 +1,5 @@
319 ################################################################################
320-### Copyright (C) 2009-2017 VMware, Inc. All rights reserved.
321+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
322 ###
323 ### This program is free software; you can redistribute it and/or modify
324 ### it under the terms of version 2 of the GNU General Public License as
325@@ -22,6 +22,7 @@ plugin_LTLIBRARIES = libguestInfo.la
326
327 libguestInfo_la_CPPFLAGS =
328 libguestInfo_la_CPPFLAGS += @PLUGIN_CPPFLAGS@
329+libguestInfo_la_CPPFLAGS += @XDR_CPPFLAGS@
330
331 libguestInfo_la_LDFLAGS =
332 libguestInfo_la_LDFLAGS += @PLUGIN_LDFLAGS@
333Index: open-vm-tools/services/plugins/resolutionKMS/resolutionKMS.c
334===================================================================
335--- open-vm-tools.orig/services/plugins/resolutionKMS/resolutionKMS.c
336+++ open-vm-tools/services/plugins/resolutionKMS/resolutionKMS.c
337@@ -1,5 +1,5 @@
338 /*********************************************************
339- * Copyright (C) 2008-2017 VMware, Inc. All rights reserved.
340+ * Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
341 *
342 * This program is free software; you can redistribute it and/or modify it
343 * under the terms of the GNU Lesser General Public License as published
344@@ -29,16 +29,13 @@
345 #include <sys/stat.h>
346 #include <fcntl.h>
347
348+#include <stdio.h>
349 #include <stdlib.h>
350 #include <string.h>
351
352 #include "vmware.h"
353-#include "debug.h"
354-#include "rpcout.h"
355-#include "str.h"
356 #include "strutil.h"
357
358-#include "xdrutil.h"
359 #include "vmware/guestrpc/tclodefs.h"
360 #include "vmware/tools/plugin.h"
361 #include "vmware/tools/utils.h"
362Index: open-vm-tools/services/plugins/resolutionSet/resolutionSet.c
363===================================================================
364--- open-vm-tools.orig/services/plugins/resolutionSet/resolutionSet.c
365+++ open-vm-tools/services/plugins/resolutionSet/resolutionSet.c
366@@ -1,5 +1,5 @@
367 /*********************************************************
368- * Copyright (C) 2008-2017 VMware, Inc. All rights reserved.
369+ * Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
370 *
371 * This program is free software; you can redistribute it and/or modify it
372 * under the terms of the GNU Lesser General Public License as published
373@@ -34,7 +34,6 @@
374
375 #include "resolutionInt.h"
376
377-#include "xdrutil.h"
378 #include "vmware/guestrpc/tclodefs.h"
379 #include "vmware/tools/plugin.h"
380 #include "vmware/tools/utils.h"
381Index: open-vm-tools/services/plugins/vix/Makefile.am
382===================================================================
383--- open-vm-tools.orig/services/plugins/vix/Makefile.am
384+++ open-vm-tools/services/plugins/vix/Makefile.am
385@@ -1,5 +1,5 @@
386 ################################################################################
387-### Copyright (C) 2009-2016 VMware, Inc. All rights reserved.
388+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
389 ###
390 ### This program is free software; you can redistribute it and/or modify
391 ### it under the terms of version 2 of the GNU General Public License as
392@@ -20,6 +20,7 @@ plugin_LTLIBRARIES = libvix.la
393
394 libvix_la_CPPFLAGS =
395 libvix_la_CPPFLAGS += @PLUGIN_CPPFLAGS@
396+libvix_la_CPPFLAGS += @XDR_CPPFLAGS@
397 libvix_la_CPPFLAGS += -I$(top_srcdir)/vgauth/public
398
399 libvix_la_LDFLAGS =
400@@ -32,6 +33,7 @@ libvix_la_LIBADD += @HGFS_LIBS@
401 libvix_la_LIBADD += $(top_builddir)/lib/auth/libAuth.la
402 libvix_la_LIBADD += $(top_builddir)/lib/foundryMsg/libFoundryMsg.la
403 libvix_la_LIBADD += $(top_builddir)/lib/impersonate/libImpersonate.la
404+libvix_la_LIBADD += @XDR_LIBS@
405 if ENABLE_VGAUTH
406 libvix_la_LIBADD += $(top_builddir)/vgauth/lib/libvgauth.la
407 endif
408Index: open-vm-tools/services/plugins/vix/vixTools.c
409===================================================================
410--- open-vm-tools.orig/services/plugins/vix/vixTools.c
411+++ open-vm-tools/services/plugins/vix/vixTools.c
412@@ -91,7 +91,6 @@
413 #include "str.h"
414 #include "file.h"
415 #include "err.h"
416-#include "guestInfo.h" // MAX_VALUE_LEN
417 #include "hostinfo.h"
418 #include "guest_os.h"
419 #include "guest_msg_def.h"
420Index: open-vm-tools/services/plugins/vmbackup/Makefile.am
421===================================================================
422--- open-vm-tools.orig/services/plugins/vmbackup/Makefile.am
423+++ open-vm-tools/services/plugins/vmbackup/Makefile.am
424@@ -1,5 +1,5 @@
425 ################################################################################
426-### Copyright (C) 2009-2017 VMware, Inc. All rights reserved.
427+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
428 ###
429 ### This program is free software; you can redistribute it and/or modify
430 ### it under the terms of version 2 of the GNU General Public License as
431@@ -20,6 +20,7 @@ plugin_LTLIBRARIES = libvmbackup.la
432
433 libvmbackup_la_CPPFLAGS =
434 libvmbackup_la_CPPFLAGS += @PLUGIN_CPPFLAGS@
435+libvmbackup_la_CPPFLAGS += @XDR_CPPFLAGS@
436
437 libvmbackup_la_LDFLAGS =
438 libvmbackup_la_LDFLAGS += @PLUGIN_LDFLAGS@
439@@ -27,6 +28,7 @@ libvmbackup_la_LDFLAGS += @PLUGIN_LDFLAG
440 libvmbackup_la_LIBADD =
441 libvmbackup_la_LIBADD += @GOBJECT_LIBS@
442 libvmbackup_la_LIBADD += @VMTOOLS_LIBS@
443+libvmbackup_la_LIBADD += @XDR_LIBS@
444
445 libvmbackup_la_SOURCES =
446 libvmbackup_la_SOURCES += nullProvider.c
447Index: open-vm-tools/services/plugins/vmbackup/stateMachine.c
448===================================================================
449--- open-vm-tools.orig/services/plugins/vmbackup/stateMachine.c
450+++ open-vm-tools/services/plugins/vmbackup/stateMachine.c
451@@ -35,7 +35,6 @@
452
453 #include "vmBackupInt.h"
454
455-#include "dynxdr.h"
456 #include <glib-object.h>
457 #include <gmodule.h>
458 #include "guestApp.h"
459Index: open-vm-tools/toolbox/Makefile.am
460===================================================================
461--- open-vm-tools.orig/toolbox/Makefile.am
462+++ open-vm-tools/toolbox/Makefile.am
463@@ -1,5 +1,5 @@
464 ################################################################################
465-### Copyright (C) 2007-2016 VMware, Inc. All rights reserved.
466+### Copyright (C) 2007-2018 VMware, Inc. All rights reserved.
467 ###
468 ### This program is free software; you can redistribute it and/or modify
469 ### it under the terms of version 2 of the GNU General Public License as
470@@ -20,9 +20,11 @@ bin_PROGRAMS = vmware-toolbox-cmd
471 vmware_toolbox_cmd_LDADD =
472 vmware_toolbox_cmd_LDADD += ../libguestlib/libguestlib.la
473 vmware_toolbox_cmd_LDADD += @VMTOOLS_LIBS@
474+vmware_toolbox_cmd_LDADD += @XDR_LIBS@
475
476 vmware_toolbox_cmd_CPPFLAGS =
477 vmware_toolbox_cmd_CPPFLAGS += @VMTOOLS_CPPFLAGS@
478+vmware_toolbox_cmd_CPPFLAGS += @XDR_CPPFLAGS@
479
480 vmware_toolbox_cmd_SOURCES =
481 vmware_toolbox_cmd_SOURCES += toolbox-cmd.c
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.2.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
index 820c95bbd..478d762cf 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.2.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
@@ -14,7 +14,7 @@ HOMEPAGE = "https://github.com/vmware/open-vm-tools"
14SECTION = "vmware-tools" 14SECTION = "vmware-tools"
15 15
16LICENSE = "LGPL-2.0 & GPL-2.0 & BSD & CDDL-1.0" 16LICENSE = "LGPL-2.0 & GPL-2.0 & BSD & CDDL-1.0"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=e5000bc3c5a39b6e66579d72cc32b45a" 17LIC_FILES_CHKSUM = "file://LICENSE;md5=559317809c5444fb39ceaf6ac45c43ac"
18LICENSE_modules/freebsd/vmblock = "BSD" 18LICENSE_modules/freebsd/vmblock = "BSD"
19LICENSE_modules/freebsd/vmmemctl = "GPL-2.0" 19LICENSE_modules/freebsd/vmmemctl = "GPL-2.0"
20LICENSE_modules/freebsd/vmxnet = "GPL-2.0" 20LICENSE_modules/freebsd/vmxnet = "GPL-2.0"
@@ -27,20 +27,18 @@ SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
27 file://vmtoolsd.init \ 27 file://vmtoolsd.init \
28 file://0001-configure.ac-don-t-use-dnet-config.patch \ 28 file://0001-configure.ac-don-t-use-dnet-config.patch \
29 file://0002-add-include-sys-sysmacros.h.patch \ 29 file://0002-add-include-sys-sysmacros.h.patch \
30 file://0001-Remove-assumptions-about-glibc-being-only-libc-imple.patch \
31 file://0004-Add-Wno-incompatible-pointer-types-and-Wno-error-add.patch \
32 file://0005-Use-configure-test-for-struct-timespec.patch \ 30 file://0005-Use-configure-test-for-struct-timespec.patch \
33 file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \ 31 file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \
34 file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \ 32 file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \
35 file://0011-Use-configure-test-for-sys-stat.h-include.patch \ 33 file://0011-Use-configure-test-for-sys-stat.h-include.patch \
36 file://use-tirpc.patch \
37 file://fix-subdir-objects-configure-error.patch \ 34 file://fix-subdir-objects-configure-error.patch \
38 file://0001-include-poll.h-instead-of-sys-poll.h.patch \ 35 file://0001-include-poll.h-instead-of-sys-poll.h.patch \
39 file://0002-Rename-poll.h-to-vm_poll.h.patch \ 36 file://0002-Rename-poll.h-to-vm_poll.h.patch \
40 file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \ 37 file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \
41 file://0004-Use-uintmax_t-for-handling-rlim_t.patch \ 38 file://0004-Use-uintmax_t-for-handling-rlim_t.patch \
39 file://0001-Use-off64_t-instead-of-__off64_t.patch \
42 " 40 "
43SRCREV = "380a3d9747999e8bcbcbcd03b1402b702770db79" 41SRCREV = "2147df6aabe639fc5ff423ed791a8e7f02bf8d0a"
44 42
45S = "${WORKDIR}/git/open-vm-tools" 43S = "${WORKDIR}/git/open-vm-tools"
46 44