diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-11-15 17:43:35 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-11-26 01:07:20 +0100 |
commit | eef06e7cbed31dec67692fee36ccffc9e1a8658e (patch) | |
tree | 6ba8f667d4a333a58bf9dba62de7f2063c7d1507 /meta-oe | |
parent | c0eabbeccbed5644a072acc0c2c9f3025e372b8e (diff) | |
download | meta-openembedded-eef06e7cbed31dec67692fee36ccffc9e1a8658e.tar.gz |
flashrom: Remove redundant const qualifier
This is flagged by latest clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/flashrom/flashrom/0001-ichspi.c-Fix-build-with-clang.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-extended/flashrom/flashrom_0.9.6.1.bb | 1 |
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/flashrom/flashrom/0001-ichspi.c-Fix-build-with-clang.patch b/meta-oe/recipes-extended/flashrom/flashrom/0001-ichspi.c-Fix-build-with-clang.patch new file mode 100644 index 0000000000..ff16f0b113 --- /dev/null +++ b/meta-oe/recipes-extended/flashrom/flashrom/0001-ichspi.c-Fix-build-with-clang.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From a2f603c54013cd0b04bb0103dc615644f315d5e8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 15 Nov 2016 17:39:24 +0000 | ||
4 | Subject: [PATCH] ichspi.c: Fix build with clang | ||
5 | |||
6 | ichspi.c:1130:24: error: duplicate 'const' declaration specifier [-Werror,-Wduplicate-decl-specifier] | ||
7 | static const uint32_t const dec_berase[4] = { | ||
8 | ^ | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | ichspi.c | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/ichspi.c b/ichspi.c | ||
15 | index 0223ae3..e47aebd 100644 | ||
16 | --- a/ichspi.c | ||
17 | +++ b/ichspi.c | ||
18 | @@ -1127,7 +1127,7 @@ static void ich_hwseq_set_addr(uint32_t addr) | ||
19 | static uint32_t ich_hwseq_get_erase_block_size(unsigned int addr) | ||
20 | { | ||
21 | uint8_t enc_berase; | ||
22 | - static const uint32_t const dec_berase[4] = { | ||
23 | + static const uint32_t dec_berase[4] = { | ||
24 | 256, | ||
25 | 4 * 1024, | ||
26 | 8 * 1024, | ||
27 | -- | ||
28 | 1.9.1 | ||
29 | |||
diff --git a/meta-oe/recipes-extended/flashrom/flashrom_0.9.6.1.bb b/meta-oe/recipes-extended/flashrom/flashrom_0.9.6.1.bb index d3ec5780eb..0edc68820c 100644 --- a/meta-oe/recipes-extended/flashrom/flashrom_0.9.6.1.bb +++ b/meta-oe/recipes-extended/flashrom/flashrom_0.9.6.1.bb | |||
@@ -9,6 +9,7 @@ SRC_URI = "http://download.flashrom.org/releases/flashrom-${PV}.tar.bz2 \ | |||
9 | file://0001-Fix-compilation-on-aarch64.patch \ | 9 | file://0001-Fix-compilation-on-aarch64.patch \ |
10 | file://0002-Disable-Wtautological-pointer-compare-when-using-cla.patch \ | 10 | file://0002-Disable-Wtautological-pointer-compare-when-using-cla.patch \ |
11 | file://0003-remove-duplicate-const-qualifiers.patch \ | 11 | file://0003-remove-duplicate-const-qualifiers.patch \ |
12 | file://0001-ichspi.c-Fix-build-with-clang.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRC_URI[md5sum] = "407e836c0a2b17ec76583cb6809f65e5" | 15 | SRC_URI[md5sum] = "407e836c0a2b17ec76583cb6809f65e5" |