summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-05-02 10:48:01 -0400
committerKhem Raj <raj.khem@gmail.com>2024-05-02 07:32:48 -0700
commitedccd846b943fddbe3e68caf5fb773c64ea822d1 (patch)
tree5bf3f68e18143b9689f0208cd0a5b652bcfd463f /meta-oe
parenta733b0c75c8111a79cd35a1e78651c78b9bbd2ef (diff)
downloadmeta-openembedded-edccd846b943fddbe3e68caf5fb773c64ea822d1.tar.gz
iniparser: upgrade 4.1 -> 4.2
License-Update: Copyright year updated to 2024. CVE-2023-33461.patch removed since it's included in 4.2 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/iniparser/iniparser/CVE-2023-33461.patch48
-rw-r--r--meta-oe/recipes-support/iniparser/iniparser_4.2.bb (renamed from meta-oe/recipes-support/iniparser/iniparser_4.1.bb)7
2 files changed, 3 insertions, 52 deletions
diff --git a/meta-oe/recipes-support/iniparser/iniparser/CVE-2023-33461.patch b/meta-oe/recipes-support/iniparser/iniparser/CVE-2023-33461.patch
deleted file mode 100644
index db5fb06aa..000000000
--- a/meta-oe/recipes-support/iniparser/iniparser/CVE-2023-33461.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1CVE: CVE-2023-33461
2Upstream-Status: Backport [https://github.com/ndevilla/iniparser/pull/146/commits/ace9871f65d11b5d73f0b9ee8cf5d2807439442d]
3Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com>
4
5
6From ace9871f65d11b5d73f0b9ee8cf5d2807439442d Mon Sep 17 00:00:00 2001
7From: Antonio <antoniolrt@gmail.com>
8Date: Fri, 2 Jun 2023 15:03:10 -0300
9Subject: [PATCH] Handle null return from iniparser_getstring
10
11Fix handling of NULL returns from iniparser_getstring in
12iniparser_getboolean, iniparser_getlongint and iniparser_getdouble,
13avoiding a crash.
14---
15 src/iniparser.c | 6 +++---
16 1 file changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/src/iniparser.c b/src/iniparser.c
19index f1d1658..dbceb20 100644
20--- a/src/iniparser.c
21+++ b/src/iniparser.c
22@@ -456,7 +456,7 @@ long int iniparser_getlongint(const dictionary * d, const char * key, long int n
23 const char * str ;
24
25 str = iniparser_getstring(d, key, INI_INVALID_KEY);
26- if (str==INI_INVALID_KEY) return notfound ;
27+ if (str==NULL || str==INI_INVALID_KEY) return notfound ;
28 return strtol(str, NULL, 0);
29 }
30
31@@ -511,7 +511,7 @@ double iniparser_getdouble(const dictionary * d, const char * key, double notfou
32 const char * str ;
33
34 str = iniparser_getstring(d, key, INI_INVALID_KEY);
35- if (str==INI_INVALID_KEY) return notfound ;
36+ if (str==NULL || str==INI_INVALID_KEY) return notfound ;
37 return atof(str);
38 }
39
40@@ -553,7 +553,7 @@ int iniparser_getboolean(const dictionary * d, const char * key, int notfound)
41 const char * c ;
42
43 c = iniparser_getstring(d, key, INI_INVALID_KEY);
44- if (c==INI_INVALID_KEY) return notfound ;
45+ if (c==NULL || c==INI_INVALID_KEY) return notfound ;
46 if (c[0]=='y' || c[0]=='Y' || c[0]=='1' || c[0]=='t' || c[0]=='T') {
47 ret = 1 ;
48 } else if (c[0]=='n' || c[0]=='N' || c[0]=='0' || c[0]=='f' || c[0]=='F') {
diff --git a/meta-oe/recipes-support/iniparser/iniparser_4.1.bb b/meta-oe/recipes-support/iniparser/iniparser_4.2.bb
index c80668d27..d44772590 100644
--- a/meta-oe/recipes-support/iniparser/iniparser_4.1.bb
+++ b/meta-oe/recipes-support/iniparser/iniparser_4.2.bb
@@ -2,7 +2,7 @@ SUMMARY = "The iniParser library is a simple C library offering INI file parsing
2SECTION = "libs" 2SECTION = "libs"
3HOMEPAGE = "https://github.com/ndevilla/iniparser" 3HOMEPAGE = "https://github.com/ndevilla/iniparser"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e02baf71c76e0650e667d7da133379ac" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=8474d3b745f77e203f1fc82fb0bb7678"
6 6
7DEPENDS = "doxygen-native" 7DEPENDS = "doxygen-native"
8 8
@@ -10,11 +10,10 @@ PV .= "+git"
10 10
11SRC_URI = "git://github.com/ndevilla/iniparser.git;protocol=https;branch=master \ 11SRC_URI = "git://github.com/ndevilla/iniparser.git;protocol=https;branch=master \
12 file://0001-iniparser.pc-Make-libpath-a-variable.patch \ 12 file://0001-iniparser.pc-Make-libpath-a-variable.patch \
13 file://Add-CMake-support.patch \ 13 file://Add-CMake-support.patch \
14 file://CVE-2023-33461.patch \
15" 14"
16 15
17SRCREV= "deb85ad4936d4ca32cc2260ce43323d47936410d" 16SRCREV = "9f5a6da1c245b44f49a46212ec0d81ffb1f821aa"
18 17
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19