diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-05-25 22:38:03 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-26 08:28:37 -0700 |
commit | e770e09e40bd9ec65412b0e1023e71694e348427 (patch) | |
tree | bc3e7f9087e362bafa3043ce021bd63e880f7ec9 /meta-oe | |
parent | 6ab0ca758a901afc70104372cabaf79301f933ec (diff) | |
download | meta-openembedded-e770e09e40bd9ec65412b0e1023e71694e348427.tar.gz |
ipmiutil: Upgrade to 3.1.9
Changes
03/12/2020 ARCress ipmiutil-3.1.6 changes (iver 3.16)
util/iconfig.c - fix Fedora bug 1811462 [abrt] ipmiutil config -a
util/ipmiutil.c - show version with usage in -h case
scripts/ipmiutil.env.template - renamed env as template
(contributed by mwilliams<at>illuminate.solutions)
scripts/Makefile.am - renamed env as template
scripts/checksel - also rm -f $ddir/sel.idx after isel -d
(contributed by eguzovsky<at>gmail.com)
doc/Makefile.am - change gzip -f to gzip -nf for man pages
(SR#40 patch from Jeremy Puhlman)
08/31/2020 ARCress ipmiutil-3.1.7 changes (iver 3.17)
setup/* - added Win msi setup files
lib/lanplus/lanplus.c - revert WIN IPv6 changes, add os_assert routine
lib/lanplus/lanplus_crypt.c - switch assert to os_assert/return
lib/lanplus/lanplus_crypt_implc.c - switch assert to os_assert
util/ipmidir.h - AMD_SMB_1_STATUS_* 1< to 1<< (SF_SR#41)
util/isel.c - fix compile warning
util/ilan.c - fix compile warning
configure.ac - add --enable-doc option to allow not building documentation
contributed by Fabrice Fontaine (ffontaine)
util/isensor.c - add SDR conflict 0xC5 handling retries with delay
contributed by albertlav
11/15/2021 ARCress ipmiutil-3.1.8 changes (iver 3.18)
libeay32.dll - updated for Windows 64 lanplus
ssleay32.dll - updated for Windows 64 lanplus
util/oem_supermicro.c - disable DIMM decoding from SMBIOS for SuperMicro (albertlav)
util/ilan.c - new -W option to limit lan settings
util/ipmicmd.h - add VENDOR_MITAC
util/subs.c - add VENDOR_MITAC
util/ipmilanplus.c - print reason if no lan2
util/ipmilan2.c - print reason if no lan2
util/isensor.c - never skip free_sdr_cache() SR#45
configure.ac - fix --disable-lanplus option to avoid random disables,
recognize openssl-3.0 for SSL flags
03/03/2023 ARCress ipmiutil-3.1.9 changes (iver 3.19)
util/isensor.c - fix -i get_idx_range to show last idx in range
util/igetevent.c - fix printf extra arg
util/memif.c - SR56: try UEFI address 6d5a7000 if F0000 error
configure.ac - Clang 16 fixes, resolve -Wimplicit-function-declaration issues
(Sam James sam@gentoo.org 11/16/2022)
lib/lanplus/lanplus.h - resolve implicit os_assert declaration (Sam James)
util/ireset.c - SR58: remove is_romley case for ireset -D
scripts/ipmiutil_wdt - SR43: changed $prog to $progn for Debian
scripts/uninstall.vbs - SR53: add ; to fix path
SR53 (Windows): install libeay32.dll, ssleay32.dll into ipmiutil path also
util/ipmidir.c - ipmi_open_direct(char)
util/mem_if.c - UCHAR/int
doc/ipmiutil.spec - enumerate ipmiutil.env, ipmiutil.env.template
configure.ac - add -Wlto-type-mismatch to cfwarn
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-kernel/ipmiutil/ipmiutil/0001-Prevent-access-times-from-changing-resulting-gzip-md.patch | 25 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/ipmiutil/ipmiutil/fix_systemd_path.patch | 25 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/ipmiutil/ipmiutil_3.1.9.bb (renamed from meta-oe/recipes-kernel/ipmiutil/ipmiutil_3.1.5.bb) | 4 |
3 files changed, 11 insertions, 43 deletions
diff --git a/meta-oe/recipes-kernel/ipmiutil/ipmiutil/0001-Prevent-access-times-from-changing-resulting-gzip-md.patch b/meta-oe/recipes-kernel/ipmiutil/ipmiutil/0001-Prevent-access-times-from-changing-resulting-gzip-md.patch deleted file mode 100644 index 78c05ef32c..0000000000 --- a/meta-oe/recipes-kernel/ipmiutil/ipmiutil/0001-Prevent-access-times-from-changing-resulting-gzip-md.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From da668e5bf1a721797361ab866d09913ee8e157c4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jeremy Puhlman <jpuhlman@mvista.com> | ||
3 | Date: Sat, 22 Feb 2020 04:37:04 +0000 | ||
4 | Subject: [PATCH] Prevent access times from changing resulting gzip md5sum | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | https://github.com/ipmitool/ipmitool/pull/186 | ||
8 | --- | ||
9 | doc/Makefile.am | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/doc/Makefile.am b/doc/Makefile.am | ||
13 | index b792762..2c52ce6 100644 | ||
14 | --- a/doc/Makefile.am | ||
15 | +++ b/doc/Makefile.am | ||
16 | @@ -59,5 +59,5 @@ install: | ||
17 | ${INSTALL_DATA_SH} iuser.8 ${manto} | ||
18 | ${INSTALL_DATA_SH} iseltime.8 ${manto} | ||
19 | ${INSTALL_DATA_SH} bmclanpet.mib ${datato} | ||
20 | - cd ${manto}; gzip -f *.8 | ||
21 | + cd ${manto}; gzip -nf *.8 | ||
22 | |||
23 | -- | ||
24 | 2.13.3 | ||
25 | |||
diff --git a/meta-oe/recipes-kernel/ipmiutil/ipmiutil/fix_systemd_path.patch b/meta-oe/recipes-kernel/ipmiutil/ipmiutil/fix_systemd_path.patch index d47e086c46..2862793b05 100644 --- a/meta-oe/recipes-kernel/ipmiutil/ipmiutil/fix_systemd_path.patch +++ b/meta-oe/recipes-kernel/ipmiutil/ipmiutil/fix_systemd_path.patch | |||
@@ -6,11 +6,9 @@ Upstream-Status: Inappropriate [Embedded] | |||
6 | 6 | ||
7 | Signed-off-by: Armin Kuster <akuster@mvista.com> | 7 | Signed-off-by: Armin Kuster <akuster@mvista.com> |
8 | 8 | ||
9 | Index: ipmiutil-3.0.5/configure.ac | 9 | --- a/configure.ac |
10 | =================================================================== | 10 | +++ b/configure.ac |
11 | --- ipmiutil-3.0.5.orig/configure.ac | 11 | @@ -151,7 +151,6 @@ CROSS_LFLAGS="" |
12 | +++ ipmiutil-3.0.5/configure.ac | ||
13 | @@ -149,7 +149,6 @@ CROSS_LFLAGS="" | ||
14 | CROSS_CFLAGS="" | 12 | CROSS_CFLAGS="" |
15 | LIBSENSORS="" | 13 | LIBSENSORS="" |
16 | SAM2OBJ="isensor2.o ievents2.o" | 14 | SAM2OBJ="isensor2.o ievents2.o" |
@@ -18,7 +16,7 @@ Index: ipmiutil-3.0.5/configure.ac | |||
18 | 16 | ||
19 | AC_ARG_ENABLE([useflags], | 17 | AC_ARG_ENABLE([useflags], |
20 | [ --enable-useflags include environment CFLAGS and LDFLAGS.], | 18 | [ --enable-useflags include environment CFLAGS and LDFLAGS.], |
21 | @@ -200,29 +199,42 @@ AC_ARG_ENABLE([gpl], | 19 | @@ -211,29 +210,42 @@ AC_ARG_ENABLE([gpl], |
22 | 20 | ||
23 | dnl Does this Linux have systemd enabled? Otherwise use sysv init. | 21 | dnl Does this Linux have systemd enabled? Otherwise use sysv init. |
24 | AC_ARG_ENABLE([systemd], | 22 | AC_ARG_ENABLE([systemd], |
@@ -83,7 +81,7 @@ Index: ipmiutil-3.0.5/configure.ac | |||
83 | fi | 81 | fi |
84 | 82 | ||
85 | dnl start main logic | 83 | dnl start main logic |
86 | @@ -528,7 +540,7 @@ AC_SUBST(INS_LIB) | 84 | @@ -563,7 +575,7 @@ AC_SUBST(INS_LIB) |
87 | AC_SUBST(SUBDIR_S) | 85 | AC_SUBST(SUBDIR_S) |
88 | AC_SUBST(CROSS_CFLAGS) | 86 | AC_SUBST(CROSS_CFLAGS) |
89 | AC_SUBST(CROSS_LFLAGS) | 87 | AC_SUBST(CROSS_LFLAGS) |
@@ -92,10 +90,8 @@ Index: ipmiutil-3.0.5/configure.ac | |||
92 | AC_SUBST(SHR_LINK) | 90 | AC_SUBST(SHR_LINK) |
93 | AC_SUBST(pkgconfigdir) | 91 | AC_SUBST(pkgconfigdir) |
94 | 92 | ||
95 | Index: ipmiutil-3.0.5/scripts/Makefile.am | 93 | --- a/scripts/Makefile.am |
96 | =================================================================== | 94 | +++ b/scripts/Makefile.am |
97 | --- ipmiutil-3.0.5.orig/scripts/Makefile.am | ||
98 | +++ ipmiutil-3.0.5/scripts/Makefile.am | ||
99 | @@ -17,7 +17,8 @@ cronto = ${DESTDIR}${etcdir}/cron.daily | 95 | @@ -17,7 +17,8 @@ cronto = ${DESTDIR}${etcdir}/cron.daily |
100 | sbinto = ${DESTDIR}${sbindir} | 96 | sbinto = ${DESTDIR}${sbindir} |
101 | varto = ${DESTDIR}/var/lib/ipmiutil | 97 | varto = ${DESTDIR}/var/lib/ipmiutil |
@@ -106,7 +102,7 @@ Index: ipmiutil-3.0.5/scripts/Makefile.am | |||
106 | sysvinit = ${datato} | 102 | sysvinit = ${datato} |
107 | sbinfls = ialarms ihealth ifru igetevent ireset icmd isol ilan isensor isel iserial iwdt iconfig ipicmg ifirewall ifwum ihpm iuser | 103 | sbinfls = ialarms ihealth ifru igetevent ireset icmd isol ilan isensor isel iserial iwdt iconfig ipicmg ifirewall ifwum ihpm iuser |
108 | 104 | ||
109 | @@ -47,10 +48,14 @@ install: | 105 | @@ -47,10 +48,13 @@ install: |
110 | ${INSTALL_SCRIPT_SH} ipmi_port.sh ${sysvinit}/ipmi_port | 106 | ${INSTALL_SCRIPT_SH} ipmi_port.sh ${sysvinit}/ipmi_port |
111 | ${INSTALL_SCRIPT_SH} ipmi_info ${sysvinit}/ipmi_info | 107 | ${INSTALL_SCRIPT_SH} ipmi_info ${sysvinit}/ipmi_info |
112 | ${INSTALL_SCRIPT_SH} checksel ${datato} | 108 | ${INSTALL_SCRIPT_SH} checksel ${datato} |
@@ -114,7 +110,6 @@ Index: ipmiutil-3.0.5/scripts/Makefile.am | |||
114 | - ${INSTALL_DATA_SH} ipmiutil_asy.service ${sysdto} | 110 | - ${INSTALL_DATA_SH} ipmiutil_asy.service ${sysdto} |
115 | - ${INSTALL_DATA_SH} ipmiutil_evt.service ${sysdto} | 111 | - ${INSTALL_DATA_SH} ipmiutil_evt.service ${sysdto} |
116 | - ${INSTALL_DATA_SH} ipmi_port.service ${sysdto} | 112 | - ${INSTALL_DATA_SH} ipmi_port.service ${sysdto} |
117 | + | ||
118 | + if [ ! -z "${systemddir}" ]; then \ | 113 | + if [ ! -z "${systemddir}" ]; then \ |
119 | + $(MKDIR) ${sysdto}; \ | 114 | + $(MKDIR) ${sysdto}; \ |
120 | + ${INSTALL_DATA_SH} ipmiutil_wdt.service ${sysdto}; \ | 115 | + ${INSTALL_DATA_SH} ipmiutil_wdt.service ${sysdto}; \ |
@@ -122,6 +117,6 @@ Index: ipmiutil-3.0.5/scripts/Makefile.am | |||
122 | + ${INSTALL_DATA_SH} ipmiutil_evt.service ${sysdto}; \ | 117 | + ${INSTALL_DATA_SH} ipmiutil_evt.service ${sysdto}; \ |
123 | + ${INSTALL_DATA_SH} ipmi_port.service ${sysdto}; \ | 118 | + ${INSTALL_DATA_SH} ipmi_port.service ${sysdto}; \ |
124 | + fi | 119 | + fi |
125 | ${INSTALL_SCRIPT_SH} ipmiutil.env ${datato} | 120 | ${INSTALL_SCRIPT_SH} ipmiutil.env.template ${datato} |
121 | ${INSTALL_SCRIPT_SH} ipmiutil.env.template ${datato}/ipmiutil.env | ||
126 | ${INSTALL_SCRIPT_SH} ipmiutil.pre ${datato} | 122 | ${INSTALL_SCRIPT_SH} ipmiutil.pre ${datato} |
127 | ${INSTALL_SCRIPT_SH} ipmiutil.setup ${datato} | ||
diff --git a/meta-oe/recipes-kernel/ipmiutil/ipmiutil_3.1.5.bb b/meta-oe/recipes-kernel/ipmiutil/ipmiutil_3.1.9.bb index 64bcf5f764..daf084f399 100644 --- a/meta-oe/recipes-kernel/ipmiutil/ipmiutil_3.1.5.bb +++ b/meta-oe/recipes-kernel/ipmiutil/ipmiutil_3.1.9.bb | |||
@@ -21,11 +21,9 @@ PARALLEL_MAKE = "" | |||
21 | 21 | ||
22 | SRC_URI = "${SOURCEFORGE_MIRROR}/ipmiutil/ipmiutil-${PV}.tar.gz \ | 22 | SRC_URI = "${SOURCEFORGE_MIRROR}/ipmiutil/ipmiutil-${PV}.tar.gz \ |
23 | file://fix_systemd_path.patch \ | 23 | file://fix_systemd_path.patch \ |
24 | file://0001-Prevent-access-times-from-changing-resulting-gzip-md.patch \ | ||
25 | file://0001-ihpm-Include-stdlib.h-for-malloc-free-atoi-functions.patch \ | 24 | file://0001-ihpm-Include-stdlib.h-for-malloc-free-atoi-functions.patch \ |
26 | " | 25 | " |
27 | SRC_URI[md5sum] = "292d6df25cad678bb27e5c8cdc6748f9" | 26 | SRC_URI[sha256sum] = "5ae99bdd1296a8e25cea839784ec39ebca57b0e3701b2d440b8e02e22dc4bc95" |
28 | SRC_URI[sha256sum] = "58ccdbd5755d7dd72478756715af09e9c73330dfad2b91dbf03d2ac504b301a3" | ||
29 | 27 | ||
30 | inherit autotools-brokensep pkgconfig systemd | 28 | inherit autotools-brokensep pkgconfig systemd |
31 | 29 | ||