diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-03-08 20:54:17 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-08 20:55:21 -0800 |
commit | e352b5bda731060894575bf8c768f50c203fb548 (patch) | |
tree | 0f3734f51472ec96ba9c94e668a649c615497d5d /meta-oe | |
parent | 63a96ba46f54a667ab8280b20f07d240498f9b52 (diff) | |
download | meta-openembedded-e352b5bda731060894575bf8c768f50c203fb548.tar.gz |
musl-nscd: Make lex syntax posix'y
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/musl/musl-nscd/0001-nsswitch.y-Replace-empty-bison-extension.patch | 50 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/musl/musl-nscd_git.bb | 1 |
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/musl/musl-nscd/0001-nsswitch.y-Replace-empty-bison-extension.patch b/meta-oe/recipes-devtools/musl/musl-nscd/0001-nsswitch.y-Replace-empty-bison-extension.patch new file mode 100644 index 0000000000..67c8b1bcfd --- /dev/null +++ b/meta-oe/recipes-devtools/musl/musl-nscd/0001-nsswitch.y-Replace-empty-bison-extension.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | From 82e51fb8ba2640b318826ef4e17b0f5c09c8dded Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 8 Mar 2021 20:10:18 -0800 | ||
4 | Subject: [PATCH] nsswitch.y: Replace %empty bison extension | ||
5 | |||
6 | POSIX compliant yacc do not understand %empty therefore replace it with | ||
7 | /* empty */ | ||
8 | |||
9 | https://github.com/pikhq/musl-nscd/issues/13 | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | src/nsswitch.y | 6 +++--- | ||
15 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
16 | |||
17 | diff --git a/src/nsswitch.y b/src/nsswitch.y | ||
18 | index 107073b..0b7c71e 100644 | ||
19 | --- a/src/nsswitch.y | ||
20 | +++ b/src/nsswitch.y | ||
21 | @@ -38,7 +38,7 @@ top: | ||
22 | ; | ||
23 | |||
24 | file: | ||
25 | - %empty { | ||
26 | + /* empty */ { | ||
27 | list_init(&$$); | ||
28 | } | ||
29 | | file line { | ||
30 | @@ -88,7 +88,7 @@ modifier: | ||
31 | ; | ||
32 | |||
33 | modifiers: | ||
34 | - %empty { | ||
35 | + /* empty */ { | ||
36 | memcpy($$, default_actions, sizeof($$)); | ||
37 | } | ||
38 | | modifiers modifier { | ||
39 | @@ -112,7 +112,7 @@ item: | ||
40 | ; | ||
41 | |||
42 | list: | ||
43 | - %empty { | ||
44 | + /* empty */ { | ||
45 | list_init(&$$); | ||
46 | } | ||
47 | | list item { | ||
48 | -- | ||
49 | 2.30.1 | ||
50 | |||
diff --git a/meta-oe/recipes-devtools/musl/musl-nscd_git.bb b/meta-oe/recipes-devtools/musl/musl-nscd_git.bb index 83125a1ba4..6af7ab9cd8 100644 --- a/meta-oe/recipes-devtools/musl/musl-nscd_git.bb +++ b/meta-oe/recipes-devtools/musl/musl-nscd_git.bb | |||
@@ -15,6 +15,7 @@ SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4" | |||
15 | SRC_URI = "git://github.com/pikhq/musl-nscd \ | 15 | SRC_URI = "git://github.com/pikhq/musl-nscd \ |
16 | file://0001-Fix-build-under-GCC-fno-common.patch \ | 16 | file://0001-Fix-build-under-GCC-fno-common.patch \ |
17 | file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \ | 17 | file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \ |
18 | file://0001-nsswitch.y-Replace-empty-bison-extension.patch \ | ||
18 | " | 19 | " |
19 | 20 | ||
20 | UPSTREAM_CHECK_COMMITS = "1" | 21 | UPSTREAM_CHECK_COMMITS = "1" |