summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-05 21:45:20 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-08 13:32:12 -0700
commitd8ed62ddc7f32310ad85271ca7e8b5f173a22e59 (patch)
treec1e0151206c65368a60acc45209baff5762c9592 /meta-oe
parenta483d344d9fb42709c09b523c1768f4142ab9da4 (diff)
downloadmeta-openembedded-d8ed62ddc7f32310ad85271ca7e8b5f173a22e59.tar.gz
synergy: Upgrade to 1.10.1-release
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/synergy/synergy_git.bb27
1 files changed, 8 insertions, 19 deletions
diff --git a/meta-oe/recipes-support/synergy/synergy_git.bb b/meta-oe/recipes-support/synergy/synergy_git.bb
index 68f0387ba..f5518bd8c 100644
--- a/meta-oe/recipes-support/synergy/synergy_git.bb
+++ b/meta-oe/recipes-support/synergy/synergy_git.bb
@@ -1,35 +1,24 @@
1SUMMARY = "Synergy - control multiple computers with one keyboard and mouse" 1SUMMARY = "Synergy - control multiple computers with one keyboard and mouse"
2HOMEPAGE = "http://synergy-project.org" 2HOMEPAGE = "http://synergy-project.org"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=d2ba51ca68e055566aade24662f9eb41" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=54c1fc8d8bb6776ae501acfb1585e9d6"
4LICENSE = "GPL-2.0-with-OpenSSL-exception" 4LICENSE = "GPL-2.0-with-OpenSSL-exception"
5SECTION = "x11/utils" 5SECTION = "x11/utils"
6 6
7DEPENDS = "virtual/libx11 libxtst libxinerama curl openssl" 7DEPENDS = "virtual/libx11 libxtst libxinerama curl openssl"
8do_unpack_extra[depends] = "unzip-native:do_populate_sysroot"
9 8
10# depends on virtual/libx11 9# depends on virtual/libx11
11REQUIRED_DISTRO_FEATURES = "x11" 10REQUIRED_DISTRO_FEATURES = "x11"
12 11
13SRC_URI = "git://github.com/symless/synergy.git;protocol=http" 12SRC_URI = "git://github.com/symless/synergy-core;protocol=https;nobranch=1"
14 13
15# Version 1.8.8-stable 14# Version 1.10.1-stable
16SRCREV ?= "c30301e23424db1125664da17deb8c3aa6aec52d" 15SRCREV ?= "1b4c076127687aceac931d269e898beaac1cad9f"
17PV = "1.8.8+${SRCPV}" 16PV = "1.10.1+git${SRCPV}"
18 17
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19
21inherit cmake distro_features_check 20inherit cmake distro_features_check
22 21
23do_unpack_extra() { 22EXTRA_OECMAKE += "-DSYNERGY_BUILD_LEGACY_GUI=OFF"
24 cd ${S}/ext 23
25 for file in *.zip; do 24FILES_${PN} += "${datadir}/icons/hicolor"
26 fname="${file##*/}"
27 unzip $file -d ${fname%.*}
28 done
29}
30addtask unpack_extra after do_unpack before do_patch
31
32do_install() {
33 install -d ${D}/usr/bin
34 install -m 0755 ${S}/bin/synergy* ${D}/usr/bin/
35}