summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-30 22:40:15 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-31 10:06:32 -0700
commitc9e205eb6ec3455ec522829db11c5be1ef233c0f (patch)
tree2e6882b4bc0d7c6a24d81d53d586e79693ab9eb1 /meta-oe
parent0a84141417bf53f6f91c307515dcd9a09391e5a1 (diff)
downloadmeta-openembedded-c9e205eb6ec3455ec522829db11c5be1ef233c0f.tar.gz
geany-plugins: Fix type error found with clang 15
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/geany/geany-plugins/0001-scope-Use-0-instead-of-NULL-for-gboolean.patch34
-rw-r--r--meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/geany/geany-plugins/0001-scope-Use-0-instead-of-NULL-for-gboolean.patch b/meta-oe/recipes-devtools/geany/geany-plugins/0001-scope-Use-0-instead-of-NULL-for-gboolean.patch
new file mode 100644
index 000000000..bb03fa63d
--- /dev/null
+++ b/meta-oe/recipes-devtools/geany/geany-plugins/0001-scope-Use-0-instead-of-NULL-for-gboolean.patch
@@ -0,0 +1,34 @@
1From 9ee9388bc66e6cf68db96b2014dca2115f745dc9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 30 Aug 2022 22:33:46 -0700
4Subject: [PATCH] scope: Use 0 instead of NULL for gboolean
5
6Fixes warnings with clang 15+
7
8scope/src/stack.c:168:11: error: incompatible pointer to integer conversion initializing 'gboolean' (aka 'int') with an expression of type 'void *' [-Wint-conversion]
9 gboolean entry = NULL;
10 ^ ~~~~
111 error generated.
12
13Upstream-Status: Submitted [https://github.com/geany/geany-plugins/pull/1191]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 scope/src/stack.c | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/scope/src/stack.c b/scope/src/stack.c
20index b03909fe..041dd415 100644
21--- a/scope/src/stack.c
22+++ b/scope/src/stack.c
23@@ -165,7 +165,7 @@ void on_stack_follow(GArray *nodes)
24 gboolean stack_entry(void)
25 {
26 GtkTreeIter iter;
27- gboolean entry = NULL;
28+ gboolean entry = 0;
29
30 if (gtk_tree_selection_get_selected(selection, NULL, &iter))
31 {
32--
332.37.3
34
diff --git a/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb b/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb
index fa4cccca0..1ed2993bf 100644
--- a/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb
+++ b/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb
@@ -33,6 +33,7 @@ SRC_URI = " \
33 file://0001-Use-pkg-config-to-find-gpgme.patch \ 33 file://0001-Use-pkg-config-to-find-gpgme.patch \
34 file://0001-git-changebar-Adjust-structs-for-libgit2-1.4.x.patch \ 34 file://0001-git-changebar-Adjust-structs-for-libgit2-1.4.x.patch \
35 file://0001-geany.m4-Do-not-tinker-with-pkg-config-paths.patch \ 35 file://0001-geany.m4-Do-not-tinker-with-pkg-config-paths.patch \
36 file://0001-scope-Use-0-instead-of-NULL-for-gboolean.patch \
36" 37"
37SRC_URI[sha256sum] = "1c578a7ebb390aa8882f195acd3d8da3ceb73925d291b28dec90cd3e5fd20586" 38SRC_URI[sha256sum] = "1c578a7ebb390aa8882f195acd3d8da3ceb73925d291b28dec90cd3e5fd20586"
38 39