summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 17:38:20 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-25 18:52:52 -0700
commitbaf8e1e39b23e9271b1b8da16714d5d0b2c91d5d (patch)
treeec32eeb308740b76610f8ee0710dd88c7c40c999 /meta-oe
parentaa1a4a8cdfea0c8b5553f75767163a81743cb066 (diff)
downloadmeta-openembedded-baf8e1e39b23e9271b1b8da16714d5d0b2c91d5d.tar.gz
wtmpdb: Upgrade to 0.11.0 release
Brings these changes wtmpdb last: support matching for username and/or tty last: add support for time-format option Drop lto patch as it has been fixed differently. Add a patch to fix build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/wtmpdb/files/0001-remove-lto-to-fix-link-error-of-clang.patch31
-rw-r--r--meta-oe/recipes-extended/wtmpdb/wtmpdb/0001-include-libgen.h-for-basename.patch32
-rw-r--r--meta-oe/recipes-extended/wtmpdb/wtmpdb_0.11.0.bb (renamed from meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb)5
3 files changed, 34 insertions, 34 deletions
diff --git a/meta-oe/recipes-extended/wtmpdb/files/0001-remove-lto-to-fix-link-error-of-clang.patch b/meta-oe/recipes-extended/wtmpdb/files/0001-remove-lto-to-fix-link-error-of-clang.patch
deleted file mode 100644
index ef188e7a1..000000000
--- a/meta-oe/recipes-extended/wtmpdb/files/0001-remove-lto-to-fix-link-error-of-clang.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 9840939789dec9153150e8f9ae34de4171a5c15e Mon Sep 17 00:00:00 2001
2From: Wang Mingyu <wangmy@fujitsu.com>
3Date: Wed, 19 Jul 2023 07:31:32 +0000
4Subject: [PATCH] remove lto to fix link error of clang
5
6error message:
7| tests/tst-dlopen.p/tst-dlopen.c.o: file not recognized: file format not recognized
8| clang-16: error: linker command failed with exit code 1 (use -v to see invocation)
9
10Upstream-Status: Pending
11
12Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
13---
14 meson.build | 1 -
15 1 file changed, 1 deletion(-)
16
17diff --git a/meson.build b/meson.build
18index 6fe8045..166a15b 100644
19--- a/meson.build
20+++ b/meson.build
21@@ -28,7 +28,6 @@ add_project_arguments(['-D_GNU_SOURCE=1',
22 '-D_TIME_BITS=64'], language : 'c')
23
24 possible_cc_flags = [
25- '-flto=auto',
26 '-ffat-lto-objects',
27 '-fstack-protector-strong',
28 '-funwind-tables',
29--
302.34.1
31
diff --git a/meta-oe/recipes-extended/wtmpdb/wtmpdb/0001-include-libgen.h-for-basename.patch b/meta-oe/recipes-extended/wtmpdb/wtmpdb/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 000000000..766865e27
--- /dev/null
+++ b/meta-oe/recipes-extended/wtmpdb/wtmpdb/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,32 @@
1From 32f99ce7e890a457af50606ea7b577659a2a790a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 25 Mar 2024 17:35:07 -0700
4Subject: [PATCH] include libgen.h for basename
5
6basename prototype has been removed from string.h from latest musl [1]
7compilers e.g. clang-18 flags the absense of prototype as error. therefore
8include libgen.h for providing it.
9
10[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
11
12Upstream-Status: Submitted [https://github.com/thkukuk/wtmpdb/pull/11]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/wtmpdb.c | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/src/wtmpdb.c b/src/wtmpdb.c
19index aac7b5b..eaffae6 100644
20--- a/src/wtmpdb.c
21+++ b/src/wtmpdb.c
22@@ -30,6 +30,7 @@
23 #include <time.h>
24 #include <ctype.h>
25 #include <errno.h>
26+#include <libgen.h>
27 #include <stdio.h>
28 #include <stdlib.h>
29 #include <string.h>
30--
312.44.0
32
diff --git a/meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb b/meta-oe/recipes-extended/wtmpdb/wtmpdb_0.11.0.bb
index 6d23c0070..785ae50e9 100644
--- a/meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb
+++ b/meta-oe/recipes-extended/wtmpdb/wtmpdb_0.11.0.bb
@@ -5,11 +5,10 @@ LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=020090a00b69dd2af9ab82eb0003ea2c" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=020090a00b69dd2af9ab82eb0003ea2c"
6SECTION = "libs" 6SECTION = "libs"
7 7
8SRCREV = "8ef2677a13d19aee3a834500f9c8a4dac9d68ef7" 8SRCREV = "493e9704dbc50f141d5fbd41c823311e79d7e8d3"
9 9
10SRC_URI = "git://github.com/thkukuk/wtmpdb.git;branch=main;protocol=https \ 10SRC_URI = "git://github.com/thkukuk/wtmpdb.git;branch=main;protocol=https \
11 file://0001-remove-lto-to-fix-link-error-of-clang.patch \ 11 file://0001-include-libgen.h-for-basename.patch"
12"
13 12
14S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
15 14