diff options
author | Khem Raj <raj.khem@gmail.com> | 2025-03-12 09:27:42 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-03-13 09:50:12 -0700 |
commit | b19ff59668fe7ccbe16112c99cf0197134d89427 (patch) | |
tree | aec9dede80c0ed7f93a75a20d8f88a598fad4f37 /meta-oe | |
parent | 436b4fcc7eea5c31a5bcb46f340c6093c99fd7b7 (diff) | |
download | meta-openembedded-b19ff59668fe7ccbe16112c99cf0197134d89427.tar.gz |
libwebsockets: Fix build with clang-20
Backport a needed patch from main branch upstream
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-sll_protocol-may-be-be16.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.5.bb | 4 |
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-sll_protocol-may-be-be16.patch b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-sll_protocol-may-be-be16.patch new file mode 100644 index 0000000000..c27644ef7d --- /dev/null +++ b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-sll_protocol-may-be-be16.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 99e3ad14c60599e5d73e4d5597c95c3b91780547 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andy Green <andy@warmcat.com> | ||
3 | Date: Wed, 22 Jan 2025 10:08:55 +0000 | ||
4 | Subject: [PATCH] sll_protocol may be be16 | ||
5 | |||
6 | Google's fuzzer platform blows a warning | ||
7 | |||
8 | /src/libwebsockets/lib/plat/unix/unix-sockets.c:497:21: warning: implicit conversion loses integer precision: 'uint32_t' (aka 'unsigned int') to '__be16' (aka 'unsigned short') [-Wimplicit-int-conversion] | ||
9 | 497 | sll.sll_protocol = (uint32_t)(htons((uint16_t)0x800)); | ||
10 | |||
11 | Upstream-Status: Backport [https://github.com/warmcat/libwebsockets/commit/2ffb8c6d5eaab509a133f3a6d922e170ae95dd59] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | lib/plat/unix/unix-sockets.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/lib/plat/unix/unix-sockets.c b/lib/plat/unix/unix-sockets.c | ||
18 | index 1a40c9cf..61292ff8 100644 | ||
19 | --- a/lib/plat/unix/unix-sockets.c | ||
20 | +++ b/lib/plat/unix/unix-sockets.c | ||
21 | @@ -453,7 +453,7 @@ lws_plat_rawudp_broadcast(uint8_t *p, const uint8_t *canned, size_t canned_len, | ||
22 | |||
23 | memset(&sll, 0, sizeof(sll)); | ||
24 | sll.sll_family = AF_PACKET; | ||
25 | - sll.sll_protocol = (uint32_t)(htons((uint16_t)0x800)); | ||
26 | + sll.sll_protocol = (uint16_t)(htons((uint16_t)0x800)); | ||
27 | sll.sll_halen = 6; | ||
28 | sll.sll_ifindex = (int)if_nametoindex(iface); | ||
29 | memset(sll.sll_addr, 0xff, 6); | ||
diff --git a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.5.bb b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.5.bb index b7120a9975..4d6ec3b7ea 100644 --- a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.5.bb +++ b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.5.bb | |||
@@ -8,7 +8,9 @@ DEPENDS:append:class-native = " libcap-native" | |||
8 | 8 | ||
9 | S = "${WORKDIR}/git" | 9 | S = "${WORKDIR}/git" |
10 | SRCREV = "ab9df9cfc39de7a49967f18387b6b76310947442" | 10 | SRCREV = "ab9df9cfc39de7a49967f18387b6b76310947442" |
11 | SRC_URI = "git://github.com/warmcat/libwebsockets.git;protocol=https;branch=v4.3-stable" | 11 | SRC_URI = "git://github.com/warmcat/libwebsockets.git;protocol=https;branch=v4.3-stable \ |
12 | file://0001-sll_protocol-may-be-be16.patch \ | ||
13 | " | ||
12 | 14 | ||
13 | UPSTREAM_CHECK_URI = "https://github.com/warmcat/${BPN}/releases" | 15 | UPSTREAM_CHECK_URI = "https://github.com/warmcat/${BPN}/releases" |
14 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" | 16 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |