summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2024-09-09 20:24:04 +0200
committerKhem Raj <raj.khem@gmail.com>2024-09-09 18:23:01 -0700
commitab4aa4045b6b4decf3ce52e62719b78a2651b5b4 (patch)
treed2a51a9ef790c23c72b4247419698a31d15aa0b9 /meta-oe
parentbe1c5980fbc778149c3b6dc7c85f7cc90e5fab8c (diff)
downloadmeta-openembedded-ab4aa4045b6b4decf3ce52e62719b78a2651b5b4.tar.gz
poppler: Correct the configuration options
* Remove -DENABLE_ZLIB=ON (it is no longer optional). * Replace -DENABLE_CMS=lcms2 with -DENABLE_LCMS=ON. * Replace the splash PACKAGECONFIG with boost (splash is no longer optional). * Correct the options for the nss and tiff PACKAGECONFIGs. This avoids the following CMake warnings: Manually-specified variables were not used by the project: ENABLE_CMS ENABLE_SPLASH ENABLE_ZLIB WITH_NSS3 WITH_TIFF Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/poppler/poppler_24.09.0.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler_24.09.0.bb b/meta-oe/recipes-support/poppler/poppler_24.09.0.bb
index 920d13f0f..fb6b534cf 100644
--- a/meta-oe/recipes-support/poppler/poppler_24.09.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_24.09.0.bb
@@ -14,15 +14,15 @@ DEPENDS = "fontconfig zlib cairo lcms glib-2.0 glib-2.0-native"
14 14
15inherit cmake pkgconfig gobject-introspection 15inherit cmake pkgconfig gobject-introspection
16 16
17PACKAGECONFIG ??= "jpeg openjpeg png tiff nss splash" 17PACKAGECONFIG ??= "boost jpeg nss openjpeg png tiff"
18PACKAGECONFIG[boost] = "-DENABLE_BOOST=ON,-DENABLE_BOOST=OFF,boost"
18PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg" 19PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg"
19PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng" 20PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng"
20PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff" 21PACKAGECONFIG[tiff] = "-DENABLE_LIBTIFF=ON,-DENABLE_LIBTIFF=OFF,tiff"
21PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl" 22PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl"
22PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg" 23PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg"
23PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native" 24PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native"
24PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss" 25PACKAGECONFIG[nss] = "-DENABLE_NSS3=ON,-DENABLE_NSS3=OFF,nss"
25PACKAGECONFIG[splash] = "-DENABLE_SPLASH=ON -DENABLE_BOOST=ON,-DENABLE_SPLASH=OFF -DENABLE_BOOST=OFF,boost"
26PACKAGECONFIG[gpgme] = "-DENABLE_GPGME=ON,-DENABLE_GPGME=OFF,gpgme" 26PACKAGECONFIG[gpgme] = "-DENABLE_GPGME=ON,-DENABLE_GPGME=OFF,gpgme"
27PACKAGECONFIG[qt6] = "-DENABLE_QT6=ON,-DENABLE_QT6=OFF,qtbase" 27PACKAGECONFIG[qt6] = "-DENABLE_QT6=ON,-DENABLE_QT6=OFF,qtbase"
28 28
@@ -32,10 +32,9 @@ inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
32SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" 32SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
33 33
34EXTRA_OECMAKE += " \ 34EXTRA_OECMAKE += " \
35 -DENABLE_CMS=lcms2 \ 35 -DENABLE_LCMS=ON \
36 -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \ 36 -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
37 -DBUILD_GTK_TESTS=OFF \ 37 -DBUILD_GTK_TESTS=OFF \
38 -DENABLE_ZLIB=ON \
39 -DRUN_GPERF_IF_PRESENT=OFF \ 38 -DRUN_GPERF_IF_PRESENT=OFF \
40 -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \ 39 -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \
41 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \ 40 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \