diff options
author | Etienne Cordonnier <ecordonnier@snap.com> | 2024-09-20 14:41:36 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-09-26 06:58:28 -0700 |
commit | a2bd05f9ecd77150d0949f27397453f949d7362e (patch) | |
tree | c62ab1e53ebbf3f422ddb00b1c4d8cbbc3ce01be /meta-oe | |
parent | a672d51b15d5180b9b8b0dcd466bf4efc2492511 (diff) | |
download | meta-openembedded-a2bd05f9ecd77150d0949f27397453f949d7362e.tar.gz |
perfetto: upgrade 31.0 -> 47.0
Release Notes: https://github.com/google/perfetto/releases/tag/v47.0
Test procedure:
Tested with TOOLCHAIN="clang" and MACHINE="qemux86-64" (using ARGS="is_debug=false enable_perfetto_x64_cpu_opt=false" in perfetto.bb because of missing SSE4.2,BMI2,AVX2 inside qemu):
```
root@qemux86-64:~# tracebox --out /tmp/perfetto dmesg sched freq idle am wm gfx view binder_driver hal dalvik camera input res memory
[100.634] service.cc:232 Started traced, listening on @traced-p-310 @traced-c-310
[100.804] probes.cc:104 Starting traced_probes service
[100.852] probes_producer.cc:332 Connected to the service
[100.957] perf_producer.cc:1201 Connected to the service
[100.979] perfetto_cmd.cc:1100 Connected to the Perfetto traced service, TTL: 10s
[101.029] ng_service_impl.cc:1125 Configured tracing session 1, #sources:4, duration:10000 ms, #buffers:1, total buffer size:32768 KB, total sessions:1, uid:0 session name: ""
[101.571] probes_producer.cc:132 Ftrace setup (target_buf=1)
[101.574] ftrace_procfs.cc:441 disabled ftrace in /sys/kernel/tracing/
[101.679] ftrace_procfs.cc:295 Failed to setup event triggers for synthetic:rss_stat_throttled (errno: 22, Invalid argument)
[101.682] atrace_wrapper.cc:196 Atrace only supported on Android.
[101.757] ftrace_procfs.cc:438 enabled ftrace in /sys/kernel/tracing/
[111.091] ng_service_impl.cc:2103 FlushAndDisableTracing(1) done, success=1
[111.097] probes_producer.cc:445 Producer stop (id=1)
[111.168] ftrace_procfs.cc:441 disabled ftrace in /sys/kernel/tracing/
[111.181] ftrace_procfs.cc:441 disabled ftrace in /sys/kernel/tracing/
[111.194] probes_producer.cc:445 Producer stop (id=2)
[111.200] probes_producer.cc:445 Producer stop (id=3)
[111.308] perfetto_cmd.cc:1263 Wrote 390764 bytes into /tmp/perfetto
root@qemux86-64:~# ls -l /tmp/perfetto
-rw------- 1 root root 390764 Sep 24 09:25 /tmp/perfetto
```
I then manually verified the file using https://ui.perfetto.dev/
Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/common/0001-fix-musl-build.patch | 40 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/files/0001-Add-missing-header-cstdint-for-uintXX_t-types.patch | 58 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/libperfetto.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/libperfetto/0001-meson-add-pc-file-for-lib_perfetto.patch (renamed from meta-oe/recipes-devtools/perfetto/files/0001-meson-add-pc-file-for-lib_perfetto.patch) | 20 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/perfetto.bb | 30 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/perfetto.inc | 11 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/perfetto/0001-Remove-check_build_deps-build-steps.patch (renamed from meta-oe/recipes-devtools/perfetto/files/0001-Remove-check_build_deps-build-steps.patch) | 18 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/perfetto/0002-traced-fix-missing-include.patch | 28 |
8 files changed, 114 insertions, 93 deletions
diff --git a/meta-oe/recipes-devtools/perfetto/common/0001-fix-musl-build.patch b/meta-oe/recipes-devtools/perfetto/common/0001-fix-musl-build.patch new file mode 100644 index 0000000000..3b7ca951ae --- /dev/null +++ b/meta-oe/recipes-devtools/perfetto/common/0001-fix-musl-build.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 485c21940eb0100a33b7efea40a83e7f79e765f8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Etienne Cordonnier <ecordonnier@snap.com> | ||
3 | Date: Sun, 22 Sep 2024 20:17:52 +0200 | ||
4 | Subject: [PATCH] fix musl build | ||
5 | |||
6 | Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com> | ||
7 | --- | ||
8 | Upstream-Status: Pending | ||
9 | |||
10 | sdk/perfetto.cc | 1 - | ||
11 | src/base/utils.cc | 1 - | ||
12 | 2 files changed, 2 deletions(-) | ||
13 | |||
14 | diff --git a/sdk/perfetto.cc b/sdk/perfetto.cc | ||
15 | index b10dd5aa92..2eb90f0d15 100644 | ||
16 | --- a/sdk/perfetto.cc | ||
17 | +++ b/sdk/perfetto.cc | ||
18 | @@ -6558,7 +6558,6 @@ std::optional<int32_t> GetTimezoneOffsetMins() { | ||
19 | |||
20 | #if PERFETTO_BUILDFLAG(PERFETTO_OS_LINUX) || \ | ||
21 | PERFETTO_BUILDFLAG(PERFETTO_OS_ANDROID) | ||
22 | -#include <linux/prctl.h> | ||
23 | #include <sys/prctl.h> | ||
24 | |||
25 | #ifndef PR_GET_TAGGED_ADDR_CTRL | ||
26 | diff --git a/src/base/utils.cc b/src/base/utils.cc | ||
27 | index 0d9318c136..419c7dbc1a 100644 | ||
28 | --- a/src/base/utils.cc | ||
29 | +++ b/src/base/utils.cc | ||
30 | @@ -40,7 +40,6 @@ | ||
31 | |||
32 | #if PERFETTO_BUILDFLAG(PERFETTO_OS_LINUX) || \ | ||
33 | PERFETTO_BUILDFLAG(PERFETTO_OS_ANDROID) | ||
34 | -#include <linux/prctl.h> | ||
35 | #include <sys/prctl.h> | ||
36 | |||
37 | #ifndef PR_GET_TAGGED_ADDR_CTRL | ||
38 | -- | ||
39 | 2.43.0 | ||
40 | |||
diff --git a/meta-oe/recipes-devtools/perfetto/files/0001-Add-missing-header-cstdint-for-uintXX_t-types.patch b/meta-oe/recipes-devtools/perfetto/files/0001-Add-missing-header-cstdint-for-uintXX_t-types.patch deleted file mode 100644 index d08721ae65..0000000000 --- a/meta-oe/recipes-devtools/perfetto/files/0001-Add-missing-header-cstdint-for-uintXX_t-types.patch +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | From e63949205682bbd2a0e33e256119472d704a2549 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 29 Jan 2023 22:03:01 -0800 | ||
4 | Subject: [PATCH] Add missing header <cstdint> for uintXX_t types | ||
5 | |||
6 | This is detected by gcc-13 | ||
7 | gcc 13 moved some includes around and as a result <cstdint> is no | ||
8 | longer transitively included [1]. Explicitly include it for uintXX_t. | ||
9 | |||
10 | [1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes | ||
11 | |||
12 | Upstream-Status: Submitted [https://android-review.googlesource.com/c/platform/external/perfetto/+/2399128] | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | include/perfetto/ext/base/http/sha1.h | 1 + | ||
16 | include/perfetto/ext/base/uuid.h | 1 + | ||
17 | src/traced/probes/common/cpu_freq_info.h | 1 + | ||
18 | 3 files changed, 3 insertions(+) | ||
19 | |||
20 | diff --git a/include/perfetto/ext/base/http/sha1.h b/include/perfetto/ext/base/http/sha1.h | ||
21 | index c583d69d4..7e3a48c83 100644 | ||
22 | --- a/include/perfetto/ext/base/http/sha1.h | ||
23 | +++ b/include/perfetto/ext/base/http/sha1.h | ||
24 | @@ -20,6 +20,7 @@ | ||
25 | #include <stddef.h> | ||
26 | |||
27 | #include <array> | ||
28 | +#include <cstdint> | ||
29 | #include <string> | ||
30 | |||
31 | namespace perfetto { | ||
32 | diff --git a/include/perfetto/ext/base/uuid.h b/include/perfetto/ext/base/uuid.h | ||
33 | index 1b4c53815..472042fab 100644 | ||
34 | --- a/include/perfetto/ext/base/uuid.h | ||
35 | +++ b/include/perfetto/ext/base/uuid.h | ||
36 | @@ -18,6 +18,7 @@ | ||
37 | #define INCLUDE_PERFETTO_EXT_BASE_UUID_H_ | ||
38 | |||
39 | #include <array> | ||
40 | +#include <cstdint> | ||
41 | #include <string> | ||
42 | |||
43 | #include "perfetto/ext/base/optional.h" | ||
44 | diff --git a/src/traced/probes/common/cpu_freq_info.h b/src/traced/probes/common/cpu_freq_info.h | ||
45 | index 36f7f9c09..8232cbf64 100644 | ||
46 | --- a/src/traced/probes/common/cpu_freq_info.h | ||
47 | +++ b/src/traced/probes/common/cpu_freq_info.h | ||
48 | @@ -17,6 +17,7 @@ | ||
49 | #ifndef SRC_TRACED_PROBES_COMMON_CPU_FREQ_INFO_H_ | ||
50 | #define SRC_TRACED_PROBES_COMMON_CPU_FREQ_INFO_H_ | ||
51 | |||
52 | +#include <cstdint> | ||
53 | #include <map> | ||
54 | #include <string> | ||
55 | #include <vector> | ||
56 | -- | ||
57 | 2.39.1 | ||
58 | |||
diff --git a/meta-oe/recipes-devtools/perfetto/libperfetto.bb b/meta-oe/recipes-devtools/perfetto/libperfetto.bb index c8f56fd527..8383db3cc0 100644 --- a/meta-oe/recipes-devtools/perfetto/libperfetto.bb +++ b/meta-oe/recipes-devtools/perfetto/libperfetto.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | LICENSE = "Apache-2.0" | 1 | LICENSE = "Apache-2.0" |
2 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f87516e0b698007e9e75a1fe1012b390" | 2 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2572d98547d43906b53615f856a8c2d" |
3 | 3 | ||
4 | require perfetto.inc | 4 | require perfetto.inc |
5 | 5 | ||
diff --git a/meta-oe/recipes-devtools/perfetto/files/0001-meson-add-pc-file-for-lib_perfetto.patch b/meta-oe/recipes-devtools/perfetto/libperfetto/0001-meson-add-pc-file-for-lib_perfetto.patch index ae644747c1..719663a802 100644 --- a/meta-oe/recipes-devtools/perfetto/files/0001-meson-add-pc-file-for-lib_perfetto.patch +++ b/meta-oe/recipes-devtools/perfetto/libperfetto/0001-meson-add-pc-file-for-lib_perfetto.patch | |||
@@ -3,21 +3,22 @@ From: Markus Volk <f_l_k@t-online.de> | |||
3 | Date: Mon, 17 Oct 2022 19:20:53 +0200 | 3 | Date: Mon, 17 Oct 2022 19:20:53 +0200 |
4 | Subject: [PATCH] meson: add PC file for lib_perfetto | 4 | Subject: [PATCH] meson: add PC file for lib_perfetto |
5 | 5 | ||
6 | Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com> | ||
6 | --- | 7 | --- |
7 | Upstream-Status: Pending | 8 | Upstream-Status: Pending |
8 | 9 | ||
9 | meson.build | 12 ++++++++++-- | 10 | meson.build | 10 +++++++++- |
10 | 1 file changed, 10 insertions(+), 2 deletions(-) | 11 | 1 file changed, 9 insertions(+), 1 deletion(-) |
11 | 12 | ||
13 | diff --git a/meson.build b/meson.build | ||
14 | index 8fb1e26275..3ef3ebf27d 100644 | ||
12 | --- a/meson.build | 15 | --- a/meson.build |
13 | +++ b/meson.build | 16 | +++ b/meson.build |
14 | @@ -19,9 +19,12 @@ | 17 | @@ -19,8 +19,11 @@ |
15 | project( | 18 | project( |
16 | 'perfetto', | 19 | 'perfetto', |
17 | ['cpp'], | 20 | ['cpp'], |
18 | - default_options: ['cpp_std=c++17'] | 21 | + version: '47.0' |
19 | + default_options: ['cpp_std=c++17'], | ||
20 | + version: '31.0' | ||
21 | ) | 22 | ) |
22 | 23 | ||
23 | +soversion = meson.project_version() | 24 | +soversion = meson.project_version() |
@@ -25,7 +26,7 @@ Upstream-Status: Pending | |||
25 | fs = import('fs') | 26 | fs = import('fs') |
26 | 27 | ||
27 | if not fs.is_dir('sdk') | 28 | if not fs.is_dir('sdk') |
28 | @@ -36,8 +39,9 @@ if host_machine.system() == 'android' | 29 | @@ -35,8 +38,9 @@ if host_machine.system() == 'android' |
29 | deps_perfetto += cpp.find_library('log') | 30 | deps_perfetto += cpp.find_library('log') |
30 | endif | 31 | endif |
31 | 32 | ||
@@ -36,7 +37,7 @@ Upstream-Status: Pending | |||
36 | sources: 'sdk/perfetto.cc', | 37 | sources: 'sdk/perfetto.cc', |
37 | dependencies: deps_perfetto, | 38 | dependencies: deps_perfetto, |
38 | install: true, | 39 | install: true, |
39 | @@ -50,6 +54,10 @@ dir_perfetto_trace = join_paths(meson.cu | 40 | @@ -50,6 +54,10 @@ dir_perfetto_trace = join_paths(meson.current_source_dir(), |
40 | 41 | ||
41 | install_data(dir_perfetto_trace / 'perfetto_trace.proto') | 42 | install_data(dir_perfetto_trace / 'perfetto_trace.proto') |
42 | 43 | ||
@@ -47,3 +48,6 @@ Upstream-Status: Pending | |||
47 | dep_perfetto = declare_dependency( | 48 | dep_perfetto = declare_dependency( |
48 | link_with: lib_perfetto, | 49 | link_with: lib_perfetto, |
49 | include_directories: inc_perfetto, | 50 | include_directories: inc_perfetto, |
51 | -- | ||
52 | 2.43.0 | ||
53 | |||
diff --git a/meta-oe/recipes-devtools/perfetto/perfetto.bb b/meta-oe/recipes-devtools/perfetto/perfetto.bb index 884e0a024b..d2a6fbe654 100644 --- a/meta-oe/recipes-devtools/perfetto/perfetto.bb +++ b/meta-oe/recipes-devtools/perfetto/perfetto.bb | |||
@@ -1,16 +1,17 @@ | |||
1 | LICENSE = "Apache-2.0 & BSD-3-Clause & MIT & Zlib" | 1 | LICENSE = "Apache-2.0 & BSD-3-Clause & MIT & Zlib" |
2 | 2 | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f87516e0b698007e9e75a1fe1012b390 \ | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2572d98547d43906b53615f856a8c2d \ |
4 | file://buildtools/libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da3953 \ | 4 | file://buildtools/libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da3953 \ |
5 | file://buildtools/libcxxabi/LICENSE.TXT;md5=7b9334635b542c56868400a46b272b1e \ | 5 | file://buildtools/libcxxabi/LICENSE.TXT;md5=7b9334635b542c56868400a46b272b1e \ |
6 | file://buildtools/libunwind/LICENSE.TXT;md5=f66970035d12f196030658b11725e1a1 \ | 6 | file://buildtools/libunwind/LICENSE.TXT;md5=f66970035d12f196030658b11725e1a1 \ |
7 | file://buildtools/protobuf/LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b \ | 7 | file://buildtools/protobuf/LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b \ |
8 | file://buildtools/zlib/LICENSE;md5=f09575dbfb09420642318b413159496f \ | 8 | file://buildtools/zlib/LICENSE;md5=8c75f2b4df47a77f9445315a9500cd1c \ |
9 | file://debian/copyright;md5=4e08364c82141f181de69d0a2b89d612 \ | 9 | file://debian/copyright;md5=4e08364c82141f181de69d0a2b89d612 \ |
10 | file://python/LICENSE;md5=c602a632c34ade9c78a976734077bce7" | 10 | file://python/LICENSE;md5=c602a632c34ade9c78a976734077bce7" |
11 | 11 | ||
12 | # Dependencies from perfetto/tools/install-build-deps | ||
12 | SRC_URI:append = " \ | 13 | SRC_URI:append = " \ |
13 | git://github.com/protocolbuffers/protobuf.git;branch=3.9.x;protocol=https;destsuffix=git/buildtools/protobuf;name=protobuf \ | 14 | git://github.com/protocolbuffers/protobuf.git;branch=main;protocol=https;destsuffix=git/buildtools/protobuf;name=protobuf \ |
14 | git://chromium.googlesource.com/external/github.com/llvm/llvm-project/libcxx.git;protocol=https;destsuffix=git/buildtools/libcxx;branch=main;name=libcxx \ | 15 | git://chromium.googlesource.com/external/github.com/llvm/llvm-project/libcxx.git;protocol=https;destsuffix=git/buildtools/libcxx;branch=main;name=libcxx \ |
15 | git://chromium.googlesource.com/external/github.com/llvm/llvm-project/libcxxabi.git;protocol=https;destsuffix=git/buildtools/libcxxabi;branch=main;name=libcxxabi \ | 16 | git://chromium.googlesource.com/external/github.com/llvm/llvm-project/libcxxabi.git;protocol=https;destsuffix=git/buildtools/libcxxabi;branch=main;name=libcxxabi \ |
16 | git://chromium.googlesource.com/external/github.com/llvm/llvm-project/libunwind.git;protocol=https;destsuffix=git/buildtools/libunwind;branch=main;name=libunwind \ | 17 | git://chromium.googlesource.com/external/github.com/llvm/llvm-project/libunwind.git;protocol=https;destsuffix=git/buildtools/libunwind;branch=main;name=libunwind \ |
@@ -22,25 +23,28 @@ SRC_URI:append = " \ | |||
22 | git://android.googlesource.com/platform/bionic.git;branch=master;protocol=https;destsuffix=git/buildtools/bionic;name=bionic \ | 23 | git://android.googlesource.com/platform/bionic.git;branch=master;protocol=https;destsuffix=git/buildtools/bionic;name=bionic \ |
23 | git://android.googlesource.com/platform/external/zlib.git;branch=master;protocol=https;destsuffix=git/buildtools/zlib;name=zlib \ | 24 | git://android.googlesource.com/platform/external/zlib.git;branch=master;protocol=https;destsuffix=git/buildtools/zlib;name=zlib \ |
24 | git://android.googlesource.com/platform/external/lzma.git;branch=master;protocol=https;destsuffix=git/buildtools/lzma;name=lzma \ | 25 | git://android.googlesource.com/platform/external/lzma.git;branch=master;protocol=https;destsuffix=git/buildtools/lzma;name=lzma \ |
26 | git://android.googlesource.com/platform/external/zstd.git;branch=master;protocol=https;destsuffix=git/buildtools/zstd;name=zstd \ | ||
25 | https://storage.googleapis.com/perfetto/gn-linux64-1968-0725d782;subdir=git/buildtools/;name=gn \ | 27 | https://storage.googleapis.com/perfetto/gn-linux64-1968-0725d782;subdir=git/buildtools/;name=gn \ |
26 | \ | 28 | \ |
27 | file://0001-Remove-check_build_deps-build-steps.patch \ | 29 | file://0001-Remove-check_build_deps-build-steps.patch \ |
28 | file://0001-Add-missing-header-cstdint-for-uintXX_t-types.patch" | 30 | file://0002-traced-fix-missing-include.patch \ |
31 | " | ||
29 | 32 | ||
30 | SRCREV_bionic = "4b0e16bc72a82a63c699977376a7d6eadca1b206" | 33 | SRCREV_bionic = "a0d0355105cb9d4a4b5384897448676133d7b8e2" |
31 | SRCREV_core = "9e6cef7f07d8c11b3ea820938aeb7ff2e9dbaa52" | 34 | SRCREV_core = "9e6cef7f07d8c11b3ea820938aeb7ff2e9dbaa52" |
32 | SRCREV_lzma = "7851dce6f4ca17f5caa1c93a4e0a45686b1d56c3" | 35 | SRCREV_lzma = "7851dce6f4ca17f5caa1c93a4e0a45686b1d56c3" |
33 | SRCREV_libprocinfo = "fd214c13ededecae97a3b15b5fccc8925a749a84" | 36 | SRCREV_libprocinfo = "fd214c13ededecae97a3b15b5fccc8925a749a84" |
34 | SRCREV_logging = "7b36b566c9113fc703d68f76e8f40c0c2432481c" | 37 | SRCREV_logging = "7b36b566c9113fc703d68f76e8f40c0c2432481c" |
35 | SRCREV_unwinding = "d66882575ebe3700d6a6b10185f3aee28acc1051" | 38 | SRCREV_unwinding = "4b59ea8471e89d01300481a92de3230b79b6d7c7" |
36 | SRCREV_protobuf = "6a59a2ad1f61d9696092f79b6d74368b4d7970a3" | 39 | SRCREV_protobuf = "f0dc78d7e6e331b8c6bb2d5283e06aa26883ca7c" |
37 | SRCREV_libbase = "78f1c2f83e625bdf66d55b48bdb3a301c20d2fb3" | 40 | SRCREV_libbase = "78f1c2f83e625bdf66d55b48bdb3a301c20d2fb3" |
38 | SRCREV_libcxx = "f8571eaba606bde2eb8cd34b30104ca33e7c207e" | 41 | SRCREV_libcxx = "852bc6746f45add53fec19f3a29280e69e358d44" |
39 | SRCREV_libcxxabi = "8dd405113a4f3694e910b79785dd7fb7535a888a" | 42 | SRCREV_libcxxabi = "a37a3aa431f132b02a58656f13984d51098330a2" |
40 | SRCREV_libunwind = "aabcd8753678f1536e15eb6385a948470debdae4" | 43 | SRCREV_libunwind = "419b03c0b8f20d6da9ddcb0d661a94a97cdd7dad" |
41 | SRCREV_zlib = "5c85a2da4c13eda07f69d81a1579a5afddd35f59" | 44 | SRCREV_zlib = "6d3f6aa0f87c9791ca7724c279ef61384f331dfd" |
45 | SRCREV_zstd = "77211fcc5e08c781734a386402ada93d0d18d093" | ||
42 | 46 | ||
43 | SRCREV_FORMAT .="_bionic_core_lzma_libprocinfo_logging_unwinding_protobuf_libbase_libcxx_libcxxabi_libunwind_zlib" | 47 | SRCREV_FORMAT .="_bionic_core_lzma_libprocinfo_logging_unwinding_protobuf_libbase_libcxx_libcxxabi_libunwind_zlib_zstd" |
44 | 48 | ||
45 | SRC_URI[gn.sha256sum] = "f706aaa0676e3e22f5fc9ca482295d7caee8535d1869f99efa2358177b64f5cd" | 49 | SRC_URI[gn.sha256sum] = "f706aaa0676e3e22f5fc9ca482295d7caee8535d1869f99efa2358177b64f5cd" |
46 | 50 | ||
@@ -97,7 +101,7 @@ do_configure () { | |||
97 | ARGS=$ARGS" target_os=\"linux\"" | 101 | ARGS=$ARGS" target_os=\"linux\"" |
98 | ARGS=$ARGS" target_cpu=\"$arch\"" | 102 | ARGS=$ARGS" target_cpu=\"$arch\"" |
99 | ARGS=$ARGS" target_cc=\"$CC_BIN ${TUNE_CCARGS} ${DEBUG_PREFIX_MAP}\"" | 103 | ARGS=$ARGS" target_cc=\"$CC_BIN ${TUNE_CCARGS} ${DEBUG_PREFIX_MAP}\"" |
100 | ARGS=$ARGS" target_cxx=\"$CXX_BIN -std=c++11 ${TUNE_CCARGS} ${DEBUG_PREFIX_MAP}\"" | 104 | ARGS=$ARGS" target_cxx=\"$CXX_BIN ${TUNE_CCARGS} ${DEBUG_PREFIX_MAP}\"" |
101 | ARGS=$ARGS" target_strip=\"$STRIP_BIN\"" # | 105 | ARGS=$ARGS" target_strip=\"$STRIP_BIN\"" # |
102 | ARGS=$ARGS" target_sysroot=\"${RECIPE_SYSROOT}\"" | 106 | ARGS=$ARGS" target_sysroot=\"${RECIPE_SYSROOT}\"" |
103 | ARGS=$ARGS" target_linker=\"$CC_BIN ${TUNE_CCARGS} ${LDFLAGS}\"" | 107 | ARGS=$ARGS" target_linker=\"$CC_BIN ${TUNE_CCARGS} ${LDFLAGS}\"" |
diff --git a/meta-oe/recipes-devtools/perfetto/perfetto.inc b/meta-oe/recipes-devtools/perfetto/perfetto.inc index 4b06c5bf04..e0e4f04a23 100644 --- a/meta-oe/recipes-devtools/perfetto/perfetto.inc +++ b/meta-oe/recipes-devtools/perfetto/perfetto.inc | |||
@@ -1,10 +1,15 @@ | |||
1 | SUMMARY = "Perfetto - System profiling, app tracing and trace analysis." | 1 | SUMMARY = "Perfetto - System profiling, app tracing and trace analysis." |
2 | HOMEPAGE = "https://github.com/google/perfetto" | 2 | HOMEPAGE = "https://github.com/google/perfetto" |
3 | 3 | ||
4 | SRC_URI = "git://github.com/google/perfetto.git;protocol=https;name=perfetto;nobranch=1" | 4 | FILESEXTRAPATHS:prepend := "${THISDIR}/common:" |
5 | 5 | ||
6 | SRCREV_perfetto = "b8da07095979310818f0efde2ef3c69ea70d62c5" | 6 | # Add only patches here which are used by both perfetto and libperfetto |
7 | SRC_URI = "git://github.com/google/perfetto.git;protocol=https;name=perfetto;nobranch=1 \ | ||
8 | file://0001-fix-musl-build.patch \ | ||
9 | " | ||
10 | |||
11 | SRCREV_perfetto = "c74251226a8caa0b43377902ee06d2570faa0c15" | ||
7 | SRCREV_FORMAT = "perfetto" | 12 | SRCREV_FORMAT = "perfetto" |
8 | PV = "31.0" | 13 | PV = "47.0" |
9 | 14 | ||
10 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
diff --git a/meta-oe/recipes-devtools/perfetto/files/0001-Remove-check_build_deps-build-steps.patch b/meta-oe/recipes-devtools/perfetto/perfetto/0001-Remove-check_build_deps-build-steps.patch index c10400aef4..118c3aed4a 100644 --- a/meta-oe/recipes-devtools/perfetto/files/0001-Remove-check_build_deps-build-steps.patch +++ b/meta-oe/recipes-devtools/perfetto/perfetto/0001-Remove-check_build_deps-build-steps.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 3b7091243ec03054ca8800b51b85a1c09e7e3075 Mon Sep 17 00:00:00 2001 | 1 | From 07ddc4b9b7a6fec73cdc295baba353944857212e Mon Sep 17 00:00:00 2001 |
2 | From: Sui Chen <suichen6@gmail.com> | 2 | From: Sui Chen <suichen6@gmail.com> |
3 | Date: Mon, 13 Jun 2022 17:46:49 +0000 | 3 | Date: Mon, 13 Jun 2022 17:46:49 +0000 |
4 | Subject: [PATCH] Remove "check_build_deps" build steps | 4 | Subject: [PATCH] Remove "check_build_deps" build steps |
@@ -11,6 +11,7 @@ Also setting "is_cross_compiling" to true, so that the host-side tools | |||
11 | rather than the Bitbake-generated one. | 11 | rather than the Bitbake-generated one. |
12 | 12 | ||
13 | Signed-off-by: Sui Chen <suichen6@gmail.com> | 13 | Signed-off-by: Sui Chen <suichen6@gmail.com> |
14 | Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com> | ||
14 | --- | 15 | --- |
15 | Upstream-Status: Pending | 16 | Upstream-Status: Pending |
16 | 17 | ||
@@ -20,10 +21,10 @@ Upstream-Status: Pending | |||
20 | 3 files changed, 9 insertions(+), 9 deletions(-) | 21 | 3 files changed, 9 insertions(+), 9 deletions(-) |
21 | 22 | ||
22 | diff --git a/gn/BUILD.gn b/gn/BUILD.gn | 23 | diff --git a/gn/BUILD.gn b/gn/BUILD.gn |
23 | index 8a7ca72a8..e4a2d39f0 100644 | 24 | index ed055ee700..ea79979ec5 100644 |
24 | --- a/gn/BUILD.gn | 25 | --- a/gn/BUILD.gn |
25 | +++ b/gn/BUILD.gn | 26 | +++ b/gn/BUILD.gn |
26 | @@ -111,7 +111,6 @@ group("default_deps") { | 27 | @@ -117,7 +117,6 @@ group("default_deps") { |
27 | deps = [ ":gen_buildflags" ] | 28 | deps = [ ":gen_buildflags" ] |
28 | if (perfetto_build_standalone) { | 29 | if (perfetto_build_standalone) { |
29 | public_deps = [ | 30 | public_deps = [ |
@@ -32,10 +33,10 @@ index 8a7ca72a8..e4a2d39f0 100644 | |||
32 | "//gn/standalone/sanitizers:deps", | 33 | "//gn/standalone/sanitizers:deps", |
33 | ] | 34 | ] |
34 | diff --git a/gn/standalone/BUILD.gn b/gn/standalone/BUILD.gn | 35 | diff --git a/gn/standalone/BUILD.gn b/gn/standalone/BUILD.gn |
35 | index 582e9b867..9c77ac64c 100644 | 36 | index 36fb6371a5..f7bc97b1a6 100644 |
36 | --- a/gn/standalone/BUILD.gn | 37 | --- a/gn/standalone/BUILD.gn |
37 | +++ b/gn/standalone/BUILD.gn | 38 | +++ b/gn/standalone/BUILD.gn |
38 | @@ -441,10 +441,10 @@ config("android_liblog") { | 39 | @@ -469,10 +469,10 @@ config("android_liblog") { |
39 | } | 40 | } |
40 | 41 | ||
41 | # Checks that tools/install-build-deps has been run since it last changed. | 42 | # Checks that tools/install-build-deps has been run since it last changed. |
@@ -53,7 +54,7 @@ index 582e9b867..9c77ac64c 100644 | |||
53 | +# args = [ "--android" ] | 54 | +# args = [ "--android" ] |
54 | +#} | 55 | +#} |
55 | diff --git a/gn/standalone/BUILDCONFIG.gn b/gn/standalone/BUILDCONFIG.gn | 56 | diff --git a/gn/standalone/BUILDCONFIG.gn b/gn/standalone/BUILDCONFIG.gn |
56 | index 6f32686c1..c041989b0 100644 | 57 | index 05ed548f9d..94db724b2b 100644 |
57 | --- a/gn/standalone/BUILDCONFIG.gn | 58 | --- a/gn/standalone/BUILDCONFIG.gn |
58 | +++ b/gn/standalone/BUILDCONFIG.gn | 59 | +++ b/gn/standalone/BUILDCONFIG.gn |
59 | @@ -59,8 +59,9 @@ declare_args() { | 60 | @@ -59,8 +59,9 @@ declare_args() { |
@@ -67,7 +68,4 @@ index 6f32686c1..c041989b0 100644 | |||
67 | + is_cross_compiling = true | 68 | + is_cross_compiling = true |
68 | } | 69 | } |
69 | default_configs = [ | 70 | default_configs = [ |
70 | "//gn/standalone:debug_symbols", | 71 | "//gn/standalone:default", |
71 | -- | ||
72 | 2.37.1 | ||
73 | |||
diff --git a/meta-oe/recipes-devtools/perfetto/perfetto/0002-traced-fix-missing-include.patch b/meta-oe/recipes-devtools/perfetto/perfetto/0002-traced-fix-missing-include.patch new file mode 100644 index 0000000000..49b7989359 --- /dev/null +++ b/meta-oe/recipes-devtools/perfetto/perfetto/0002-traced-fix-missing-include.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From d005c0123b2f929b918359a53ffe61d7ca2212a0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lalit Maganti <lalitm@google.com> | ||
3 | Date: Wed, 14 Aug 2024 11:56:47 +0100 | ||
4 | Subject: [PATCH] traced: fix missing include | ||
5 | |||
6 | Change-Id: Ib9ce8ce5b057e89fa451ccef228228d607b36793 | ||
7 | Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com> | ||
8 | --- | ||
9 | Upstream-Status: Backport [https://github.com/google/perfetto/commit/d005c0123b2f929b918359a53ffe61d7ca2212a0] | ||
10 | |||
11 | src/traced/probes/sys_stats/sys_stats_data_source.h | 1 + | ||
12 | 1 file changed, 1 insertion(+) | ||
13 | |||
14 | diff --git a/src/traced/probes/sys_stats/sys_stats_data_source.h b/src/traced/probes/sys_stats/sys_stats_data_source.h | ||
15 | index e09cd8a2ca..7e4749bdcd 100644 | ||
16 | --- a/src/traced/probes/sys_stats/sys_stats_data_source.h | ||
17 | +++ b/src/traced/probes/sys_stats/sys_stats_data_source.h | ||
18 | @@ -21,6 +21,7 @@ | ||
19 | |||
20 | #include <map> | ||
21 | #include <memory> | ||
22 | +#include <optional> | ||
23 | #include <string> | ||
24 | |||
25 | #include "perfetto/ext/base/paged_memory.h" | ||
26 | -- | ||
27 | 2.43.0 | ||
28 | |||