summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2020-03-18 11:22:14 +0800
committerKhem Raj <raj.khem@gmail.com>2020-03-18 15:33:49 -0700
commita12ce6d446f0dbf1367227e8606394248a136f87 (patch)
tree479756048efd7afe9b46826b8cac3e453dacc322 /meta-oe
parent43f1485e21ebde03502f12500f66933b15fee50c (diff)
downloadmeta-openembedded-a12ce6d446f0dbf1367227e8606394248a136f87.tar.gz
doxygen-native: fix compile error
It fails to compile doxygen-native when /usr/bin/python is a link to python3 on build host: | Failed to import the site module | Traceback (most recent call last): | File "/usr/lib64/python3.6/site.py", line 564, in <module> | main() | File "/usr/lib64/python3.6/site.py", line 550, in main | known_paths = addusersitepackages(known_paths) | File "/usr/lib64/python3.6/site.py", line 282, in addusersitepackages | user_site = getusersitepackages() | File "/usr/lib64/python3.6/site.py", line 258, in getusersitepackages | user_base = getuserbase() # this will also set USER_BASE | File "/usr/lib64/python3.6/site.py", line 248, in getuserbase | USER_BASE = get_config_var('userbase') | File "/usr/lib64/python3.6/sysconfig.py", line 604, in get_config_var | return get_config_vars().get(name) | File "/usr/lib64/python3.6/sysconfig.py", line 553, in get_config_vars | _init_posix(_CONFIG_VARS) | File "/usr/lib64/python3.6/sysconfig.py", line 424, in _init_posix | _temp = __import__(name, globals(), locals(), ['build_time_vars'], 0) | ModuleNotFoundError: No module named '_sysconfigdata' Replace find_package PythonInterp with Python3 to fix this issue that it uses python3 from python3-native. And it also replaces the result variable PYTHON_EXECUTABLE with Python3_EXECUTABLE. This patch is only needded by doxygen-native. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch433
-rw-r--r--meta-oe/recipes-devtools/doxygen/doxygen_1.8.17.bb1
2 files changed, 434 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch b/meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch
new file mode 100644
index 000000000..a9650c232
--- /dev/null
+++ b/meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch
@@ -0,0 +1,433 @@
1It fails to compile doxygen-native when /usr/bin/python is a link to python3 on
2build host:
3
4| Failed to import the site module
5| Traceback (most recent call last):
6| File "/usr/lib64/python3.6/site.py", line 564, in <module>
7| main()
8| File "/usr/lib64/python3.6/site.py", line 550, in main
9| known_paths = addusersitepackages(known_paths)
10| File "/usr/lib64/python3.6/site.py", line 282, in addusersitepackages
11| user_site = getusersitepackages()
12| File "/usr/lib64/python3.6/site.py", line 258, in getusersitepackages
13| user_base = getuserbase() # this will also set USER_BASE
14| File "/usr/lib64/python3.6/site.py", line 248, in getuserbase
15| USER_BASE = get_config_var('userbase')
16| File "/usr/lib64/python3.6/sysconfig.py", line 604, in get_config_var
17| return get_config_vars().get(name)
18| File "/usr/lib64/python3.6/sysconfig.py", line 553, in get_config_vars
19| _init_posix(_CONFIG_VARS)
20| File "/usr/lib64/python3.6/sysconfig.py", line 424, in _init_posix
21| _temp = __import__(name, globals(), locals(), ['build_time_vars'], 0)
22| ModuleNotFoundError: No module named '_sysconfigdata'
23
24Replace find_package PythonInterp with Python3 to fix this issue that
25it uses python3 from python3-native. And it also replaces the result
26variable PYTHON_EXECUTABLE with Python3_EXECUTABLE.
27
28This patch is only needded by doxygen-native.
29
30Upstream-Status: Inappropriate[oe specific]
31
32Signed-off-by: Kai Kang <kai.kang@windriver.com>
33---
34diff --git a/CMakeLists.txt b/CMakeLists.txt
35index 969ae58..604400f 100644
36--- a/CMakeLists.txt
37+++ b/CMakeLists.txt
38@@ -93,7 +93,7 @@ else ()
39 endif ()
40
41 find_program(DOT NAMES dot)
42-find_package(PythonInterp REQUIRED)
43+find_package(Python3 REQUIRED)
44 find_package(FLEX REQUIRED)
45 find_package(BISON REQUIRED)
46 if (BISON_VERSION VERSION_LESS 2.7)
47diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
48index 6aacd8b..fa197e9 100644
49--- a/addon/doxywizard/CMakeLists.txt
50+++ b/addon/doxywizard/CMakeLists.txt
51@@ -58,7 +58,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/settings.h PROPERTIES GENERA
52
53 # generate version.cpp
54 add_custom_command(
55- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/version.py ${VERSION} > ${GENERATED_SRC_WIZARD}/version.cpp
56+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/version.py ${VERSION} > ${GENERATED_SRC_WIZARD}/version.cpp
57 DEPENDS ${CMAKE_SOURCE_DIR}/VERSION ${CMAKE_SOURCE_DIR}/src/version.py
58 OUTPUT ${GENERATED_SRC_WIZARD}/version.cpp
59 )
60@@ -66,7 +66,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/version.cpp PROPERTIES GENER
61
62 # generate configdoc.cpp
63 add_custom_command(
64-COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -wiz ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC_WIZARD}/configdoc.cpp
65+COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -wiz ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC_WIZARD}/configdoc.cpp
66 OUTPUT ${GENERATED_SRC_WIZARD}/configdoc.cpp
67 )
68 set_source_files_properties(${GENERATED_SRC_WIZARD}/configdoc.cpp PROPERTIES GENERATED 1)
69@@ -74,7 +74,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/configdoc.cpp PROPERTIES GEN
70 set(LEX_FILES config_doxyw)
71 foreach(lex_file ${LEX_FILES})
72 add_custom_command(
73- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/addon/doxywizard/${lex_file}.l > ${GENERATED_SRC_WIZARD}/${lex_file}.l.h
74+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/addon/doxywizard/${lex_file}.l > ${GENERATED_SRC_WIZARD}/${lex_file}.l.h
75 DEPENDS ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/addon/doxywizard/${lex_file}.l
76 OUTPUT ${GENERATED_SRC_WIZARD}/${lex_file}.l.h
77 )
78diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
79index 032c16a..332f1b2 100644
80--- a/doc/CMakeLists.txt
81+++ b/doc/CMakeLists.txt
82@@ -132,7 +132,7 @@ configure_file(${CMAKE_SOURCE_DIR}/doc/doxyindexer.1 ${PROJECT_BINARY_DIR}/
83
84 # doc/language.doc (see tag Doxyfile:INPUT)
85 add_custom_command(
86- COMMAND ${PYTHON_EXECUTABLE} translator.py ${CMAKE_SOURCE_DIR}
87+ COMMAND ${Python3_EXECUTABLE} translator.py ${CMAKE_SOURCE_DIR}
88 DEPENDS ${PROJECT_BINARY_DIR}/doc/maintainers.txt ${PROJECT_BINARY_DIR}/doc/language.tpl ${PROJECT_BINARY_DIR}/doc/translator.py
89 OUTPUT language.doc
90 WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/doc
91@@ -141,7 +141,7 @@ set_source_files_properties(language.doc PROPERTIES GENERATED 1)
92
93 # doc/config.doc (see tag Doxyfile:INPUT)
94 add_custom_command(
95- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/src/configgen.py -doc ${TOP}/src/config.xml > config.doc
96+ COMMAND ${Python3_EXECUTABLE} ${TOP}/src/configgen.py -doc ${TOP}/src/config.xml > config.doc
97 DEPENDS ${TOP}/src/config.xml ${TOP}/src/configgen.py
98 OUTPUT config.doc
99 WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/doc/
100@@ -192,7 +192,7 @@ add_custom_target(docs_chm
101 COMMAND ${CMAKE_COMMAND} -E echo " for file in files:" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py
102 COMMAND ${CMAKE_COMMAND} -E echo " if file.endswith('.html') or file.endswith('.png') or file.endswith('.css') or file.endswith('.gif'):" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py
103 COMMAND ${CMAKE_COMMAND} -E echo " print(os.path.join(root, file))" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py
104- COMMAND ${CMAKE_COMMAND} -E chdir ${PROJECT_BINARY_DIR}/chm ${PYTHON_EXECUTABLE} ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual.hhp
105+ COMMAND ${CMAKE_COMMAND} -E chdir ${PROJECT_BINARY_DIR}/chm ${Python3_EXECUTABLE} ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual.hhp
106 COMMAND ${CMAKE_COMMAND} -E chdir ${PROJECT_BINARY_DIR}/chm "${HTML_HELP_COMPILER}" doxygen_manual.hhp || echo > nul
107 COMMAND ${CMAKE_COMMAND} -E rename ${PROJECT_BINARY_DIR}/chm/index.chm ${PROJECT_BINARY_DIR}/chm/doxygen_manual.chm
108 DEPENDS ${PROJECT_BINARY_DIR}/doc/language.doc ${PROJECT_BINARY_DIR}/doc/config.doc
109diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
110index 967f3d4..a8d1aad 100644
111--- a/examples/CMakeLists.txt
112+++ b/examples/CMakeLists.txt
113@@ -52,196 +52,196 @@ add_custom_target(examples
114
115 add_custom_command(
116 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen class.cfg
117- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/class/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/class/latex/refman_doc.tex
118+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/class/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/class/latex/refman_doc.tex
119 DEPENDS doxygen class.h class.cfg ${TOP}/examples/strip_example.py
120 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/class/html/index.html ${PROJECT_BINARY_DIR}/html/examples/class/latex/refman_doc.tex
121 )
122
123 add_custom_command(
124 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen define.cfg
125- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/define/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/define/latex/refman_doc.tex
126+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/define/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/define/latex/refman_doc.tex
127 DEPENDS doxygen define.h define.cfg ${TOP}/examples/strip_example.py
128 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/define/html/index.html ${PROJECT_BINARY_DIR}/html/examples/define/latex/refman_doc.tex
129 )
130
131 add_custom_command(
132 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen enum.cfg
133- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/enum/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/enum/latex/refman_doc.tex
134+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/enum/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/enum/latex/refman_doc.tex
135 DEPENDS doxygen enum.h enum.cfg ${TOP}/examples/strip_example.py
136 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/enum/html/index.html ${PROJECT_BINARY_DIR}/html/examples/enum/latex/refman_doc.tex
137 )
138
139 add_custom_command(
140 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen file.cfg
141- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/file/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/file/latex/refman_doc.tex
142+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/file/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/file/latex/refman_doc.tex
143 DEPENDS doxygen file.h file.cfg ${TOP}/examples/strip_example.py
144 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/file/html/index.html ${PROJECT_BINARY_DIR}/html/examples/file/latex/refman_doc.tex
145 )
146
147 add_custom_command(
148 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen func.cfg
149- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/func/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/func/latex/refman_doc.tex
150+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/func/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/func/latex/refman_doc.tex
151 DEPENDS doxygen func.h func.cfg ${TOP}/examples/strip_example.py
152 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/func/html/index.html ${PROJECT_BINARY_DIR}/html/examples/func/latex/refman_doc.tex
153 )
154
155 add_custom_command(
156 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen javadoc-banner.cfg
157- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/javadoc-banner/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/javadoc-banner/latex/refman_doc.tex
158+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/javadoc-banner/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/javadoc-banner/latex/refman_doc.tex
159 DEPENDS doxygen javadoc-banner.h javadoc-banner.cfg ${TOP}/examples/strip_example.py
160 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/javadoc-banner/html/index.html ${PROJECT_BINARY_DIR}/html/examples/javadoc-banner/latex/refman_doc.tex
161 )
162
163 add_custom_command(
164 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen page.cfg
165- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/page/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/page/latex/refman_doc.tex
166+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/page/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/page/latex/refman_doc.tex
167 DEPENDS doxygen page.doc page.cfg ${TOP}/examples/strip_example.py
168 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/page/html/index.html ${PROJECT_BINARY_DIR}/html/examples/page/latex/refman_doc.tex
169 )
170
171 add_custom_command(
172 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen relates.cfg
173- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/relates/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/relates/latex/refman_doc.tex
174+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/relates/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/relates/latex/refman_doc.tex
175 DEPENDS doxygen relates.cpp relates.cfg ${TOP}/examples/strip_example.py
176 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/relates/html/index.html ${PROJECT_BINARY_DIR}/html/examples/relates/latex/refman_doc.tex
177 )
178
179 add_custom_command(
180 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen author.cfg
181- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/author/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/author/latex/refman_doc.tex
182+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/author/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/author/latex/refman_doc.tex
183 DEPENDS doxygen author.cpp author.cfg ${TOP}/examples/strip_example.py
184 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/author/html/index.html ${PROJECT_BINARY_DIR}/html/examples/author/latex/refman_doc.tex
185 )
186
187 add_custom_command(
188 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen par.cfg
189- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/par/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/par/latex/refman_doc.tex
190+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/par/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/par/latex/refman_doc.tex
191 DEPENDS doxygen par.cpp par.cfg ${TOP}/examples/strip_example.py
192 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/par/html/index.html ${PROJECT_BINARY_DIR}/html/examples/par/latex/refman_doc.tex
193 )
194
195 add_custom_command(
196 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen overload.cfg
197- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/overload/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/overload/latex/refman_doc.tex
198+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/overload/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/overload/latex/refman_doc.tex
199 DEPENDS doxygen overload.cpp overload.cfg ${TOP}/examples/strip_example.py
200 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/overload/html/index.html ${PROJECT_BINARY_DIR}/html/examples/overload/latex/refman_doc.tex
201 )
202
203 add_custom_command(
204 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen example.cfg
205- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/example/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/example/latex/refman_doc.tex
206+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/example/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/example/latex/refman_doc.tex
207 DEPENDS doxygen example.cpp example_test.cpp example.cfg ${TOP}/examples/strip_example.py
208 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/example/html/index.html ${PROJECT_BINARY_DIR}/html/examples/example/latex/refman_doc.tex
209 )
210
211 add_custom_command(
212 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen include.cfg
213- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/include/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/include/latex/refman_doc.tex
214+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/include/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/include/latex/refman_doc.tex
215 DEPENDS doxygen include.cpp include_test.cpp include.cfg ${TOP}/examples/strip_example.py
216 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/include/html/index.html ${PROJECT_BINARY_DIR}/html/examples/include/latex/refman_doc.tex
217 )
218
219 add_custom_command(
220 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen qtstyle.cfg
221- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/qtstyle/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/qtstyle/latex/refman_doc.tex
222+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/qtstyle/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/qtstyle/latex/refman_doc.tex
223 DEPENDS doxygen qtstyle.cpp qtstyle.cfg ${TOP}/examples/strip_example.py
224 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/qtstyle/html/index.html ${PROJECT_BINARY_DIR}/html/examples/qtstyle/latex/refman_doc.tex
225 )
226
227 add_custom_command(
228 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen jdstyle.cfg
229- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/jdstyle/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/jdstyle/latex/refman_doc.tex
230+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/jdstyle/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/jdstyle/latex/refman_doc.tex
231 DEPENDS doxygen jdstyle.cpp jdstyle.cfg ${TOP}/examples/strip_example.py
232 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/jdstyle/html/index.html ${PROJECT_BINARY_DIR}/html/examples/jdstyle/latex/refman_doc.tex
233 )
234
235 add_custom_command(
236 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen structcmd.cfg
237- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/structcmd/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/structcmd/latex/refman_doc.tex
238+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/structcmd/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/structcmd/latex/refman_doc.tex
239 DEPENDS doxygen structcmd.h structcmd.cfg ${TOP}/examples/strip_example.py
240 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/structcmd/html/index.html ${PROJECT_BINARY_DIR}/html/examples/structcmd/latex/refman_doc.tex
241 )
242
243 add_custom_command(
244 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen autolink.cfg
245- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/autolink/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/autolink/latex/refman_doc.tex
246+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/autolink/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/autolink/latex/refman_doc.tex
247 DEPENDS doxygen autolink.cpp autolink.cfg ${TOP}/examples/strip_example.py
248 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/autolink/html/index.html ${PROJECT_BINARY_DIR}/html/examples/autolink/latex/refman_doc.tex
249 )
250
251 add_custom_command(
252 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen tag.cfg
253- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/tag/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/tag/latex/refman_doc.tex
254+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/tag/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/tag/latex/refman_doc.tex
255 DEPENDS doxygen tag.cpp tag.cfg ${PROJECT_BINARY_DIR}/html/examples/example/html/index.html ${TOP}/examples/strip_example.py
256 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/tag/html/index.html ${PROJECT_BINARY_DIR}/html/examples/tag/latex/refman_doc.tex
257 )
258
259 add_custom_command(
260 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen restypedef.cfg
261- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/restypedef/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/restypedef/latex/refman_doc.tex
262+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/restypedef/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/restypedef/latex/refman_doc.tex
263 DEPENDS doxygen restypedef.cpp restypedef.cfg ${TOP}/examples/strip_example.py
264 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/restypedef/html/index.html ${PROJECT_BINARY_DIR}/html/examples/restypedef/latex/refman_doc.tex
265 )
266
267 add_custom_command(
268 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen afterdoc.cfg
269- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/afterdoc/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/afterdoc/latex/refman_doc.tex
270+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/afterdoc/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/afterdoc/latex/refman_doc.tex
271 DEPENDS doxygen afterdoc.h afterdoc.cfg ${TOP}/examples/strip_example.py
272 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/afterdoc/html/index.html ${PROJECT_BINARY_DIR}/html/examples/afterdoc/latex/refman_doc.tex
273 )
274
275 add_custom_command(
276 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen templ.cfg
277- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/template/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/template/latex/refman_doc.tex
278+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/template/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/template/latex/refman_doc.tex
279 DEPENDS doxygen templ.cpp templ.cfg ${TOP}/examples/strip_example.py
280 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/template/html/index.html ${PROJECT_BINARY_DIR}/html/examples/template/latex/refman_doc.tex
281 )
282
283 add_custom_command(
284 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen group.cfg
285- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/group/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/group/latex/refman_doc.tex
286+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/group/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/group/latex/refman_doc.tex
287 DEPENDS doxygen group.cpp group.cfg ${TOP}/examples/strip_example.py
288 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/group/html/index.html ${PROJECT_BINARY_DIR}/html/examples/group/latex/refman_doc.tex
289 )
290
291 add_custom_command(
292 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen memgrp.cfg
293- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/memgrp/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/memgrp/latex/refman_doc.tex
294+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/memgrp/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/memgrp/latex/refman_doc.tex
295 DEPENDS doxygen memgrp.cpp memgrp.cfg ${TOP}/examples/strip_example.py
296 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/memgrp/html/index.html ${PROJECT_BINARY_DIR}/html/examples/memgrp/latex/refman_doc.tex
297 )
298
299 add_custom_command(
300 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen pyexample.cfg
301- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/pyexample/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/pyexample/latex/refman_doc.tex
302+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/pyexample/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/pyexample/latex/refman_doc.tex
303 DEPENDS doxygen pyexample.py pyexample.cfg ${TOP}/examples/strip_example.py
304 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/pyexample/html/index.html ${PROJECT_BINARY_DIR}/html/examples/pyexample/latex/refman_doc.tex
305 )
306
307 add_custom_command(
308 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen tclexample.cfg
309- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/tclexample/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/tclexample/latex/refman_doc.tex
310+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/tclexample/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/tclexample/latex/refman_doc.tex
311 DEPENDS doxygen tclexample.tcl tclexample.cfg ${TOP}/examples/strip_example.py
312 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/tclexample/html/index.html ${PROJECT_BINARY_DIR}/html/examples/tclexample/latex/refman_doc.tex
313 )
314
315 add_custom_command(
316 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen mux.cfg
317- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/mux/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/mux/latex/refman_doc.tex
318+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/mux/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/mux/latex/refman_doc.tex
319 DEPENDS doxygen mux.vhdl mux.cfg ${TOP}/examples/strip_example.py
320 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/mux/html/index.html ${PROJECT_BINARY_DIR}/html/examples/mux/latex/refman_doc.tex
321 )
322
323 add_custom_command(
324 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen manual.cfg
325- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/manual/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/manual/latex/refman_doc.tex
326+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/manual/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/manual/latex/refman_doc.tex
327 DEPENDS doxygen manual.c manual.cfg ${TOP}/examples/strip_example.py
328 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/manual/html/index.html ${PROJECT_BINARY_DIR}/html/examples/manual/latex/refman_doc.tex
329 )
330
331 add_custom_command(
332 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen docstring.cfg
333- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/docstring/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/docstring/latex/refman_doc.tex
334+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/docstring/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/docstring/latex/refman_doc.tex
335 DEPENDS doxygen docstring.py docstring.cfg ${TOP}/examples/strip_example.py
336 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/docstring/html/index.html ${PROJECT_BINARY_DIR}/html/examples/docstring/latex/refman_doc.tex
337 )
338@@ -249,7 +249,7 @@ add_custom_command(
339 if (DOT)
340 add_custom_command(
341 COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen diagrams.cfg
342- COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/diagrams/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/diagrams/latex/refman_doc.tex
343+ COMMAND ${Python3_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/diagrams/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/diagrams/latex/refman_doc.tex
344 DEPENDS doxygen diagrams_a.h diagrams_b.h diagrams_c.h diagrams_d.h diagrams_e.h diagrams.cfg ${TOP}/examples/strip_example.py
345 OUTPUT ${PROJECT_BINARY_DIR}/html/examples/diagrams/html/index.html ${PROJECT_BINARY_DIR}/html/examples/diagrams/latex/refman_doc.tex
346 )
347diff --git a/libmscgen/CMakeLists.txt b/libmscgen/CMakeLists.txt
348index 079fcfc..e6d86f6 100644
349--- a/libmscgen/CMakeLists.txt
350+++ b/libmscgen/CMakeLists.txt
351@@ -7,7 +7,7 @@ include_directories(
352 set(LEX_FILES mscgen_lexer)
353 foreach(lex_file ${LEX_FILES})
354 add_custom_command(
355- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/libmscgen/${lex_file}.l > ${GENERATED_SRC}/${lex_file}.l.h
356+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/libmscgen/${lex_file}.l > ${GENERATED_SRC}/${lex_file}.l.h
357 DEPENDS ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/libmscgen/${lex_file}.l
358 OUTPUT ${GENERATED_SRC}/${lex_file}.l.h
359 )
360diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
361index 23460d0..58f679a 100644
362--- a/src/CMakeLists.txt
363+++ b/src/CMakeLists.txt
364@@ -35,7 +35,7 @@ set_source_files_properties(${GENERATED_SRC}/settings.h PROPERTIES GENERATED 1)
365
366 # configvalues.h
367 add_custom_command(
368- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -maph ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC}/configvalues.h
369+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -maph ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC}/configvalues.h
370 DEPENDS ${CMAKE_SOURCE_DIR}/src/config.xml ${CMAKE_SOURCE_DIR}/src/configgen.py
371 OUTPUT ${GENERATED_SRC}/configvalues.h
372 )
373@@ -47,7 +47,7 @@ add_custom_target(
374
375 # configvalues.cpp
376 add_custom_command(
377- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -maps ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC}/configvalues.cpp
378+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -maps ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC}/configvalues.cpp
379 DEPENDS ${CMAKE_SOURCE_DIR}/src/config.xml ${CMAKE_SOURCE_DIR}/src/configgen.py
380 OUTPUT ${GENERATED_SRC}/configvalues.cpp
381 )
382@@ -55,7 +55,7 @@ set_source_files_properties(${GENERATED_SRC}/configvalues.cpp PROPERTIES GENERAT
383
384 # configoptions.cpp
385 add_custom_command(
386- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -cpp ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC}/configoptions.cpp
387+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -cpp ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC}/configoptions.cpp
388 DEPENDS ${CMAKE_SOURCE_DIR}/src/config.xml ${CMAKE_SOURCE_DIR}/src/configgen.py
389 OUTPUT ${GENERATED_SRC}/configoptions.cpp
390 )
391@@ -86,7 +86,7 @@ file(GLOB RESOURCES ${CMAKE_SOURCE_DIR}/templates/*/*)
392 # resources.cpp
393 add_custom_command(
394 COMMENT "Generating ${GENERATED_SRC}/resources.cpp"
395- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/res2cc_cmd.py ${CMAKE_SOURCE_DIR}/templates ${GENERATED_SRC}/resources.cpp
396+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/res2cc_cmd.py ${CMAKE_SOURCE_DIR}/templates ${GENERATED_SRC}/resources.cpp
397 DEPENDS ${RESOURCES}
398 OUTPUT ${GENERATED_SRC}/resources.cpp
399 )
400@@ -94,7 +94,7 @@ set_source_files_properties(${GENERATED_SRC}/resources.cpp PROPERTIES GENERATED
401
402 # layout_default.xml
403 add_custom_command(
404- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/to_c_cmd.py < ${CMAKE_SOURCE_DIR}/src/layout_default.xml > ${GENERATED_SRC}/layout_default.xml.h
405+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/to_c_cmd.py < ${CMAKE_SOURCE_DIR}/src/layout_default.xml > ${GENERATED_SRC}/layout_default.xml.h
406 DEPENDS ${CMAKE_SOURCE_DIR}/src/layout_default.xml
407 OUTPUT ${GENERATED_SRC}/layout_default.xml.h
408 )
409@@ -124,7 +124,7 @@ foreach(lex_file ${LEX_FILES})
410 set(LEX_FILES_H ${LEX_FILES_H} " " ${GENERATED_SRC}/${lex_file}.l.h CACHE INTERNAL "Stores generated files")
411 set(LEX_FILES_CPP ${LEX_FILES_CPP} " " ${GENERATED_SRC}/${lex_file}.cpp CACHE INTERNAL "Stores generated files")
412 add_custom_command(
413- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/src/${lex_file}.l > ${GENERATED_SRC}/${lex_file}.l.h
414+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/src/${lex_file}.l > ${GENERATED_SRC}/${lex_file}.l.h
415 DEPENDS ${CMAKE_SOURCE_DIR}/src/scan_states.py ${CMAKE_SOURCE_DIR}/src/${lex_file}.l
416 OUTPUT ${GENERATED_SRC}/${lex_file}.l.h
417 )
418diff --git a/testing/CMakeLists.txt b/testing/CMakeLists.txt
419index 40cb40b..a301acd 100644
420--- a/testing/CMakeLists.txt
421+++ b/testing/CMakeLists.txt
422@@ -1,9 +1,9 @@
423 add_custom_target(tests
424 COMMENT "Running doxygen tests..."
425- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --doxygen ${PROJECT_BINARY_DIR}/bin/doxygen --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
426+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --doxygen ${PROJECT_BINARY_DIR}/bin/doxygen --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
427 DEPENDS doxygen
428 )
429 add_test(NAME suite
430- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --doxygen $<TARGET_FILE:doxygen> --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
431+ COMMAND ${Python3_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --doxygen $<TARGET_FILE:doxygen> --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
432 )
433
diff --git a/meta-oe/recipes-devtools/doxygen/doxygen_1.8.17.bb b/meta-oe/recipes-devtools/doxygen/doxygen_1.8.17.bb
index 7a4eee32c..45de71826 100644
--- a/meta-oe/recipes-devtools/doxygen/doxygen_1.8.17.bb
+++ b/meta-oe/recipes-devtools/doxygen/doxygen_1.8.17.bb
@@ -9,6 +9,7 @@ DEPENDS = "flex-native bison-native"
9SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.src.tar.gz \ 9SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.src.tar.gz \
10 file://0001-build-don-t-look-for-Iconv.patch \ 10 file://0001-build-don-t-look-for-Iconv.patch \
11" 11"
12SRC_URI_append_class-native = " file://doxygen-native-only-check-python3.patch"
12SRC_URI[md5sum] = "7997a15c73a8bd6d003eaba5c2ee2b47" 13SRC_URI[md5sum] = "7997a15c73a8bd6d003eaba5c2ee2b47"
13SRC_URI[sha256sum] = "2cba988af2d495541cbbe5541b3bee0ee11144dcb23a81eada19f5501fd8b599" 14SRC_URI[sha256sum] = "2cba988af2d495541cbbe5541b3bee0ee11144dcb23a81eada19f5501fd8b599"
14 15