summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-31 10:18:11 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:34 -0700
commit9aed371228fd93c1c3c74ea88746751eb65aaa27 (patch)
treed5734c233f2e6b9f82efd728ca6450bda0d8ab39 /meta-oe
parent1830c04a549b73a8775d883a32c1af19597430a4 (diff)
downloadmeta-openembedded-9aed371228fd93c1c3c74ea88746751eb65aaa27.tar.gz
libutempter: Upgrade to 1.2.2-alt1
License-Update: Whitespace removal [1] Drop glibc assumptions patch its fixed upstream [1] https://git.altlinux.org/people/ldv/packages/libutempter.git?p=libutempter.git;a=blobdiff;f=libutempter/COPYING;h=5522aa5f33e23eb2be04b0c1fe789b609e7961fe;hp=2d2d780e6014b850ca3b8437452e24eba5f96508;hb=10539e43e615225da8351895668e704726ffcb53;hpb=3e657409d46e0571f44970ebcd2c972b60778ec3 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch7
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter/libutempter-remove-glibc-assumption.patch81
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter_1.2.2-alt1.bb (renamed from meta-oe/recipes-support/libutempter/libutempter.bb)8
3 files changed, 4 insertions, 92 deletions
diff --git a/meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch b/meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch
index 8140ea343..00119af11 100644
--- a/meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch
+++ b/meta-oe/recipes-support/libutempter/libutempter/0001-Fix-macro-error.patch
@@ -11,15 +11,13 @@ Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com>
11 iface.c | 9 ++++++++- 11 iface.c | 9 ++++++++-
12 1 file changed, 8 insertions(+), 1 deletion(-) 12 1 file changed, 8 insertions(+), 1 deletion(-)
13 13
14diff --git a/iface.c b/iface.c
15index 5951d81..27793f0 100644
16--- a/iface.c 14--- a/iface.c
17+++ b/iface.c 15+++ b/iface.c
18@@ -43,7 +43,14 @@ 16@@ -43,7 +43,14 @@
19 __result; })) 17 __result; }))
20 #endif 18 #endif
21 19
22-#define UTEMPTER_DEFAULT_PATHNAME LIBEXECDIR "/utempter/utempter" 20-#define UTEMPTER_DEFAULT_PATHNAME LIBEXECDIR "/utempter/utempter"
23+#ifdef LIBEXECDIR 21+#ifdef LIBEXECDIR
24+# define CAT_PATH(DIR1,DIR2) DIR1##DIR2 22+# define CAT_PATH(DIR1,DIR2) DIR1##DIR2
25+# define RAW_UTEMPTER_PATH CAT_PATH(LIBEXECDIR,/utempter/utempter) 23+# define RAW_UTEMPTER_PATH CAT_PATH(LIBEXECDIR,/utempter/utempter)
@@ -31,6 +29,3 @@ index 5951d81..27793f0 100644
31 29
32 static const char *utempter_pathname; 30 static const char *utempter_pathname;
33 static int saved_fd = -1; 31 static int saved_fd = -1;
34--
351.8.3.1
36
diff --git a/meta-oe/recipes-support/libutempter/libutempter/libutempter-remove-glibc-assumption.patch b/meta-oe/recipes-support/libutempter/libutempter/libutempter-remove-glibc-assumption.patch
deleted file mode 100644
index 6ed93355b..000000000
--- a/meta-oe/recipes-support/libutempter/libutempter/libutempter-remove-glibc-assumption.patch
+++ /dev/null
@@ -1,81 +0,0 @@
1diff -Naur libutempter-1.1.6.orig/utempter.c libutempter-1.1.6/utempter.c
2--- libutempter-1.1.6.orig/utempter.c 2010-11-04 13:14:53.000000000 -0400
3+++ libutempter-1.1.6/utempter.c 2014-06-20 16:37:09.762403323 -0400
4@@ -34,13 +34,7 @@
5 #include <sys/stat.h>
6 #include <utmp.h>
7
8-#ifdef __GLIBC__
9 # include <pty.h>
10-#elif defined(__FreeBSD__)
11-# include <libutil.h>
12-#else
13-# error Unsupported platform
14-#endif /* __GLIBC__ || __FreeBSD__ */
15
16 #define DEV_PREFIX "/dev/"
17 #define DEV_PREFIX_LEN (sizeof(DEV_PREFIX)-1)
18@@ -106,17 +100,12 @@
19
20 static int
21 write_uwtmp_record(const char *user, const char *term, const char *host,
22-#ifdef __GLIBC__
23 pid_t pid,
24-#endif
25 int add)
26 {
27 struct utmp ut;
28 struct timeval tv;
29-
30-#ifdef __GLIBC__
31 size_t offset;
32-#endif
33
34 memset(&ut, 0, sizeof(ut));
35
36@@ -128,8 +117,6 @@
37 if (host)
38 strncpy(ut.ut_host, host, sizeof(ut.ut_host));
39
40-#ifdef __GLIBC__
41-
42 offset = (strlen(term) <= sizeof(ut.ut_id)) ? 0 :
43 strlen(term) - sizeof(ut.ut_id);
44 strncpy(ut.ut_id, term + offset, sizeof(ut.ut_id));
45@@ -156,27 +143,6 @@
46
47 (void) updwtmp(_PATH_WTMP, &ut);
48
49-#elif defined(__FreeBSD__)
50-
51- ut.ut_time = tv.tv_sec;
52-
53- if (add)
54- {
55- login(&ut);
56- } else
57- {
58- if (logout(term) != 1)
59- {
60-#ifdef UTEMPTER_DEBUG
61- fprintf(stderr, "utempter: logout: %s\n",
62- strerror(errno));
63-#endif
64- exit(EXIT_FAILURE);
65- }
66- }
67-
68-#endif /* __GLIBC__ || __FreeBSD__ */
69-
70 #ifdef UTEMPTER_DEBUG
71 fprintf(stderr,
72 "utempter: DEBUG: utmp/wtmp record %s for terminal '%s'\n",
73@@ -255,8 +221,6 @@
74 validate_device(device);
75
76 return write_uwtmp_record(pw->pw_name, device + DEV_PREFIX_LEN, host,
77-#ifdef __GLIBC__
78 pid,
79-#endif
80 add);
81 }
diff --git a/meta-oe/recipes-support/libutempter/libutempter.bb b/meta-oe/recipes-support/libutempter/libutempter_1.2.2-alt1.bb
index 5c05271d1..0d2cd135c 100644
--- a/meta-oe/recipes-support/libutempter/libutempter.bb
+++ b/meta-oe/recipes-support/libutempter/libutempter_1.2.2-alt1.bb
@@ -5,16 +5,14 @@ screen and xterm to record user sessions to utmp and wtmp files."
5HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter" 5HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter"
6SECTION = "System Environment/Libraries" 6SECTION = "System Environment/Libraries"
7LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-only & MIT" 7LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-only & MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" 8LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
9 9
10SRCREV = "3ef74fff310f09e2601e241b9f042cd39d591018" 10SRCREV = "63825e2244629d44dae21132b1065d7ecc0491c0"
11PV = "1.1.6-alt2+git${SRCPV}"
12 11
13SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git;branch=master \ 12SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git;branch=master \
14 file://0001-Fix-macro-error.patch \ 13 file://0001-Fix-macro-error.patch \
15 file://0002-Proper-macro-path-generation.patch \ 14 file://0002-Proper-macro-path-generation.patch \
16 file://libutempter-remove-glibc-assumption.patch \ 15 "
17 "
18 16
19S = "${WORKDIR}/git/${BPN}" 17S = "${WORKDIR}/git/${BPN}"
20 18