diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-06-08 19:56:35 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-06-14 20:25:16 -0700 |
commit | 91e95fede450c56487f34b6096944183dcf06efa (patch) | |
tree | 15fb39eec77cdc6e5c672385f21aa532bac3db3e /meta-oe | |
parent | 4e070b589aad54a3025b8b0ed6e88b1e82a967c8 (diff) | |
download | meta-openembedded-91e95fede450c56487f34b6096944183dcf06efa.tar.gz |
cpprest: Fix build with gcc-8
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.2/0001-disable-more-Werror-warnings.patch | 48 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb | 1 |
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.2/0001-disable-more-Werror-warnings.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.2/0001-disable-more-Werror-warnings.patch new file mode 100644 index 0000000000..febfd5bc96 --- /dev/null +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.2/0001-disable-more-Werror-warnings.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From ee92f84a96a507b0a7a3c54929ce190ee28b4ecd Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Moriarty <amoriarty@fetchrobotics.com> | ||
3 | Date: Wed, 6 Jun 2018 10:38:43 -0700 | ||
4 | Subject: [PATCH] disable more -Werror warnings | ||
5 | |||
6 | gcc-8: -Wno-format-truncation | ||
7 | |||
8 | clang-6: -Wdelete-non-virtual-dtor | ||
9 | clang-6: -Wunused-lambda-capture | ||
10 | |||
11 | removed duplicated: -Wno-reorder | ||
12 | |||
13 | This fixes #778 | ||
14 | |||
15 | Upstream-Status: Pending [https://github.com/Microsoft/cpprestsdk/pull/779] | ||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | Release/CMakeLists.txt | 6 +++--- | ||
19 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
20 | |||
21 | diff --git a/Release/CMakeLists.txt b/Release/CMakeLists.txt | ||
22 | index 1267aff1..fb291ccd 100644 | ||
23 | --- a/Release/CMakeLists.txt | ||
24 | +++ b/Release/CMakeLists.txt | ||
25 | @@ -166,12 +166,12 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR IOS) | ||
26 | set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-attributes -Wno-pointer-arith") | ||
27 | elseif(CMAKE_SYSTEM_NAME MATCHES "Linux") | ||
28 | set(WARNINGS -Wall -Wextra -Wcast-qual -Wconversion -Wformat=2 -Winit-self -Winvalid-pch -Wmissing-format-attribute -Wmissing-include-dirs -Wpacked -Wredundant-decls) | ||
29 | - set(LINUX_SUPPRESSIONS -Wno-overloaded-virtual -Wno-sign-conversion -Wno-deprecated -Wno-unknown-pragmas -Wno-reorder -Wno-char-subscripts -Wno-switch -Wno-unused-parameter -Wno-unused-variable -Wno-deprecated -Wno-unused-value -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-unused-function -Wno-sign-compare -Wno-shorten-64-to-32 -Wno-reorder -Wno-unused-local-typedefs) | ||
30 | + set(LINUX_SUPPRESSIONS -Wno-overloaded-virtual -Wno-sign-conversion -Wno-deprecated -Wno-unknown-pragmas -Wno-reorder -Wno-char-subscripts -Wno-switch -Wno-unused-parameter -Wno-unused-variable -Wno-deprecated -Wno-unused-value -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-unused-function -Wno-sign-compare -Wno-shorten-64-to-32 -Wno-unused-local-typedefs -Wno-delete-non-virtual-dtor -Wno-unused-lambda-capture) | ||
31 | set(WARNINGS ${WARNINGS} ${LINUX_SUPPRESSIONS}) | ||
32 | set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-return-type-c-linkage -Wno-unneeded-internal-declaration") | ||
33 | else() | ||
34 | set(WARNINGS -Wall -Wextra -Wcast-qual -Wconversion -Wformat=2 -Winit-self -Winvalid-pch -Wmissing-format-attribute -Wmissing-include-dirs -Wpacked -Wredundant-decls) | ||
35 | - set(OSX_SUPPRESSIONS -Wno-overloaded-virtual -Wno-sign-conversion -Wno-deprecated -Wno-unknown-pragmas -Wno-reorder -Wno-char-subscripts -Wno-switch -Wno-unused-parameter -Wno-unused-variable -Wno-deprecated -Wno-unused-value -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-unused-function -Wno-sign-compare -Wno-shorten-64-to-32 -Wno-reorder -Wno-unused-local-typedefs) | ||
36 | + set(OSX_SUPPRESSIONS -Wno-overloaded-virtual -Wno-sign-conversion -Wno-deprecated -Wno-unknown-pragmas -Wno-reorder -Wno-char-subscripts -Wno-switch -Wno-unused-parameter -Wno-unused-variable -Wno-deprecated -Wno-unused-value -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-unused-function -Wno-sign-compare -Wno-shorten-64-to-32 -Wno-unused-local-typedefs -Wno-delete-non-virtual-dtor -Wno-unused-lambda-capture) | ||
37 | set(WARNINGS ${WARNINGS} ${OSX_SUPPRESSIONS}) | ||
38 | |||
39 | set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++ -Wno-return-type-c-linkage -Wno-unneeded-internal-declaration") | ||
40 | @@ -184,7 +184,7 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR IOS) | ||
41 | elseif(CMAKE_CXX_COMPILER_ID MATCHES "GNU") | ||
42 | message("-- Setting gcc options") | ||
43 | |||
44 | - set(WARNINGS -Wall -Wextra -Wunused-parameter -Wcast-align -Wcast-qual -Wconversion -Wformat=2 -Winit-self -Winvalid-pch -Wmissing-format-attribute -Wmissing-include-dirs -Wpacked -Wredundant-decls -Wunreachable-code) | ||
45 | + set(WARNINGS -Wall -Wextra -Wunused-parameter -Wcast-align -Wcast-qual -Wconversion -Wformat=2 -Winit-self -Winvalid-pch -Wmissing-format-attribute -Wmissing-include-dirs -Wpacked -Wredundant-decls -Wunreachable-code -Wno-format-truncation) | ||
46 | set(LD_FLAGS "${LD_FLAGS} -Wl,-z,defs") | ||
47 | |||
48 | set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -fno-strict-aliasing") | ||
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb index 1dbe093bee..fea5d4b2eb 100644 --- a/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb +++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.2.bb | |||
@@ -9,6 +9,7 @@ SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=maste | |||
9 | file://fix-cmake-install.patch \ | 9 | file://fix-cmake-install.patch \ |
10 | file://0001-Fix-a-build-problem-on-Clang.patch;patchdir=.. \ | 10 | file://0001-Fix-a-build-problem-on-Clang.patch;patchdir=.. \ |
11 | file://0002-Define-virtual-destructor.patch;patchdir=.. \ | 11 | file://0002-Define-virtual-destructor.patch;patchdir=.. \ |
12 | file://0001-disable-more-Werror-warnings.patch;patchdir=.. \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | # tag 2.10.2 | 15 | # tag 2.10.2 |